Fuji EF-42 TTL flash pass-through on V6 II & XT-2 not working properly

I have a Fuji EF-42 flash that I placed on top of the Cactus V6 II, mounted on a Fuji X-T2. When using TTL pass-through, the flash is not firing correctly. Only fires full power and does not adjust based on TTL.

If I place the same EF-42 & V6 II on my X-T1 it works as expected.

If I place the EF-42 on the X-T2 it works as expected.

Using latest firmware as of this post.


Comments


  • Using latest firmware as of this post.


    Are you referring to the beta firmware? Or the public one, 1.1.004?

    The X-T2 is still llisted as NOT compatible with the V6 II.
    So with or without the TTL Pass Through it's not going to work on this Fujifilm camera.

    If you are interested in testing the beta firmware, send an email to info@cactus-image.com with subject heading "X-T2" and I will send it to you. ;)

    Thanks!
    Antonio Lao
    Brand Manager
    _____________

    To help us better help you, always state the exact firmware version installed on your Cactus device(s), such as: "1.1.013", "FUJ.1.002", "NIK.A.001", "v.103".

    For the time being, Cactus V6 (MK1) running on firmware version 2.1.001 can be triggered by a V6 II (MK2) running on Multi-brand HSS firmware (e.g. 1.1.013) but not by X-TTL firmware versions:  PEN.A.001 NIK.A.001 OLY.A.001.  No schedule has been released yet for an "A" version firmware on the V6 (MK1). 

    Cactus RF60X / RF60 Firmware versions A04 and A03 currently ONLY works with PEN.A.001 NIK.A.001 and OLY.A.001.  Other "A" version of X-TTL firmware will be released soon. For both Multi-brand HSS and X-TTL firmware versions (FUJ, SIG, SON), install firmware version 103 / 205 on your RF60X / RF60.

    Nikon D750 users please read this thread: 

    Fujifilm EF-X500 users please read this thread:

    Feel free to suggest an improvement or share product ideas. Contact us directly at info@cactus-image.com.  At Cactus, we listen. 
Sign In or Register to comment.