V6IIs with Cactus RF60

I just got the V6IIs and three RF60. 

#  RF60 in SLAVE mode and V6IIs in TX mode
#  All RF60 is on same channel as V6IIs TX
#  RF60 are on group A-B-C, same group are activated on V6IIs TX

when I press on TEST BUTTON/ SHUTTER RELEASE BUTTON on V6IIs all flash fire.
when I press shutter release button on my Sony A6000 all flash fire.
AF-assist light work fine on V6IIs

But I can not change/control the RF60s power from V6IIs?

Does anyone have a solution to this problem?


  • edited October 2016
    Do you have the V6II transmitter set to Power Sync mode? If so, only full power will be available with shutter speeds that exceed the sync-speed.

    The only other problem I can think of is that you are too close to the RF60s when trying to update the power levels. Use the "SHORT" radio range option on the transmitter, if you can get really close the the flashes during shooting.

    As a rule, ensure to have the latest firmware versions on your devices. The Firmware Updater can update both the V6IIs and the RF60.
  • V6IIs transmitter is set to Normal HSS mode.
    I use short radio range on V6IIs transmitter.

    Unfortunately I have not been able to put in the latest firmware on my devices because of the error (DLL file is missing, such as "libusb0.dll") like many other users encountered when they tried to update.

    Could it be a setting in the flash that affect this problem?

  • As long as the flash is in slave mode (S) and the channels match, you should be able to change the power level.

    If you don't have V2.04 yet on your RF60, that's a problem. You'll probably experience reliability issues with older firmware versions.

    Have you tried the Firmware Updater recently? I think Cactus provided a new version of it that solved the DLL issue.

    Uninstall the current Firmware Updater, download the latest version, and install it again. AFAIK, you shouldn't be seeing the DLL error message anymore. If there is still a problem, try to get hold of another computer, as you won't be getting the most out of the RF60 with older firmware versions.

    If you are running a really old firmware version that would probably explain your current problem as well. I'm not a 100% sure, though.
  • Problem solved! 
    I did factory reset on all units(V6IIs & RF60) and after that it was possible to update all units without error code "missing libusb0.dll file"

    Thanks for quick response/reply Class A.

  • Nice!  Thanks for sharing your experience @NIK
    Antonio Lao
    Brand Manager

    To help us better help you, always state the exact firmware version installed on your Cactus device(s), such as: "1.1.013", "NIK.A.001", "v.103", or "A06".

    TTL or HSS not working on Cactus V6 II and V6 IIs? Be sure to check hot shoe connectivity by doing the <CAMERA INFO> check.

    Feel free to suggest an improvement or share product ideas. Contact us directly at info@cactus-image.com.  At Cactus, we listen. 
Sign In or Register to comment.