Cactus V6II not working with Canon speedlite 600ex-RT

It won't work together, maybe it's has something to do with the profiles. You can chose the 600EX but there is no 600EX-RT, I thought it would be the same, but probably it isn't...

The test flash is working fine, it sometimes fires when you make pictures, but with the wrong power or it won't fire the next time...

Really strange. 

My camera is an 5d mark III and a 5d mark IV, it won't work on both camera's.

Is there a solution for this?

Comments

  • Hi wchef,

    I assume you have a V6 II in the hot shoe on your 5D mk II and mk IV.
    Does this V6 II come up with a camera symbol with the letter "C" inside when you turn it on?

    I had this problem with my Fuji camera in the begining, but I finally made it work.
    As long as the flash is the Cactus RF60 it does not matter, but if you work with a TTL flash, the V6 II on the camera must detect the brand of the camera.

    If the V6 II does not correctly detect your camera you can forget everything else.


    Cheers,

    Geir
  • When I set the trigger to TX on the camera I see the camera symbol without an C...
    When I set the camera-system to Canon the flashes do nothing.

    I don't want to use the TTL, I want to set the flash power manually with 1/128 up to 1/1

    But the first problem is that they won't work as it should.


  • I would say that the 5d Mark III or IV would work really fine with cactus???

    Or is the problem the 600EX-RT? 
  • I read something about a release cable, will that fix the problem?!

    http://www.cactus-image.com/community/discussion/818/can-v6-trigger-canon-5d-mark-iii
  • Hi again,

    I don't know if a release cable will help.

    If you get a camera symbol without a letter "C" inside you are not in business and things will not work.
    You absolutely need to see the "C" inside the camera symbol.
    1. Turn on the camera. Half-press the shutter button several times.
    2. Turn on  the V6 II to TX mode while still half-pressing the shutter button.

    With my Fuji X-Pro 2 I have to press the shutter button many times and sometimes even take  a picture before the V6 II puts the letter "F" inside the camera symbol.

    Yes, I understand that you want manual control. That is mainly what Cactus is for. But your flash has to be in TTL mode, not in manual mode. The V6 II transceivers exploit the TTL mode of your flash to give the right dose of light.

    What I experienced with my Fuji camera and non-Cactus flashes (Nikon, Sigma etc) was the the power was always the same (not full power, but not far from).

    As soon as I managed to get the "F" inside the camera symbol on the camera-mounted V6 II, everything works fine.

    On the flash side, make sure you turn on the flash first and then the V6 in RX mode. It should then detect the brand of your flash.

    Good luck and let me know how it goes.


    Cheers,


    Geir 
  • if you are keeping the default settings of auto-detect on the RX units, always follow this order of powering on devices:
    1. Turn on the flash
    2. Set it to TTL mode
    3. Turn on HSS
    4. Turn on the V6 II to RX mode (it will auto-detect the system and apply an AUTO flash profile)

    Hope this helps!

    Antonio Lao
    Brand Manager
    _____________

    To help us better help you, always state the exact firmware version installed on your Cactus device(s), such as: "1.1.013", "FUJ.1.002", "v.103".

    For the time being, Cactus V6 (MK1) running on firmware version 2.1.001 can be triggered by a V6 II (MK2) running on Multi-brand HSS firmware (e.g. 1.1.013) and not by X-TTL firmware versions: PEN.A.001 and OLY.A.001.  No schedule has been released yet. 

    Cactus RF60X / RF60 Firmware versions A01 and A02 currently ONLY works with PEN.A.001 and OLY.A.001.  Other "A" version of X-TTL firmware will be released soon. For both Multi-brand HSS and X-TTL firmware versions (FUJ, SIG, SON), install firmware version 103 / 205 on your RF60X / RF60.

    Cactus RF60 is now an off-camera TTL flash with firmware version 205 or later!

    Metz M400 (for Fujifilm) is now supported on the Cactus V6 II (HSS and TTL).

    Nikon D750 users please read this thread: 

    Fujifilm EF-X500 users please read this thread:

    Feel free to suggest an improvement or share product ideas. Contact us directly at info@cactus-image.com.  At Cactus, we listen. 
  • It works perfect!!! Tnx a lot
  • wchef said:

    It works perfect!!! Tnx a lot

    Cool! 

    Thanks for the update. :)
    Antonio Lao
    Brand Manager
    _____________

    To help us better help you, always state the exact firmware version installed on your Cactus device(s), such as: "1.1.013", "FUJ.1.002", "v.103".

    For the time being, Cactus V6 (MK1) running on firmware version 2.1.001 can be triggered by a V6 II (MK2) running on Multi-brand HSS firmware (e.g. 1.1.013) and not by X-TTL firmware versions: PEN.A.001 and OLY.A.001.  No schedule has been released yet. 

    Cactus RF60X / RF60 Firmware versions A01 and A02 currently ONLY works with PEN.A.001 and OLY.A.001.  Other "A" version of X-TTL firmware will be released soon. For both Multi-brand HSS and X-TTL firmware versions (FUJ, SIG, SON), install firmware version 103 / 205 on your RF60X / RF60.

    Cactus RF60 is now an off-camera TTL flash with firmware version 205 or later!

    Metz M400 (for Fujifilm) is now supported on the Cactus V6 II (HSS and TTL).

    Nikon D750 users please read this thread: 

    Fujifilm EF-X500 users please read this thread:

    Feel free to suggest an improvement or share product ideas. Contact us directly at info@cactus-image.com.  At Cactus, we listen. 
Sign In or Register to comment.