Cannot get out of TTL mode after updating V6 II

Firmware updater V1.08


V6 Mk II 

Firmware 1.1.006 


RF60 

Firmware V204


Fuji X-Pro2 

Firmware 2.01


I recently updated the V6 to the latest firmware to try out HSS, but i’ve found that at 250 shutter speed, on continuos high 8fps, every other shot is underpowered by the flash. I’m also now unable to get out of TTL mode on the camera, although this isn’t too troubling because i’m somehow STILL able to adjust the power of the RF60 manually via the V6 (I thought TTL didn’t allow manual intervention?)


As you can see i’m a confused beginner, not used to flash yet, but before the firmware update I was quite happy with how the setup performed; I’m likely to be missing something very obvious.

Comments

  • Hello @fooltech,
    .... I’m also now unable to get out of TTL mode on the camera, although this isn’t too troubling because i’m somehow STILL able to adjust the power of the RF60 manually via the V6 (I thought TTL didn’t allow manual intervention?)


    From our understanding, when camera displays "TTL" icon it simply means that a TTL-compatible flash device is detected on camera hot shoe.

    So it could be that on X-Pro2 firmware version v2.01 is no longer able to recognize the V6 II as a compatiblel flash device.

    I will report your other findings to R&D in the meantime.

    Thank you.
    Antonio Lao
    Brand Manager
    _____________

    To help us better help you, always state the exact firmware version installed on your Cactus device(s), such as: "1.1.013", "NIK.A.001", "v.103", or "A06".

    TTL or HSS not working on Cactus V6 II and V6 IIs? Be sure to check hot shoe connectivity by doing the <CAMERA INFO> check.

    Feel free to suggest an improvement or share product ideas. Contact us directly at info@cactus-image.com.  At Cactus, we listen. 
Sign In or Register to comment.