Pentax 645z with Canon 600EXRT via cactus V6-II

Hi, 

trying to get my canon speedlights working in hss mode with my 645z. 
Up to 1/125 everything works fine, including being able to change zoom on camera flash. 

Beyond 1/125 the pentax does trigger the flash, but does not synch properly, either the whole image is dark or, occasionally a big black bar is coveing most of the image. 

Both systems (pentax as camera system, canon as flash system) are properly recognised by the v6-ii on my camera and under my flash. 

Tryed both flash auto detect or manually selecting it (it actually gives a checkmark when I toggle to canon). 

Has anyone managed to get this combination going? 

Thank you for your support.
«1

Comments

  • Hello @darkstar,

    Thanks for reporting the problem. Another user reports similar experience with the Canon 580EXII.

    We will be getting our hands on a 645Z next week so we will find out soon. Please bear with us during this time.

    Thank you.


    Antonio Lao
    Brand Manager
    _____________

    To help us better help you, always state the exact firmware version installed on your Cactus device(s), such as: "1.1.013", "NIK.A.001", "v.103", or "A06".

    TTL or HSS not working on Cactus V6 II and V6 IIs? Be sure to check hot shoe connectivity by doing the <CAMERA INFO> check.

    Feel free to suggest an improvement or share product ideas. Contact us directly at info@cactus-image.com.  At Cactus, we listen. 
  • Hi Antonio, 

    thanks for getting back. 

    Meanwhile I have received a Godox AD360II-C with an X1-C transmitter. 
    Although I read that some people apparently had it working with a 645D, piggy back on the cactus, I haven't been able to do so with the 645Z. 

    Let's see whether you manage to get the 580EXII/600EXRT working in hss with the Z. 

    For now, Happy New Year


  • Happy New Year to you too, @darkstar.
    ... Meanwhile I have received a Godox AD360II-C with an X1-C transmitter.

    You should be able to control and trigger the AD360-II directly using the V6 II, mounted on a V6 II RX unit. So you don't really need the cumbersome setup with X1C.
    ... Although I read that some people apparently had it working with a 645D, piggy back on the cactus, I haven't been able to do so with the 645Z. 



    Are you referring to this?
    http://www.cactus-image.com/community/discussion/comment/3442/#Comment_3442
    Antonio Lao
    Brand Manager
    _____________

    To help us better help you, always state the exact firmware version installed on your Cactus device(s), such as: "1.1.013", "NIK.A.001", "v.103", or "A06".

    TTL or HSS not working on Cactus V6 II and V6 IIs? Be sure to check hot shoe connectivity by doing the <CAMERA INFO> check.

    Feel free to suggest an improvement or share product ideas. Contact us directly at info@cactus-image.com.  At Cactus, we listen. 
  • Hi Antonio, 

    what I am after is hss on my pentax 645z. 

    I have now available. 2x cactusV6-II (HSS), 1 X1T-C, 1x Godox AD360II=C
    (also 2x canon 600EXRT, 1xST-E3-RT)


    -As to your last reply. I tried putting the AD360 on the one of the V6 and triggering
    the other V6 by the camera. 

    hss in this setup is not working (meaning, I didn't get it to work) I tried pretty much all different menu options on the AD360 (ETTL, M, radio, master, slave)

    If you did get this to work, can you tell me the settings ON THE MENU of the AD360, because I am pretty certain I have all other settings correct on the triggers/receivers (camera system Pentax, flash system Canon).

    (but also, the heavy AD360 is a bit wobbly on this setup. To be honest, I prefer having 2 controllers if needed on the camera, and the the flash more steady). 

    At this point I started to have doubts that any wireless hss is possible in combination with the 645z. 


    Can you give me advice as to ANY wireless hss setup with the 645z with my existing flashes, preferably the more powerful AD360. 

    Appreciate your ongoing support. 




  • edited January 2017
    hss in this setup is not working (meaning, I didn't get it to work) I tried pretty much all different menu options on the AD360 (ETTL, M, radio, master, slave)

    If you did get this to work, can you tell me the settings ON THE MENU of the AD360, because I am pretty certain I have all other settings correct on the triggers/receivers (camera system Pentax, flash system Canon).

    The correct setting for the AD360 should be "E-TTL". Poster dedgle got the AD360II-C (or what is most likely a a re-badged version of it) working with the V6II.

    Make sure to turn on the attached flash first and then the (correctly configured) V6II receiver. 

    Have you chosen "Canon" as the flash system on the V6II receiver? The flash system choice on the on-camera transmitter should not matter. The flash system choice on the receiver is important, though. For the flash profile choice on the receiver "AUTO CANON" should be correct but it may not hurt to try other profiles.

    The camera system choice "Pentax" for the on-camera transmitter is correct, but you may want to set it to "AUTO" and see whether the V6II correctly detects your camera. Make sure to keep tapping the shutter button of the 645Z while turning on the on-camera V6II transmitter and check whether the "P" in a camera symbol will show on the V6II to indicate that the camera has been recognised.

    With respect to stacking a trigger like the X1T-C on an on-camera V6II,  people apparently have varied success, depending on which trigger they are using. If  choosing "Canon" as the flash system on the on-camera V6II does not work try choosing the flash system "Nikon". Apparently, some people needed to do the latter to get trigger support for a receiver (the flash system "Manual" would not work for them).

    I hope Cactus can clarify whether the need to choose "Nikon" in some circumstances when "Manual" would be the logical choice still exists in with the latest firmware.

    N.B., what firmware version are you running on your V6II units? Make sure to update to the latest version. Don't forget to first use the button "Check for latest firmware" and select the latest firmware before you press the "Update" button.


  • Hi Class A,

    thank you for your detailed reply. 

    I followed your instructions at verbatim, but had mixed results.
    Nothing consistent. Flash triggers every time, but most of the time does not
    register in image. Sometimes it does if synch below 1/125. 
    At faster than1/125 flash gets triggered but never registers in image. 


    AD360II-C  :Ettl   (hss icon showing)
    with Receiver:  on canon setting

    Transmitter on Pentax 645z:
    shows (P) in camera system. 
    set to Canon in Flash


    Later I tried variations of  flash system on the transmitter while keeping receiver flash system as Canon (C). No reliable results. As above. 



    Most reliable way of triggering the flash appears to be not using the cactus triggers at all:

    X1 on Pentax. Manually controlling output at up to 1/125s. works every time. 


    BUT: no hss in either setup. 







  • We have the 645Z with us right now. Some firmware tweaking is required - we will post an update sometime next week.

    Thanks for your patience during this time.
    Antonio Lao
    Brand Manager
    _____________

    To help us better help you, always state the exact firmware version installed on your Cactus device(s), such as: "1.1.013", "NIK.A.001", "v.103", or "A06".

    TTL or HSS not working on Cactus V6 II and V6 IIs? Be sure to check hot shoe connectivity by doing the <CAMERA INFO> check.

    Feel free to suggest an improvement or share product ideas. Contact us directly at info@cactus-image.com.  At Cactus, we listen. 
  • Hi Antonio, did you come up with any solutions working with the 645z?
  • Hey darkstar,

    Yes we have been testing the 645Z over the past week and so far it appears that a new firmware is required to work with this camera when it is triggering non-Pentax flashes off-camera.  In other words, Pentax has a slightly different settings on the 645Z than other Pentax cameras.

    We shall have the firmware ready within the next couple weeks.

    Thank you for your understanding during this time.
    Antonio Lao
    Brand Manager
    _____________

    To help us better help you, always state the exact firmware version installed on your Cactus device(s), such as: "1.1.013", "NIK.A.001", "v.103", or "A06".

    TTL or HSS not working on Cactus V6 II and V6 IIs? Be sure to check hot shoe connectivity by doing the <CAMERA INFO> check.

    Feel free to suggest an improvement or share product ideas. Contact us directly at info@cactus-image.com.  At Cactus, we listen. 
  • Hi

    I have the Pentax 645Z and the Canon 430exII flash and HSS does not work. I have tried using a shutter release cable and also piggybacking my sky ports but that didn't work. My set up is: Camera pentax, flash Canon profile 430ex Normal HSS. The flash to camera works up to 125 any shutter speed after this does not trigger the flash. I have tried flash on and off the camera and I get the same results. My Cactus firmware version is 1.1.005.  I bought the 2xCactus 6II because I was under the impression from your website that this would work on any Pentax to any flash.  
  • Hi 
    I have now change my set up to the following: Camera = Pentax, flash = Canon, flash profile Yongnuo 568exII. these settings are on both V6II. The flash works in HSS up to 125. Above 125 the pre flash works  but full HSS does not. MY YN568exII  is set to ETTL,  H.  why does the pre flash work and not the flash ?
  • @chickwit, we will soon (in a few days) release a new firmware version to work with the Pentax 645Z.

    Thank you for your understanding during this time.
    Antonio Lao
    Brand Manager
    _____________

    To help us better help you, always state the exact firmware version installed on your Cactus device(s), such as: "1.1.013", "NIK.A.001", "v.103", or "A06".

    TTL or HSS not working on Cactus V6 II and V6 IIs? Be sure to check hot shoe connectivity by doing the <CAMERA INFO> check.

    Feel free to suggest an improvement or share product ideas. Contact us directly at info@cactus-image.com.  At Cactus, we listen. 
  • Good morning

    Any news on the new firmware yet ?
  • Good morning

    Any news on the new firmware yet ?
    Thanks for checking in.

    Sorry we found some more bugs so we decided not to release the udpate yet. We are still doing internal testing right now.

    Available date: T.B.A.
    Antonio Lao
    Brand Manager
    _____________

    To help us better help you, always state the exact firmware version installed on your Cactus device(s), such as: "1.1.013", "NIK.A.001", "v.103", or "A06".

    TTL or HSS not working on Cactus V6 II and V6 IIs? Be sure to check hot shoe connectivity by doing the <CAMERA INFO> check.

    Feel free to suggest an improvement or share product ideas. Contact us directly at info@cactus-image.com.  At Cactus, we listen. 
  • Antonio - any news on this yet?
  • We are doing last bits of testing before releasing it.

    Thanks for your patience, people.
    Antonio Lao
    Brand Manager
    _____________

    To help us better help you, always state the exact firmware version installed on your Cactus device(s), such as: "1.1.013", "NIK.A.001", "v.103", or "A06".

    TTL or HSS not working on Cactus V6 II and V6 IIs? Be sure to check hot shoe connectivity by doing the <CAMERA INFO> check.

    Feel free to suggest an improvement or share product ideas. Contact us directly at info@cactus-image.com.  At Cactus, we listen. 
  • So looking forward to the new firmware. Can't wait shooting 645z beyond its ridiculous sync speed
  • Quick update, we plan to release the new firmware within this week!

    Once we do we shall post an update here on the fourm as well as on social media.

    Thanks all!

    Antonio Lao
    Brand Manager
    _____________

    To help us better help you, always state the exact firmware version installed on your Cactus device(s), such as: "1.1.013", "NIK.A.001", "v.103", or "A06".

    TTL or HSS not working on Cactus V6 II and V6 IIs? Be sure to check hot shoe connectivity by doing the <CAMERA INFO> check.

    Feel free to suggest an improvement or share product ideas. Contact us directly at info@cactus-image.com.  At Cactus, we listen. 
  • thanks for the update!
  • Sorry, this post came after our social media posts :)

    Just in case you've missed it, go get it now, version 1.1.007.

    Antonio Lao
    Brand Manager
    _____________

    To help us better help you, always state the exact firmware version installed on your Cactus device(s), such as: "1.1.013", "NIK.A.001", "v.103", or "A06".

    TTL or HSS not working on Cactus V6 II and V6 IIs? Be sure to check hot shoe connectivity by doing the <CAMERA INFO> check.

    Feel free to suggest an improvement or share product ideas. Contact us directly at info@cactus-image.com.  At Cactus, we listen. 
  • Good morning

    I download the new firmware and just tried the Cactus V6II and the flash would not fire above 1/125.

    My camera is the pentax 645Z and the transmitter was set to:- pentax, flash Canon 430X. The receiver was set to Canon 430X with a off camera flash attached showing high speed sync and Manual. The transmitter still shows TTL passthrough as NO MATCH. I have even bought a cable to attached from the Cactus to the Pentax flash sync socket and with or without I still cannot get over 1/125

    When I used a shutter speed less than and up to 1/125 the flash worked but over 1/125 and nothing. What am I doing wrong ?

  • edited February 2017
    Check the actual firmware version you are running by visiting the respective menu item. It will help troubleshooting, if you post the firmware number you see on the unit here.

    On the transmitter, you don't need to set the flash system. There is no need to set it to "Canon". Only the V6II receiver needs its flash system set to "Canon". You don't need to deal with "TTL pass-through" either. That function is only for mounting a flash on the V6II that is on the camera.

    I suggest to factory reset all units and attempt to let the V6II transmitter (the unit on the camera) detect your camera. To accomplish that, turn on the camera first. Then keep tapping the camera's shutter release button while turning on the V6II transmitter on the camera's hot-shoe. If the transmitter does not display a camera symbol with a small "P" inside it (to show that it detected a Pentax camera), you have a hot-shoe connection issue that you may or may not address by wiggling the V6II in the camera's hot-shoe a bit. You'll have to try the detection procedure again, though.

    Once you have established communication between the V6II and the camera, you should be able to fire the off-camera flash at all shutter speeds. You may then also set the camera system to "Pentax" to skip the detection step. However, I'd first try the automatic detection of the camera system to see whether you can establish transmitter<->camera communication.
  • Good morning

    I have finally got the Pentax 645Z to work with Yongnuo 568EXii flashes for Canon, by setting the TX and RX to see Canon - Yongnuo for the flashes and it works great in HSS. 

    The Canon 430EXii don't work I get a black half way down the image on anything over /125 regardless of what ever i do, including factory reset and every flash and flash profile I can think of. I have checked the flashes back on my Canon camera and they are working in HSS.  

    the setting on the Cactus are: TX Camera = P, flash = C and profile 430exII, RX = Canon 430EXii. 

    I am happy using the Yongnuo with the Pentax645Z so I am now a happy bunny, but I thought I would share the issue with the Canon 430exII.


  • Hey chickwit thanks for sharing the information.  In your setup with 568EXii with cactus does it TTL works with HSS?  On only manual HSS?
  • ...My camera is the pentax 645Z and the transmitter was set to:- pentax, flash Canon 430X. ...
    Since you are using a 645Z, you need to select <TYPE 1> under:

    MENU > Camera & Flash Setup > Custom Setting

    Thanks!

    Antonio Lao
    Brand Manager
    _____________

    To help us better help you, always state the exact firmware version installed on your Cactus device(s), such as: "1.1.013", "NIK.A.001", "v.103", or "A06".

    TTL or HSS not working on Cactus V6 II and V6 IIs? Be sure to check hot shoe connectivity by doing the <CAMERA INFO> check.

    Feel free to suggest an improvement or share product ideas. Contact us directly at info@cactus-image.com.  At Cactus, we listen. 
  • Thanks Antonio!

    I have some Canon 430x already updated the firmware and will try with the 645z and see if it works.
  • Thanks Antonio!

    I have some Canon 430x already updated the firmware and will try with the 645z and see if it works.
    Great! Keep us posted :)
    Antonio Lao
    Brand Manager
    _____________

    To help us better help you, always state the exact firmware version installed on your Cactus device(s), such as: "1.1.013", "NIK.A.001", "v.103", or "A06".

    TTL or HSS not working on Cactus V6 II and V6 IIs? Be sure to check hot shoe connectivity by doing the <CAMERA INFO> check.

    Feel free to suggest an improvement or share product ideas. Contact us directly at info@cactus-image.com.  At Cactus, we listen. 
  • Hey Antonio,

    So I followed your instructions in the camera Cactus V6 II unit the profile is Pentax and Menu for custom settings.

    In the receiver unit the the Flash profile is set to Canon 430ex and the speedlights is just normal. No additional settings were used.

    I am very happy to report that it worked flawlessly!! And without any issues! I got normal HSS without any banding or gradation.

    You guys are awesome!!!!

    I also used the Cactus V6 ii with studio strobes (Speedotron 102 and 103 heads) in full power output.

    Where on the transmitter it was set to Pentax. And the receiver profile was set to manual or Canon/Nikon.

    I stacked or piggy backed another trigger Pocket Wizard on top of the receiver V6 II unit and also got emulated HSS (without pulses)!

    This is because of the long flash duration the Speedotrons. The 102 is reported to be 225th of a second flash duration and the 103 strobe head is 450th or so.

    So any strobes with LONG flash duration will be good to get emulated HSS with the Cactus V6 ii.

    I have a question for this community. Has anyone used Cononmark battery powered strobe the DL 4.0 with the cactus V6 ii and Pentax? Apparently the real measured flash duration for Cononmark may be similar to the Speedotrons at any power output.

    Please share your posts.

    Thanks a million.
  • ....

    I am very happy to report that it worked flawlessly!! And without any issues! I got normal HSS without any banding or gradation.



    You guys are awesome!!!!
    Fantastic news!  Thanks for sharing the test results, Xavier.

    If the DL4.0 has similar flash duration as your other strobes then it's likely going to work too.
    Antonio Lao
    Brand Manager
    _____________

    To help us better help you, always state the exact firmware version installed on your Cactus device(s), such as: "1.1.013", "NIK.A.001", "v.103", or "A06".

    TTL or HSS not working on Cactus V6 II and V6 IIs? Be sure to check hot shoe connectivity by doing the <CAMERA INFO> check.

    Feel free to suggest an improvement or share product ideas. Contact us directly at info@cactus-image.com.  At Cactus, we listen. 
  • After reading this thread, glad getting the 645z in HSS with canon 430exii and 580exii and HSS strobe.

    However, using the the custom setting to " type 1" doesnt work. 

    645z will get occasionally banding, and to solve the problem will be changing the custom settings to "Type 1" and back to "OFF", or change the flash profile o 430ex or 580ex on TX

    Any reason why?

    TX and RX on 1. 1.011

    TX: 
    Camera System = Pentax
    Flash System = Canon
    Custom Setting = OFF
    Flash Profile = 580ex or 430ex

    RX on 430exii or 580exii:
    Auto detect Canon Flash

    RX w/ sync cord to Flashpoint RL-600 strobe:
    Manual Flash
Sign In or Register to comment.