Fuji XT2 problems with SB910 and V6 ll

So everything seems to have paired up nicely. Cactus V6 lI recognises Fuji and HSS synced up. On the RX the unit recognises Nikon.
What I don't see is the TTL icon on the display on the Tx and if I hold the menu button for 2secs I get TTL not compatible(or similar message).
I've removed the spring from the flash shoe.
The unit flashes if I press test button and the power changes on the RX when I change it on the TX but it won't flash when I press the shutter release. Tried factory resets etc.
I really need to get this going for a wedding in a couple of weeks so any help would be most welcome.
Ps could it be a firmware issue with the SB910 currently 7.001 I think?

Comments

  • Solved...I thought Id successfully updated the firmware but on checking for some reason it hadn't updated. All good now. It even works with the spring back in place. 
  • Glad to hear it's working now. And thanks for posting an update, @PaulD.

    Antonio Lao
    Brand Manager
    _____________

    To help us better help you, always state the exact firmware version installed on your Cactus device(s), such as: "1.1.013", "NIK.A.001", "v.103", or "A06".

    TTL or HSS not working on Cactus V6 II and V6 IIs? Be sure to check hot shoe connectivity by doing the <CAMERA INFO> check.

    Feel free to suggest an improvement or share product ideas. Contact us directly at info@cactus-image.com.  At Cactus, we listen. 
Sign In or Register to comment.