V6 II will not auto detect Fujifilm X-E2

V6 II Firmware 1.1.007
Went through factory reset
Hot shoe spring plate removed
V6 II firmly inserted into hot shoe
Turned on camera, press shutter button half way
Turn on V6 II to TX
V6 II attempts to detect flash system, then attempts to detect camera system.
Camera icon still empty when it goes to normal screen of the 4 power settings
Called up status screen by holding down menu button while scrolling - camera icon is still blank/empty

Did this multiple times with variations on how tight the V6 II is tightened down, pushed down, slight rotation to right, etc. Never auto detected Fuji camera system. 

Same result with both V6 II units that I have. 

Without successful detection, flash is never fired when camera shutter is triggered.

Communications with the receiver appears fine since I can remotely change power and zoom. Also, test button on TX will trigger flash at RX. (Nikon SB-700 flash on V6 II in RX)

The same devices work fine with my Nikon D600. Auto detect works on Nikon. HSS works on Nikon using same SB-700 on V6 II in RX.

Also, my older V6s with firmware 2.1.001 work perfectly with the same Fuji X-E2 body, even without the removal of the hot shoe spring clip.

Can you tell what I am doing wrong? Did I miss a step?

Any help is greatly appreciated. Thanks in advance.

William Waung

Comments

  • By the way, my Fuji X-E2 has firmware v 4.01, in case that is relevant.
  • Camera(s) tested that does not support high-speed sync modes on the Cactus V6 II:
      - Fujifilm X-E2 (Updated: July 18, 2016)

  • Thanks basz. I saw that after a night of trying to get it to work. Oh well, such is life. ;-)

    I wonder if the newly announced firmware update for cross platform HSS still has the problem with the X-E2? Sounds like it may be a hardware incompatibility problem that cannot be cured by a firmware update.
  • Yeah new firmware won't cut it unfortunately.

    Let's hope the upcoming X-E3 will work with the V6 II. :)
    Antonio Lao
    Brand Manager
    _____________

    To help us better help you, always state the exact firmware version installed on your Cactus device(s), such as: "1.1.013", "NIK.A.001", "v.103", or "A06".

    TTL or HSS not working on Cactus V6 II and V6 IIs? Be sure to check hot shoe connectivity by doing the <CAMERA INFO> check.

    Feel free to suggest an improvement or share product ideas. Contact us directly at info@cactus-image.com.  At Cactus, we listen. 
Sign In or Register to comment.