Fuji xt2 stuck in ttl mode with cactus v6 ii

Hello all,
Just received 3 cactus v6 II triggers and here is my problem:
With the godox x1tn trigger on the cactus v6ii hotshoe, my xt2 detects everything fine (fuji camera, Nikon flash, auto Nikon flash profile) but for some reason the camera is stuck in ttl mode and doesn't allow to switch it to manual and the camera won't trigger the flash (ad360ii). FYI if I take off the cactus and use only the x1 trigger on the fuji hotshoe everything works perfectly fine up to 1/250 shutter speed.
The reason I got these cactus triggers is to have hss with my fuji xt2 and the godox ad360 and jinbei hd610ttl.
Cheers and I hope someone can help!

Comments

  • What happens if you take away the Godox transmitter?

    Since you got 3 V6 II transceivers I assume you have one on the camera, and the other two connected to your AD360II? I believe you could mount the flash directly on the V6 II and have it auto-detecting their flash system, Canon or Nikon? So the V6 II TX unit can adjust the power outputs of the AD360II and you no longer need Godox own transmitter.
    Antonio Lao
    Brand Manager
    _____________

    To help us better help you, always state the exact firmware version installed on your Cactus device(s), such as: "1.1.013", "NIK.A.001", "v.103", or "A06".

    TTL or HSS not working on Cactus V6 II and V6 IIs? Be sure to check hot shoe connectivity by doing the <CAMERA INFO> check.

    Feel free to suggest an improvement or share product ideas. Contact us directly at info@cactus-image.com.  At Cactus, we listen. 
Sign In or Register to comment.