Pentax System issues (Firmware 1.1.008)

edited March 2017 in V6 II Problems
Hi,

I have found some issues using the cactus v6II with Pentax system.
  • The firmware used is 1.1.008.
  • I have always performed a factory reset before changing the flash or changing scenario.

Only one v6II on camera as Tx, flash on v6II:

  • With Pentax flash AF201FG: Tested on K1, K5IIs & K5

    1. Camera system set to Auto -> After power on, Pentax is recognized.
    2. Flash system set to Auto -> After power on, Pentax is recognized.
      If flash is tilted, no flash system is set. It is not recognized as Pentax.
    3. Flash Profile -> After power on, Auto Pentax is set.
    4. There is no flash symbol on camera, so the flash does not fire when camera shutter is pressed.
      Only when the flash profile is set to Metz (any of them) the flash fires on camera shutter press (flash symbol on camera).
  • With Pentax flash AF540FGZ: Tested on K1, K5IIs & K5
    1. Camera system set to Auto -> After power on, Pentax
    2. Flash system set to Auto -> After power on, Pentax.
      If flash is tilted or rotated, no flash system is set. It is not recognized as Pentax.
    3. Flash Profile -> After power on, Auto Pentax is set.
      The 'Pentax AF540F' profile is not automatically selected.
    4. The format on flash (digital, 35mm, etc) cannot be changed when the flash is attached to v6II.
    5. On K1, the format on the flash is set to 'digital', but it should be '35mm'.
      With firmware 1.1.006 is correctly set to '35mm'.
    6. On K1, the focal length set on v6II for the flash zoom is not equal to the focal length displayed in the flash:
      v6II - AF540FGZ
      wide(16mm) - 24mm
      24mm - 35mm
      35mm - 50mm
      70mm - 85mm

Two v6II. Tx on camera. Rx off camera with flash.

  • With Pentax flash AF201FG: Tested on K1, K5IIs & K5
    1. Flash system is set to Pentax only when flash is not tilted.
    2. Flash fires on camera shutter press only when flash profile is set to Metz.
  • With Pentax flash AF540FGZ: Tested on K1, K5IIs & K5
    1. Flash system is set to Pentax only when flash is not tilted or rotated.
    2. Flash Profile -> After power on, Auto Pentax.
      The 'Pentax AF540F' profile is not automatically selected.
    3. When the flash is not tilted up nor rotated, every time the camera shutter is pressed, the flash fires, as expected.
      But when the flash is tilted up (any angle) or rotated , the flash fires only once, the next camera shutter press does not fire the flash (the light on Rx is not light up).
      At this point if I press the shutter on Tx, the Rx is light up and the flash fires, but pressing the shutter on camera does not fire the flash nor light up Rx.
      This happens when flash profile is Auto Pentax or any of the Pentax flashes. If the profile is any of the Metz, it works correctly even tilted up or rotated.


Regards
Ramon

Comments

  • Hi Ramon,

    For the AF201 flash, if the flash head is not tilted, is the V6 II able to auto-detect it? 

    if you manually select any Pentax flash profile, are you able to control its power remotely? Does HSS works?

    FYI Auto-detect will not selecting an model specfic flash profile. It will select an AUTO flash profile.

    Thanks for the your observations about the zoom settings. I will pass them on to the R&D team.

    Cheers!


    Antonio Lao
    Brand Manager
    _____________

    To help us better help you, always state the exact firmware version installed on your Cactus device(s), such as: "1.1.013", "NIK.A.001", "v.103", or "A06".

    TTL or HSS not working on Cactus V6 II and V6 IIs? Be sure to check hot shoe connectivity by doing the <CAMERA INFO> check.

    Feel free to suggest an improvement or share product ideas. Contact us directly at info@cactus-image.com.  At Cactus, we listen. 
  • Hi Antonio, 

    Thanks for your answer.

    About your AF201 questions:

    1. When it is not tilted, it is correctly detected as a Pentax Flash. In both Tx and Rx modes.
    2. If the selected flash profile is any of the Metz models, I can control the flash power and HSS works perfectly. In both Tx and Rx modes.
    3. If the selected flash profile is 'Auto (Pentax)' or any of the Pentax models, the flash does not fire in any mode (Tx or Rx).
    I will check all this again when I arrive home this evening.

    Thanks again
    Ramon
  • edited March 2017
    Hi Antonio,

    I have tested again the AF201.
    The answers to your questions apply for both the following two scenarios:
    • Only one v6II. v6II as Tx on camera with the flash on v6II.
      In this scenario the power setting is changed for the local flash (menu button + wheel in Tx)
    • Two v6II. One as Tx on camera. Other as Rx off camera with flash on Rx.
      In this scenario the power setting is changed for remote flash (wheel in Tx).
      The flash should be turned on without tilt before turning on the Rx (more on this at the end).
    For the AF201 flash, if the flash head is not tilted, is the V6 II able to auto-detect it? 
    Yes, if the flash head is not tilted, V6II (Tx or Rx mode) auto-detect it as a Pentax system flash.
    if you manually select any Pentax flash profile, are you able to control its power remotely? Does HSS works?
    With any Pentax model profile or Auto Pentax profile, the flash does not fire (any power setting selected). The flash profile should be any of the Metz models for the flash to fire when camera shutter is pressed.
    • When camera shutter speed is below x-sync (no HSS), the flash output (light emitted) is related with the selected power in Tx V6II (1/128: dimmer light, 1/1: brighter light). Flash-Camera synchronization is OK.
    • When camera shutter speed is above x-sync (HSS), the flash output (light emitted) is always the same with any selected power in Tx V6II (I think the flash output is the one related with 1/128 power setting). Flash-Camera synchronization is OK.


    I explain now some strange behaviors in the second scenario (two v6II):

    1. Attach flash to Rx. Flash head not tilted. Both turned off.
    2. Turn on Rx (Rx displays 'MANUAL ON')
    3. Turn on flash.
    4. Manually select Pentax flash system in Rx.
    5. The flash does not fire when camera shutter is pressed.
      Changing to any available profiles (Auto Pentax, Pentax model, Metz model) and/or tilting the flash head, does not fix it.
      Tx-Rx communication is OK. Pressing Tx shutter, lights up Rx and flash.
    6. Set profile to 'Auto Pentax'
    7. Keep flash head not tilted and turn it off and on again.
    8. Now the flash fires when camera shutter is pressed, but only once, the next camera shutter press does not fire the flash.
      Changing to any available profiles (Auto Pentax, Pentax model, Metz model) and/or tilting the flash head, does not fix it.
      Tx-Rx communication is OK. Pressing Tx shutter, lights up Rx and flash.
    9. Set profile to 'Auto Pentax'
    10. Tilt up the flash. Turn it off and on again.
    11. The flash does not fire when camera shutter is pressed.
      Changing to any available profiles (Auto Pentax, Pentax model, Metz model) and/or tilting the flash head, does not fix it.
      Tx-Rx communication is OK. Pressing Tx shutter, lights up Rx and flash.


    1. Attach flash to Rx. Flash head not tilted. Both turned off.
    2. Turn on flash.
    3. Turn on Rx. It displays MANUAL ON.
    4. Manually select Pentax flash system in Rx.
    5. The flash fires when camera shutter is pressed, but only once, the next camera shutter presses does not fire the flash.
      Changing to any available profiles (Auto Pentax, Pentax model, Metz model) and/or tilting the flash head, does not fix it.
      Tx-Rx communication is OK. Pressing Tx shutter, lights up Rx and flash.
    6. Set profile to 'Auto Pentax'
    7. Keep flash head not tilted and turn it off and on again.
    8. The flash does not fire when camera shutter is pressed.
      Changing to any available profiles (Auto Pentax, Pentax model, Metz model) and/or tilting the flash head, does not fix it.
      Tx-Rx communication is OK. Pressing Tx shutter, lights up Rx and flash.


    If you need more tests with AF201 or AF540, please let me know :).

    Regard
    Ramon

  • Thanks Ramon for the detailed response.

    You should also switch on the flash first, set it to TTL mode, and then lastly switch on the V6 II to R mode.

    And when you do a new power cycle, be sure to do a factory reset first so that flash system and flash profile are properly set.

    From your description, apparently there are some bugs with Pentax flash model flash profiles and even the AUTO profile. I will forward this to the R&D team.

    Your understanding during this time is much appreciated.
    Antonio Lao
    Brand Manager
    _____________

    To help us better help you, always state the exact firmware version installed on your Cactus device(s), such as: "1.1.013", "NIK.A.001", "v.103", or "A06".

    TTL or HSS not working on Cactus V6 II and V6 IIs? Be sure to check hot shoe connectivity by doing the <CAMERA INFO> check.

    Feel free to suggest an improvement or share product ideas. Contact us directly at info@cactus-image.com.  At Cactus, we listen. 
  • Hi Antonio, 

    Looking forward for the new firmware :).

    BTW, I made a mistake in the description of the second strange behavior. The correct description is as follows:
    1. Attach flash to Rx. Flash head tilted. Both turned off.
    2. Turn on flash.
    3. Turn on Rx. It displays MANUAL ON (not recognized)
    4. Manually select Pentax flash system in Rx.
    5. The flash fires when camera shutter is pressed, but only once, the next camera shutter presses does not fire the flash.
      Changing to any available profiles (Auto Pentax, Pentax model, Metz model) and/or tilting the flash head, does not fix it.
      Tx-Rx communication is OK. Pressing Tx shutter, lights up Rx and flash.
    6. Set profile to 'Auto Pentax'
    7. Keep flash head not tilted and turn it off and on again.
    8. The flash does not fire when camera shutter is pressed.
      Changing to any available profiles (Auto Pentax, Pentax model, Metz model) and/or tilting the flash head, does not fix it.
      Tx-Rx communication is OK. Pressing Tx shutter, lights up Rx and flash.

    It seems there is a problem with Pentax flashes when the head of the flash is tilted or rotated.

    Regards
    Ramón

  • ...It seems there is a problem with Pentax flashes when the head of the flash is tilted or rotated.

    Yes, seems like it's affecting PENTAX branded flashes and AUTO Pentax, but not Metz, as you have tested.

    Thanks!
    Antonio Lao
    Brand Manager
    _____________

    To help us better help you, always state the exact firmware version installed on your Cactus device(s), such as: "1.1.013", "NIK.A.001", "v.103", or "A06".

    TTL or HSS not working on Cactus V6 II and V6 IIs? Be sure to check hot shoe connectivity by doing the <CAMERA INFO> check.

    Feel free to suggest an improvement or share product ideas. Contact us directly at info@cactus-image.com.  At Cactus, we listen. 
  • i also experience strange behaviour of nearly all the flashes i have on the V6II .... not even on the first V6 i experienced problems that bad.

    first: FW 1.1.006 - Sigma 610 DG Super works OTB  you can even control its power when profile is set to PENTAX AUTO...

    all the other firmwares - no chance... LED lights up but flash doesnt fire.
    test button on TX fires the flash on RX... but not firing when actuating the camera... ???WIT?

    not even the pentax 540 FGZ seems to synch correctly... or better said it only syncs sporadically..

    Cactus should really do something about it and do some test with P-TTL Flashes for gods sake(or in the name of the money we all handed out for ONE V6II unit!!!) ...

  • Firmwares 1.1.007 and 1.1.008 are a disaster on Pentax.  There's no point in even trying anything beyond 1.1.006 at the moment.
  • Sorry guys, we will release new firmware that fixes all the problems. Please wait for 1.1.009, to be released later this week!
    Antonio Lao
    Brand Manager
    _____________

    To help us better help you, always state the exact firmware version installed on your Cactus device(s), such as: "1.1.013", "NIK.A.001", "v.103", or "A06".

    TTL or HSS not working on Cactus V6 II and V6 IIs? Be sure to check hot shoe connectivity by doing the <CAMERA INFO> check.

    Feel free to suggest an improvement or share product ideas. Contact us directly at info@cactus-image.com.  At Cactus, we listen. 
  • Hello,

    I have done a quick test with firmware 1.1.009.
    As stated in the release notes, the tilt/rotate problems have been solved, at least in my two Pentax flashes (540FGZ and 201FG).

    Regarding AF540FGZ flash:
    In K1 the flash now is set to 35mm and there is no focal length mismatch between the flash and v6II.
    When the flash is tilted or rotated, the v6II recognizes it as a pentax flash and works as expected (no need to set to metz profile).

    Regarding AF201FG flash:
    The problems related to the flash being tilted have been resolved.
    But the v6II still needs to be set to a metz profile for the flash to fire.

    Regards
    Ramon

Sign In or Register to comment.