Fuji X-T2 & Cactus v6ii Burst Mode (CH/CL) Issue?

I have a pair of new Cactus v6ii updated with the latest firmware.  When I connect to my Fuji X-T2 hotshoe, the Fuji burst mode options (CH & CL on the dial), seem to operate but at a very very slow rate (about 3fps).

If I put Fuji and non-Fuji flashes in the hot-shoe, CH & CL operate normally and the flash fires off as many flashes as it can.  If I use another brand of remote trigger, CH & CL operate normally as well.

Is there a setting I'm missing or a reason why Cactus won't let the X-T2 fire off more that 3fps?

Note that I am not using HSS and this is not an HSS issue.  I also noticed by accident that if the Cactus v6ii unit is not seated in the hot shoe all the way the camera will fire at full frame rate while the RX Cactus unit receives the signal (per flashing LED) but it will not fire the flash at all.

Thanks.

Comments

  • Hi there @kcsuttle

    What my understanding mounting any flash device on a Fujifilm camera would slow down the FPS rate. Let me check with R&D and get back to you.

    Thank you.
    Antonio Lao
    Brand Manager
    _____________

    To help us better help you, always state the exact firmware version installed on your Cactus device(s), such as: "1.1.013", "NIK.A.001", "v.103", or "A06".

    TTL or HSS not working on Cactus V6 II and V6 IIs? Be sure to check hot shoe connectivity by doing the <CAMERA INFO> check.

    Feel free to suggest an improvement or share product ideas. Contact us directly at info@cactus-image.com.  At Cactus, we listen. 
  • @kcsuttle, Just got a reply from R&D.

    The reason is because the V6 II is seen as a Fujifilm device, thus you are not triggering it in manual mode.

    If you mount a manual flash, such as the RF60X, directly on the hot shoe, then you can shoot at the same CL / CH speeds.

    On the other hand, if you mount the EF-X500 on your X-T2, it too won't be able to fire in the normal CL / CH rates.

    Thanks!
    Antonio Lao
    Brand Manager
    _____________

    To help us better help you, always state the exact firmware version installed on your Cactus device(s), such as: "1.1.013", "NIK.A.001", "v.103", or "A06".

    TTL or HSS not working on Cactus V6 II and V6 IIs? Be sure to check hot shoe connectivity by doing the <CAMERA INFO> check.

    Feel free to suggest an improvement or share product ideas. Contact us directly at info@cactus-image.com.  At Cactus, we listen. 
  • Thank you Antonio.  Can you look into why rapid fire works on X-T1 but on X-T2 it will not rapid fire?
  • Thank you Antonio.  Can you look into why rapid fire works on X-T1 but on X-T2 it will not rapid fire?



    What firmware is your X-T1 running on?
    Antonio Lao
    Brand Manager
    _____________

    To help us better help you, always state the exact firmware version installed on your Cactus device(s), such as: "1.1.013", "NIK.A.001", "v.103", or "A06".

    TTL or HSS not working on Cactus V6 II and V6 IIs? Be sure to check hot shoe connectivity by doing the <CAMERA INFO> check.

    Feel free to suggest an improvement or share product ideas. Contact us directly at info@cactus-image.com.  At Cactus, we listen. 
Sign In or Register to comment.