Yongnuo YN685 (Canon version)

edited June 2017 in V6 II Compatibility
Hi there,

I'm trying to get the YN685 (Canon version) to work with the V6II. Even with AUTO CANON profile selected the flash doesn't even fire when triggered remotely. Also none of the settings changed in the transmitter (like exposure value or zoom) is properly forwarded to the flash on the receiver. Manual mode works fine and the receiver switches to MANUAL when set to auto-detect and switched on.

Shouldn't the flash at least be recognized as Canon type flash given that it of course seems to support the Canon standard protocolls and works fine when placed directly onto my Canon 5DMIII!? Anyone knows a tweak to get this flash working properly?

Thanks in advance for any help.

Comments

  • Hi @junOlive

    Just to confirm, did you first switch on the flash, set it to TTL mode, and lastly switch on the V6 II to RX mode?

    Thanks!
    Antonio Lao
    Brand Manager
    _____________

    To help us better help you, always state the exact firmware version installed on your Cactus device(s), such as: "1.1.013", "NIK.A.001", "v.103", or "A06".

    TTL or HSS not working on Cactus V6 II and V6 IIs? Be sure to check hot shoe connectivity by doing the <CAMERA INFO> check.

    Feel free to suggest an improvement or share product ideas. Contact us directly at info@cactus-image.com.  At Cactus, we listen. 
  • Hi Antonio,

    Yes, exactly in that order. And by the way, I have three V6II and two YN685 units and the behavior is the same whichever of the units I combine.

    Thanks a lot for looking into this!
  • Hi Antonio,

    Yes, exactly in that order. And by the way, I have three V6II and two YN685 units and the behavior is the same whichever of the units I combine.

    Thanks a lot for looking into this!
    Thanks for the extra details.

    I have forwarded your case to our R&D team to follow up. But first we will have to bring this particular Yongnuo model in so we can study it. We will post an update when we are able to find one.

    Thank you for your understanding during this time.
    Antonio Lao
    Brand Manager
    _____________

    To help us better help you, always state the exact firmware version installed on your Cactus device(s), such as: "1.1.013", "NIK.A.001", "v.103", or "A06".

    TTL or HSS not working on Cactus V6 II and V6 IIs? Be sure to check hot shoe connectivity by doing the <CAMERA INFO> check.

    Feel free to suggest an improvement or share product ideas. Contact us directly at info@cactus-image.com.  At Cactus, we listen. 
  • Hi

    Having the same flash, among others, I am interested to know if this has been resolved?  I want to buy Cactus V6II triggers, but I am needing confirmation of compatibity on various issues.

    Thanks
  • Hi @Tomsk, let me check with @raychan.

    I believe we bought a YN568EX-II but we do not have the Mark I. 

    We shall get back to you tomorrow.  Thanks!
    Antonio Lao
    Brand Manager
    _____________

    To help us better help you, always state the exact firmware version installed on your Cactus device(s), such as: "1.1.013", "NIK.A.001", "v.103", or "A06".

    TTL or HSS not working on Cactus V6 II and V6 IIs? Be sure to check hot shoe connectivity by doing the <CAMERA INFO> check.

    Feel free to suggest an improvement or share product ideas. Contact us directly at info@cactus-image.com.  At Cactus, we listen. 
  • Hi @Antonio,

    Just to be sure: we are talking about the Yongnuo YN685, not a YN568.

    By the way - I updated to the Fuji X-TTL version which, however, changed nothing on the problem described above.

    Best,
    Frank
Sign In or Register to comment.