Fujifilm HSS

Hi,
Thank you for the good work you did, TTL works fine for me with the new firmware, with X-T2, Cactus RF60x, Nikon SB910 and Metz M400.
But I couldn't make them work in HSS, in manual or TTL mode (it worked well in forced HSS before). Did I miss something?
Thanks for your help, and for the work done on the software
Pierre

Comments

  • I'm having the same trouble with my X-T2, V6ii and RF60. I just upgraded my V6II today, and while TTL seems to work, HSS does not. The flash simply won't fire if the shutter speed exceeds 1/250, and there is no longer an option to learn or force HSS. I couldn't persuade power sync to work either.

    Also, the camera's menu will not let me change from TTL to manual mode. If I try to alter the setting, it just skips back to TTL. I *think* that taking the V6ii out of TTL mode and just manually setting the flash does work, but I didn't test this thoroughly enough to be sure.

    Is the latest V6ii firmware definitely compatible with the latest X-T2 firmware released about three weeks ago (v2.10)?
  • Sorry, I made a mistake: the Metz M400 doesn't work correctly in TTL mode, the flash is always at the same power, but fires.
    TTL works well for me with Nikon SB910 ans RF60X.
    HSS doesn't work anymore.

  • With Cactus RF60X the flash fires, but HSS doesn't work (dark band on the image).
  • rvsesam: I have noticed the same issue with unregulated flash power for the M400, Have not tested HSS, but I have no doubt your observations are correct

    Furthermore, the general interface between V6II and camera can be greatly improved. It is not possible to set flash mode, power (in M or TTL mode), AF-assist light, or zoom from the camera body.

    I hope Cactus is able to improve TTL&HSS for the M400 and RF60X soon and the camera interface for the V6II soon.
  • Well, sorry, it was my fault! I hadn't turned on "FP" in the sync mode on the XT2... Now it works perfectly with Cactus RF60X and Nikon SB 910 for TTL and HSS.  HSS works with M400, but TTL doesn't (always full power).
    Anyway, great job already done Cactus!
  • If you attach the small Fuji flash that comes with the camera you can then go into the menu and change the flash mode to TTL and fp. Everything will then work when you attach the transmitter to the camera
  • Hey guys,

    we have the Metz M400 now so we will check out what went wrong.

    Thanks for reporting the various updates.

    Cheers!
    Antonio Lao
    Brand Manager
    _____________

    To help us better help you, always state the exact firmware version installed on your Cactus device(s), such as: "1.1.013", "NIK.A.001", "v.103", or "A06".

    TTL or HSS not working on Cactus V6 II and V6 IIs? Be sure to check hot shoe connectivity by doing the <CAMERA INFO> check.

    Feel free to suggest an improvement or share product ideas. Contact us directly at info@cactus-image.com.  At Cactus, we listen. 
Sign In or Register to comment.