Fujifilm TX unit compatibility

I think the integration between the TX unit and Fuji cameras can be improved:
The AF-assist signal from the camera is currently apparently not used
Settings in the in-camera flash menu are not propagated to the TX unit, and vice versa

Comments

  • Thanks for your comments.

    AF-assis? It's Fujifilm's fault. :)
    They took it away. There's actually no AF-assist signal going through their camera hot shoe. This is something Cactus can't fake it.  But don't worry, we have a feature for user to manually switch on the AF-assist light on the V6 II. 

    Settings in the in-camera menu, on the next firmware release (FUJ.1.002?), when we enable Group metering.

    Thanks!
    Antonio Lao
    Brand Manager
    _____________

    To help us better help you, always state the exact firmware version installed on your Cactus device(s), such as: "1.1.013", "NIK.A.001", "v.103", or "A06".

    TTL or HSS not working on Cactus V6 II and V6 IIs? Be sure to check hot shoe connectivity by doing the <CAMERA INFO> check.

    Feel free to suggest an improvement or share product ideas. Contact us directly at info@cactus-image.com.  At Cactus, we listen. 
  • I supposed there must be a AF-assist signal, as for example the Fuji EF-X500 and the Metz M400 do switch on their AF-assist light in darkness.

    Great you continue improving the firmware, I am looking forward to better camera-menu coupling and Metz M400 compatibility!
  • I supposed there must be a AF-assist signal, as for example the Fuji EF-X500 and the Metz M400 do switch on their AF-assist light in darkness.

    Great you continue improving the firmware, I am looking forward to better camera-menu coupling and Metz M400 compatibility!
    You are right!~
    It does, after turning on the AF setting on the flash, the flash AF-assist light does turn on. 
    Cool stuff. Thanks for letting us know. 

    It shall be done on the next firmware release.

    Thank you!
    Antonio Lao
    Brand Manager
    _____________

    To help us better help you, always state the exact firmware version installed on your Cactus device(s), such as: "1.1.013", "NIK.A.001", "v.103", or "A06".

    TTL or HSS not working on Cactus V6 II and V6 IIs? Be sure to check hot shoe connectivity by doing the <CAMERA INFO> check.

    Feel free to suggest an improvement or share product ideas. Contact us directly at info@cactus-image.com.  At Cactus, we listen. 
  • We are testing it now and the AF-assist light on the V6 II already turns on. So you are referring to the on-camera mounted M400?
    Antonio Lao
    Brand Manager
    _____________

    To help us better help you, always state the exact firmware version installed on your Cactus device(s), such as: "1.1.013", "NIK.A.001", "v.103", or "A06".

    TTL or HSS not working on Cactus V6 II and V6 IIs? Be sure to check hot shoe connectivity by doing the <CAMERA INFO> check.

    Feel free to suggest an improvement or share product ideas. Contact us directly at info@cactus-image.com.  At Cactus, we listen. 
  • The AF-assist light works fine, you are right.
  • The AF-assist light works fine, you are right.
    Cool to know! :) 
    Antonio Lao
    Brand Manager
    _____________

    To help us better help you, always state the exact firmware version installed on your Cactus device(s), such as: "1.1.013", "NIK.A.001", "v.103", or "A06".

    TTL or HSS not working on Cactus V6 II and V6 IIs? Be sure to check hot shoe connectivity by doing the <CAMERA INFO> check.

    Feel free to suggest an improvement or share product ideas. Contact us directly at info@cactus-image.com.  At Cactus, we listen. 
Sign In or Register to comment.