Inconsistent power with Canon speedlite 600EX-RT

I recently purchased the Cactus v6 II for my Canon 5D Mark III along with 4x Canon 600EX-RT speedlights.
Cactus v6 II is updated with the latest firmware (may-2017),

Camera and speedlights are recognized very well by the Cactus triggers and everything works fine.
The problem is that while shooting the speedlights intermittently fire at full power. 
It happens on 3x 5D MKIII bodies and 6 diferent 600EX-RTspeedlights.
I have no clue why this is happening and how to fix it.

Startup sequence:
1. Camera on
2. Speedlight on (ETTL)
3. Cactus V6 II on

Hopefully someone can help me out with this issue.

Thanks in advance.

Dollia

Comments

  • Hello Dollia,

    2 days ago we just released new firmware, which may fixed the problem you experienced. 

    Version 1.1.011. 

    Thank you.
    Antonio Lao
    Brand Manager
    _____________

    To help us better help you, always state the exact firmware version installed on your Cactus device(s), such as: "1.1.013", "NIK.A.001", "v.103", or "A06".

    TTL or HSS not working on Cactus V6 II and V6 IIs? Be sure to check hot shoe connectivity by doing the <CAMERA INFO> check.

    Feel free to suggest an improvement or share product ideas. Contact us directly at info@cactus-image.com.  At Cactus, we listen. 
  • Antonio

    Can we get the release notes updated please?  They are still for 1.1.010.

    Thanks
    Paul
  • Try again...


    scroll down to page 2 of the PDF.
    Antonio Lao
    Brand Manager
    _____________

    To help us better help you, always state the exact firmware version installed on your Cactus device(s), such as: "1.1.013", "NIK.A.001", "v.103", or "A06".

    TTL or HSS not working on Cactus V6 II and V6 IIs? Be sure to check hot shoe connectivity by doing the <CAMERA INFO> check.

    Feel free to suggest an improvement or share product ideas. Contact us directly at info@cactus-image.com.  At Cactus, we listen. 
  • Thanks for the reply Antonio.
    I have updated the latest version Version 1.1.011.
    Still having the same problem.
    Looks like this is happening only with Canon speedlites.
    A colleage photographer is using mixed Canon and Nikon speedlites and he told me that the Canon missfires intermittently. The Nikon speedlites never do.

    Dollia
  • Hi Dollia, @raychan told me he's been emailing with you.

    Cheers!
    Antonio Lao
    Brand Manager
    _____________

    To help us better help you, always state the exact firmware version installed on your Cactus device(s), such as: "1.1.013", "NIK.A.001", "v.103", or "A06".

    TTL or HSS not working on Cactus V6 II and V6 IIs? Be sure to check hot shoe connectivity by doing the <CAMERA INFO> check.

    Feel free to suggest an improvement or share product ideas. Contact us directly at info@cactus-image.com.  At Cactus, we listen. 
Sign In or Register to comment.