How to set up V6ii + RF60X in TTL mode for Pentax K1

I had the V6ii sat on the hot shoe of my Pentax K1.   My RF60X  was used as an off-camera flash and it was setting to S (slave mode)

HSS worked great I never miss a fire. Wonderful !!!


However I was unable to have the TTL worked for me. 

Status : 
1)  the RF60X was updated to the newest firmware 103 released on 16 Jun 2017
2) The V6ii  was currently having firmware version 1.1.006

Notes:

    1) Since this is a Cactus flash, on my V6ii, I set Camera=PENTAX,  flash=AUTO.   With is configuration, when I turn on the TTL mode (hold down the menu button  for 2 seconds),  it complained : " TTL SYSTEMS DO NOT MATCH"

   2) Similar to 1 above, I set Camera=PENTAX, but I set flash=PENTAX (even this a Cactus Flash),  it allowed me to switch to TTL mode.  However, the TTL didn't work.  The dial to adjust the flash power on the V6ii was still controlled the power on the RF60X -- even the icon TTL was showing -- Manual was still active in TTL mode?  In this case, the HSS was still working fine.


 What do I need to do to use the TTL ?

Thanks 


Comments


  •  What do I need to do to use the TTL ?



    You need to wait for Cactus to release X-TTL firmware for Pentax.

    FYI we will soon run beta testing so we expect it to be available in around 2-3 months.

    Thank you.


    Antonio Lao
    Brand Manager
    _____________

    To help us better help you, always state the exact firmware version installed on your Cactus device(s), such as: "1.1.013", "NIK.A.001", "v.103", or "A06".

    TTL or HSS not working on Cactus V6 II and V6 IIs? Be sure to check hot shoe connectivity by doing the <CAMERA INFO> check.

    Feel free to suggest an improvement or share product ideas. Contact us directly at info@cactus-image.com.  At Cactus, we listen. 
  • edited July 2017
    When you switched to "TTL mode", you only enabled the "TTL pass-through" mode, meaning that the V6II tries to "disappear" between the camera and a flash that is mounted on top of the V6II.

    So "TTL" for the current firmware version only applies to an "on-camera" flash (with the V6II sandwiched between the camera and the flash).

    In other words, there currently is no TTL communication via radio. Once we get the X-TTL firmware for Pentax then we'll be able to use TTL via radio as you intended.
  • So "TTL" for the current firmware version only applies to an "on-camera" flash (with the V6II sandwiched between the camera and the flash).

    It would be nice to have TTL on-camera flash while waiting for the firmware for wireless.

    I had the V6II sandwiched between the camera (Pentax K1) and the the RF60X.   When I switched to TTL mode (on the V6II),  the flash (RF60X) still on manual mode.

    What do I need to set on the RF60X to make it understand V6II is on TTL mode? 

  • edited August 2017
    There is no point in enabling TTL pass-through for the RF60x. The RF60x does not have hot-shoe contacts to exchange TTL information with cameras or triggers. It only has a single centre trigger hot-shoe contact, so no TTL can be "passed through".

    So you won't get TTL features from an RF60x before the new X-TTL firmware is released for the V6II.

    If you want to use the RF60X on the V6II, with the V6II being mounted on the camera, and are happy with just manual power control, just enable the "SHORT" option on the V6II for the work range (in the RADIO settings). Keep the RF60x in (radio-) slave mode.

    You will probably also need to find a way to insulate the centre pin of the RF60x against the V6II centre contact in the hot-shoe. Otherwise, you may be getting double or wrong trigger signals through the hot-shoe as well.
Sign In or Register to comment.