Pentax flash won't fire in TTL mode

Since my last firmware update my flash won't fire in P-TTL mode. My camera is a K20 and my flash is a AF-360fgz. The zoom function works fine, but the flash doesn't fire in TTL-mode. It does fire in M or A mode, but then I can't adjust the power level. I downgraded my triggers to 1.1.008 and then it works fine.

Comments

  • What was the version you last updated to? Was it V1.1.011?

    I don't have your flash model but am a Pentax user myself. Remote power control works for me with my Metz 58 AF-2 and V1.1.011.

    Does it make a difference whether you select the AF 360 FGZ profile manually on the Rx unit? I have to select the Metz 58 AF-2 profile manually, as auto-detection does not work for this model.


  • Hello PMFlag,

    Sorry for my late response.

    The firmware ws 1.1.011 indeed. It makes no difference wether I select the profile manually, or or let the V6II select the profile on auto.
  • Hi @Arend_Witte,  it could be a potential camera compatibility issue. 

    We will need to get a K-20 to confirm.

    In the meantime do you have other Pentax camera models?
    Antonio Lao
    Brand Manager
    _____________

    To help us better help you, always state the exact firmware version installed on your Cactus device(s), such as: "1.1.013", "NIK.A.001", "v.103", or "A06".

    TTL or HSS not working on Cactus V6 II and V6 IIs? Be sure to check hot shoe connectivity by doing the <CAMERA INFO> check.

    Feel free to suggest an improvement or share product ideas. Contact us directly at info@cactus-image.com.  At Cactus, we listen. 
  • Hi Antonio,

    Again sorry for the late response. I have been on vacation for a few weeks :).
    Sorry, but I don’t have another type of Pentax body, only another K20 which has the same issue. In the mean time I bought a RF60X, which is working fine with the K20. My AF360 flash fell down and broke, so I can’t test with that one anymore. Last week I bought an old AF540FGZ. This flash has the same issues. Everything works fine, as long as I keep the firmware on my TX below the 1.0.010 (1.0.009 works fine). The firmware on the RX’s doesn’t seem to make any difference.
  • Always good to have a vacation!

    Could you confirm that you are setting up your AF540FGZ off-camera, mounted on a second Cactus V6 II?

    Your original post says you can't get the flash to fire in TTL mode - are you expecting the flash to fire with automatic exposure?  Or what do you mean by "TTL mode"?

    Does flash sync with image?
    Are you seeing any shadow banding issues?
    What shutter speeds have you set on camera?

    FYI Cactus V6 II with Multi-brand HSS firmware, i.e. 1.1.xxx does not support any form of wireless TTL automatic metering.   It only supports:
    1. wireless power output control
    2. wireless zoom control
    3. wireless High-speed Sync 

    Quick check:  When you mount the AF540GFZ on a V6 II set to RX mode, did you first switch on the flash, set it to TTL mode and then switch V6 II to RX mode?  Can V6 II auto-detect the flash as Pentax and apply an AUTO flash profile?  A letter "P" will appear in the flash icon. We always recommend using the latest firmware, 1.1.012.  

    We are pretty sure remote power control and HSS works when following correct steps in gear setup.

    Please keep us posted on your findings. Thank you.

    Antonio Lao
    Brand Manager
    _____________

    To help us better help you, always state the exact firmware version installed on your Cactus device(s), such as: "1.1.013", "NIK.A.001", "v.103", or "A06".

    TTL or HSS not working on Cactus V6 II and V6 IIs? Be sure to check hot shoe connectivity by doing the <CAMERA INFO> check.

    Feel free to suggest an improvement or share product ideas. Contact us directly at info@cactus-image.com.  At Cactus, we listen. 
  • Antonio,

    Indeed I am setting up a AF 540FGZ off-camera, mounted on a V6II in RX mode and another V6II on TX mode on the camera. The power and zoom settings are working colrrectly in all the firmware versions. The only thing that doesn’t work in the setup is the actual firing of the flash when a later firmware version then 1.0.009 is in the TX V6II on the camera. The green led of the V6 lights when shooting. The V6 does recognize the flash when powering the V6. The RF60X does fire when in slave mode. When I use the RF60 as a TX instead of the V6, the setup also doen’t fire. The RF60X is fitted with the latest firmware (I haven’t tested it yet with an older firmware).
    kind regards, Arend.
  • Hi Antonio. I just tested the RF60X as TX, with the oldest firmware available (2.01). In this setup the RX V6II with the Pentax AF540FGZ also didn’t fire (green led lights up).
    Kind regards, Arend.
  • Please install the latest firmware version, 1.1.012 on the V6 II and v2.05 on RF60 and v1.03.

    RF60 / RF60X cannot trigger a V6 II (RX).  It only works the other way around.

    Reason:  V6 II is smarter than RF60X. 

    RF60/RF60 = full manual flash mounted on-camera, there's only one hot shoe pin. 

    So using the RF60/RF60X as on-camera master flash / transmitter, you cannot trigger a V6 II even if it is set to Manual flash mode (meaning you have no remote control ability of it - you will have to physically walk over to punch in the adjustment directly on the flash unit).
    Antonio Lao
    Brand Manager
    _____________

    To help us better help you, always state the exact firmware version installed on your Cactus device(s), such as: "1.1.013", "NIK.A.001", "v.103", or "A06".

    TTL or HSS not working on Cactus V6 II and V6 IIs? Be sure to check hot shoe connectivity by doing the <CAMERA INFO> check.

    Feel free to suggest an improvement or share product ideas. Contact us directly at info@cactus-image.com.  At Cactus, we listen. 
  • edited September 2017
    Antonio, Thanks for the info. So I cannot use the RF60 as a trigger for the V6. You say I should update the V6II to 1.1.12, but the problem is that the V6II on camera doesn’t fire my AF540FGZ mounted on a V6II if the firmware on the TX is greater then 1.0.009.
  • Antonio, Thanks for the info. So I cannot use the RF60 as a trigger for the V6. You say I should update the V6II to 1.1.12, but the problem is that the V6II on camera doesn’t fire my AF540FGZ mounted on a V6II if the firmware on the TX is greater then 1.0.009.
    I supposed you have updated the firmware on both V6 II units, TX and RX?
    Antonio Lao
    Brand Manager
    _____________

    To help us better help you, always state the exact firmware version installed on your Cactus device(s), such as: "1.1.013", "NIK.A.001", "v.103", or "A06".

    TTL or HSS not working on Cactus V6 II and V6 IIs? Be sure to check hot shoe connectivity by doing the <CAMERA INFO> check.

    Feel free to suggest an improvement or share product ideas. Contact us directly at info@cactus-image.com.  At Cactus, we listen. 
  • That is correct. I’ve updated all my triggers to 1.0.012, but that doesn’t work.
  • Just to make sure, when you said, "but the flash doesn't fire in TTL-mode.", did you mean:

    A) The AF540FGZ is set to TTL mode, mounted on a V6 II set to RX, Pentax flash profile used (either AUTO or manually selected Pentax) but flash does not fire?

    Or

    B) The AF540FGZ is set to TTL mode, mounted on a V6 II set to RX, Pentax flash profile used (either AUTO or manually selected Pentax) but flash does not fire with automatic TTL exposure?

    Note: Current Multi-brand HSS firmware versions do not support off-camera TTL metering / automatic exposure.

    Some more questions:
    1. Does the flash not fire at all?
    2. If not, at what shutter speeds would the camera trigger a flash?
    3. Does the flash fired syncs with image?

    We do not have a K20 but K30, and will try it in the meantime, and see if we could reproduce the problem you encountered.

    Thank you!
    Antonio Lao
    Brand Manager
    _____________

    To help us better help you, always state the exact firmware version installed on your Cactus device(s), such as: "1.1.013", "NIK.A.001", "v.103", or "A06".

    TTL or HSS not working on Cactus V6 II and V6 IIs? Be sure to check hot shoe connectivity by doing the <CAMERA INFO> check.

    Feel free to suggest an improvement or share product ideas. Contact us directly at info@cactus-image.com.  At Cactus, we listen. 
  • I just had a quick go on our K-30, with two (2) V6 II both running on firmware version 1.1.012 and I was able to shoot at 1/6000s, firing a AF360FGZ, AUTO flash profile (Pentax), with remote power control. Here's a quick video of how I set them up. 

    Hope this helps!
    Antonio Lao
    Brand Manager
    _____________

    To help us better help you, always state the exact firmware version installed on your Cactus device(s), such as: "1.1.013", "NIK.A.001", "v.103", or "A06".

    TTL or HSS not working on Cactus V6 II and V6 IIs? Be sure to check hot shoe connectivity by doing the <CAMERA INFO> check.

    Feel free to suggest an improvement or share product ideas. Contact us directly at info@cactus-image.com.  At Cactus, we listen. 
  • Hey Antonio,

    Thanks for the video. Here is my setup. Hope you can help me.
  • Hi Arend,

    Did you paste something below your texts? I am not seeing any link.

    Thanks!

    Antonio Lao
    Brand Manager
    _____________

    To help us better help you, always state the exact firmware version installed on your Cactus device(s), such as: "1.1.013", "NIK.A.001", "v.103", or "A06".

    TTL or HSS not working on Cactus V6 II and V6 IIs? Be sure to check hot shoe connectivity by doing the <CAMERA INFO> check.

    Feel free to suggest an improvement or share product ideas. Contact us directly at info@cactus-image.com.  At Cactus, we listen. 
  • I can’t get the video to upload. I’ll try again later.
  • I can’t get the video to upload. I’ll try again later.
    Okay, you may try wetransfer.com and email it to us directly at info@cactus-image.com, or on YouTube as Unlisted video.
    Antonio Lao
    Brand Manager
    _____________

    To help us better help you, always state the exact firmware version installed on your Cactus device(s), such as: "1.1.013", "NIK.A.001", "v.103", or "A06".

    TTL or HSS not working on Cactus V6 II and V6 IIs? Be sure to check hot shoe connectivity by doing the <CAMERA INFO> check.

    Feel free to suggest an improvement or share product ideas. Contact us directly at info@cactus-image.com.  At Cactus, we listen. 
  • I just watched the video. Thanks for sending it through.

    What firmware version is installed on the V6 II RX unit? The one the AF540FGZ is sitting on.

    I suppose it is on 1.1.009?

    When you switched the transmitter unit from 009 to 012, you did not change the Receiver unit.  You must use the same firmware version on both TX and RX units. 

    What would happen if you install 012 also on the RX unit?
    Antonio Lao
    Brand Manager
    _____________

    To help us better help you, always state the exact firmware version installed on your Cactus device(s), such as: "1.1.013", "NIK.A.001", "v.103", or "A06".

    TTL or HSS not working on Cactus V6 II and V6 IIs? Be sure to check hot shoe connectivity by doing the <CAMERA INFO> check.

    Feel free to suggest an improvement or share product ideas. Contact us directly at info@cactus-image.com.  At Cactus, we listen. 
  • edited September 2017
    The RX unit (in the video) is fitted with 1.1.012. When I use 1.1.012 in both units, the same problem occurs. When both units are fitted with 1.0.009 everything works fine (exept when the flash is tilted I think, but I’m niet sure about that). I’ll test that this weekend.
  • Hi Antonio,

    Just tested the tilted flash. It fires when tilted with version 1.0.009.
  • Thanks Arend,

    I will report your findings to R&D.  As mentioned above, our K30D is working just fine with 1.1.012.  Because we do not have a K20D we won't be able to verify a fix. But hopefully R&D team can figure something out, for this what seems to be a camera model specific issue.

    In the meantime, please continue using 1.1.009 before we identify the problem.

    Thank you very much for your understanding during this time.
    Antonio Lao
    Brand Manager
    _____________

    To help us better help you, always state the exact firmware version installed on your Cactus device(s), such as: "1.1.013", "NIK.A.001", "v.103", or "A06".

    TTL or HSS not working on Cactus V6 II and V6 IIs? Be sure to check hot shoe connectivity by doing the <CAMERA INFO> check.

    Feel free to suggest an improvement or share product ideas. Contact us directly at info@cactus-image.com.  At Cactus, we listen. 
  • 1.1.0.13 both K10D & K20D not working.. other hs trigger do work without issue.. please help fix the issue asap... I just want use one brand / set or trigger for all my cameras otherwise i will have to return the v6
  • Hi @kentam

    Not working meaning...
    1) flash does not fire
    2) flash fired but did not sync
    3) HSS did not work

    Which one? Or all three of them?


    Is your V6 II able to auto-detect both K10D and K20D as "P"?

    FYI K10D is not listed as compatible on our website. So you may want to try with using Customs Settings.



    But the K20D should be fine without any special settings.

    Run a Factory Reset before attempting further tests on your V6 II.

    And remember to half press camera shutter button as you switch on the V6 II to TX mode.

    Thanks!
    Antonio Lao
    Brand Manager
    _____________

    To help us better help you, always state the exact firmware version installed on your Cactus device(s), such as: "1.1.013", "NIK.A.001", "v.103", or "A06".

    TTL or HSS not working on Cactus V6 II and V6 IIs? Be sure to check hot shoe connectivity by doing the <CAMERA INFO> check.

    Feel free to suggest an improvement or share product ideas. Contact us directly at info@cactus-image.com.  At Cactus, we listen. 
Sign In or Register to comment.