Fuji x-t1 Metz 58 af-1 (Canon)

Hi

I have a problem with fuj.1.002 firmware.
i am using fuji x-t1, cactus v6ii and metz 58 af-1. the metz 58 af-1 is constantly blinking in display like they can't communicate. It's fine only cactus and metz, when I turn on camera, it starts blinking. It seems that HSS works, but has not dared to test too much. Is there anyone who has a solution to this?

Comments

  • What flash mode was the Metz 58 AF-1 set to? 

    Did you use auto-detect?
    i.e. switching on the flash first, set it to TTL mode, and then switching on the V6 II to RX?

    Are you using the Metz as an off-camera flash?

    Did you install the FUJ firmware on all V6 II transceivers?

    What batteries did you use? Have you tried another set? Another brand? Freshly charged ones?  Just in case it's the batteries that are acting up.

    We only have an 58 AF-2 for Canon, and I just tested it no problem, no flashing lights whatsoever.

    V6 II firmware used:  FUJ.1.002  (I also tested Multi-brand HSS 1.1.012)
    V6 II RX auto-detect

    I was able to control flash power outputs as well as zoom level remotely, from another V6 II (TX).

    Thanks!
    Antonio Lao
    Brand Manager
    _____________

    To help us better help you, always state the exact firmware version installed on your Cactus device(s), such as: "1.1.013", "NIK.A.001", "v.103", or "A06".

    TTL or HSS not working on Cactus V6 II and V6 IIs? Be sure to check hot shoe connectivity by doing the <CAMERA INFO> check.

    Feel free to suggest an improvement or share product ideas. Contact us directly at info@cactus-image.com.  At Cactus, we listen. 
  • I am using auto detect. No flashing display in multi brand firmware. In Fuji Firmware, I can not set modes on Metz or Camera. It's changing all the time back to TTL HSS and jumps in menu when i changes modes. I will try with new batteries. But its fine in multi brand and my metz 48 canon works in fuji firmware with same batteries. I will try to put metz 58 in ttl before turning on the other devices. tests later today. I use on camera flash with cactus in between. thanks for reply
  • Thanks for your reply.

    For your on-camera flash setup, first switch on the flash, set it to TTL mode, then turn on the camera (X-T1, for example), and lastly swtich on the V6 II.

    Before you do the above, do a factory reset first so you can be sure all the camera system and flash system is fresh.

    You don't need to choose a specific Metz flash profile, just let auto-detect do the job. 

    Thank you.
    Antonio Lao
    Brand Manager
    _____________

    To help us better help you, always state the exact firmware version installed on your Cactus device(s), such as: "1.1.013", "NIK.A.001", "v.103", or "A06".

    TTL or HSS not working on Cactus V6 II and V6 IIs? Be sure to check hot shoe connectivity by doing the <CAMERA INFO> check.

    Feel free to suggest an improvement or share product ideas. Contact us directly at info@cactus-image.com.  At Cactus, we listen. 
  • thanks. I will test later and return with the results.
  • I have tried again as you described and with the same result. has taken some shots and looks like it all works. But metz display keep flicker If thats a better word for it.
  • I have tried again as you described and with the same result. has taken some shots and looks like it all works. But metz display keep flicker If thats a better word for it.
    It just suddenly hit me, I personally also have a 58 AF-1 for Canon (haven't used it for some time) so I can test it for you tomorrow and see if there's any LED flickering.

    Thanks!
    Antonio Lao
    Brand Manager
    _____________

    To help us better help you, always state the exact firmware version installed on your Cactus device(s), such as: "1.1.013", "NIK.A.001", "v.103", or "A06".

    TTL or HSS not working on Cactus V6 II and V6 IIs? Be sure to check hot shoe connectivity by doing the <CAMERA INFO> check.

    Feel free to suggest an improvement or share product ideas. Contact us directly at info@cactus-image.com.  At Cactus, we listen. 
  • sounds good. thanks
  • edited September 2017
    On my Metz 58 AF-1 for Canon running on v3.0, I also see a flickering LCD screen, which refreshes around 2-3 seconds.

    I consult with R&D and they advised there's nothing they can do about this because it's part of V6 II's function of Multi-master.  Albeit a bit annoying if you stare at the back of the flash, this does not affect the flash functions. 

    Thank you for your understanding.

    EDIT:  R&D said there's a chance we can fix this in the near future. Thanks!
    Antonio Lao
    Brand Manager
    _____________

    To help us better help you, always state the exact firmware version installed on your Cactus device(s), such as: "1.1.013", "NIK.A.001", "v.103", or "A06".

    TTL or HSS not working on Cactus V6 II and V6 IIs? Be sure to check hot shoe connectivity by doing the <CAMERA INFO> check.

    Feel free to suggest an improvement or share product ideas. Contact us directly at info@cactus-image.com.  At Cactus, we listen. 
  • Okay so i can not damage any devices by using it. thanks for reply
  • Okay so i can not damage any devices by using it. thanks for reply
    Yeah no worries there. :)
    Thank you.
    Antonio Lao
    Brand Manager
    _____________

    To help us better help you, always state the exact firmware version installed on your Cactus device(s), such as: "1.1.013", "NIK.A.001", "v.103", or "A06".

    TTL or HSS not working on Cactus V6 II and V6 IIs? Be sure to check hot shoe connectivity by doing the <CAMERA INFO> check.

    Feel free to suggest an improvement or share product ideas. Contact us directly at info@cactus-image.com.  At Cactus, we listen. 
Sign In or Register to comment.