Firmware Update for V6 and RF60

Just curious as which version of firmware to update to for most features and reliability.

I own:
2 of Cactus V6
4 of Cactus RF60
2 of Pentax K3
1 of Pentax K1

Also when I bought the cactus gear I was told that HSS would just be a firmware update away. So even though I haven't used them much since I bought them, I was hoping that I could do that. Although it appears, I will have to upgrade to the V6II to get that functionality but the RF60 will be capable of HSS with the V6II?

Equipment has worked great for me. I have used V4 (didn't work so good) and V5 (worked good) and rarely use the HSS, but I admit I was disappointed to hear HSS wasn't a firmware update away as I was initially told.

I downloaded the firmware update software, and updated to the latest firmware (A03?) before reading this:
- Firmware version 200 and onwards are for use with the Cactus V6II and V6IIs ONLY.
- For use with Cactus V6, use firmware version 142 and earlier.
Hoping I can go back to 142? or which firmware is optimal for V6 and RF60?
I am using these with my Pentax K-1 and K-3 dslrs.

Thanks for any input!
Randy



Comments

  • Hi Randy,

    Sorry for your disappointment but if you need HSS you need to get the V6 II.

    The V6 when triggered by a V6 II can achieve Power Sync (full power burst and not the HSS long pulsing flash).

    Only use "Axx" firmware versions on RF60 / RF60X if you have a V6 II running on PEN.A.xxx.

    On the other hand if you are using a V6 (MK1) running on 2.1.001, install versions 205 and 104 on the flash respectively.

    Thank you.
    Antonio Lao
    Brand Manager
    _____________

    To help us better help you, always state the exact firmware version installed on your Cactus device(s), such as: "1.1.013", "NIK.A.001", "v.103", or "A06".

    TTL or HSS not working on Cactus V6 II and V6 IIs? Be sure to check hot shoe connectivity by doing the <CAMERA INFO> check.

    Feel free to suggest an improvement or share product ideas. Contact us directly at info@cactus-image.com.  At Cactus, we listen. 
  • edited April 2018
    Thanks for the response Antonio,

    How do I find what I am currently running? or are you saying I should install 2.1.001 on the mark1. I can't afford to upgrade to the V6 II currently so I will be sticking to the mark1.

    Install 205 and 104 both on the flash?

    I might have screwed up this flash and/or transceiver as it doesn't seem to be functioning as good as it did before I upgraded. Is there anyway I can clean off the firmware that I put on, or installing this version overwrite the existing firmware.

    I wonder why I was told that HSS would just be a firmware flash away, guess they thought they could have done it at the time with the existing hardware. I bought my units from gadgetinfinity. I wish I would have waited for the mk2.

    Thanks again, sorry I am confused on this!
    Randy




  • edited April 2018
    randee said:


    How do I find what I am currently running?

    For the V6:
    Keep the "A" and "D" group buttons pressed while turning on the V6. Be sure to not press any other buttons at the same time.

    For the RF60:
    Keep the "Next" button pressed while turning the RF60 on.


    randee said:


    ...are you saying I should install 2.1.001 on the mark1.

    Yes, that's the latest version for the V6 (Mk 1).

    You can install that firmware (or an older one, if you prefer for some reason) regardless of what firmware version is currently running on your V6.


    randee said:


    Install 205 and 104 both on the flash?

    No, just 205.
    As you are using an RF60, firmware version 205 is the one you need. Again, you can go back to an older one, if you want to for some reason.


    randee said:


    I wonder why I was told that HSS would just be a firmware flash away, guess they thought they could have done it at the time with the existing hardware.

    I don't remember any talk about the V6 potentially receiving HSS. There are some "HSS workaround" techniques for the V6, but to the best of my knowledge there were never any HSS announcements or rumours for the V6 (Mk 1).

    The V6II came with HSS straight away. What became "just a firmware replacement away" was "TTL via radio" (-> X-TTL) for the V6II.

  • Hey ClassA Thanks for laying that out for me that was very helpful.
    I will upgrade my (2) V6 and my (4) RF60 units.

    I think I asked if I would be able to get to even 1/250 sync and as I recall they sent me to a link saying the V6 would be able to imitate the AF540FGZ (which I had 2 of and sold). I looked through my emails, but was thinking I might have chatted with someone who sent me a link. Well obviously I didn't ask the right question or got the wrong answer, but probably misunderstood on my end.

    I saw your workarounds, thanks for those, I will play around with them!
    Since I don't have a HSS compatible flash (RF60 wouldn't work right?) I will try the starter pistol method you described. I think I have what I need for that. Actually I gave away my (4) V5 units, maybe I shouldn't have.

    Thanks again ClassA!
    Randy


  • edited April 2018
    Hi Randy,

    glad I could help and how cool is it that you found the workarounds?! :)

    I obviously would have pointed to them if you had asked, I just don't always dig up links in case people aren't interested anyhow. :)

    Good luck with your further experiments!
Sign In or Register to comment.