Pentax K10D / K20D Flash not fire in wither TTL / M mode

Firmware: 1.1.013

Case 1
Camera: Pentax K10D / K20D
Flash: Pentax 540Fgz Mode M / TTL
Sync: Power sync / HSS
Shutter speed all
Test button can remote fire the flash, but no flash while take photo

Case 2
Camera: Pentax K10D / K20D
Flash: Manual PC sync to studio flash
Sync: Power sync / normal HSS
Shutter speed all (but below 1/180 can trigger the flash)
Test button can remote fire the flash but no flash while take photo

acon trigger do working well and without such issues, can you please fix it asap... otherwise I may need to return the cactus v6 ii

Comments

  • Hi again @kentam

    The flash MUST operate in TTL mode.
    1. Switch on the flash first
    2. Set it to TTL (P-TTL) mode
    3. Then switch the V6 II to RX mode
    Do you see the V6 II auto detect the flash, applying an AUTO flash profile and a letter "P" shown inside the flash icon?

    Similarly, on the camera side, do you also see a letter "P" in the camera icon?

    As I mentioned in another thread, did you keep the camera active by pressing camera shutter button as you switch V6 II to TX mode?

    Also mentioned in another thread, the K10D may not be compatible. If auto-detect works but flash still does not sync with image, you may want to try the custom settings.

    Thank you.
    Antonio Lao
    Brand Manager
    _____________

    To help us better help you, always state the exact firmware version installed on your Cactus device(s), such as: "1.1.013", "NIK.A.001", "v.103", or "A06".

    TTL or HSS not working on Cactus V6 II and V6 IIs? Be sure to check hot shoe connectivity by doing the <CAMERA INFO> check.

    Feel free to suggest an improvement or share product ideas. Contact us directly at info@cactus-image.com.  At Cactus, we listen. 
  • Antonio said:

    Hi again @kentam

    The flash MUST operate in TTL mode.

    1. Switch on the flash first

      Yes done

    2. Set it to TTL (P-TTL) mode

      Yes done
    3. Then switch the V6 II to RX mode

      Yes done
    Do you see the V6 II auto detect the flash, applying an AUTO flash profile and a letter "P" shown inside the flash icon?

    Yes done


    Similarly, on the camera side, do you also see a letter "P" in the camera icon?

    Yes done


    As I mentioned in another thread, did you keep the camera active by pressing camera shutter button as you switch V6 II to TX mode?

    Also mentioned in another thread, the K10D may not be compatible. If auto-detect works but flash still does not sync with image, you may want to try the custom settings.

    IT just not fire the flash when take photo while > 1/180 or < 1/180


    Thank you.
  • Thanks for the confirmations. So it appears that the V6 II established good connections with the camera and flash.

    So is it only the K10D that is not working?

    Have you tried choosing a custom camera setting? Possibly 2 or 3 as 1 is for 645Z.

    Does your K20D work? We have one which we can certainly test again for you, but it has always worked.
    Antonio Lao
    Brand Manager
    _____________

    To help us better help you, always state the exact firmware version installed on your Cactus device(s), such as: "1.1.013", "NIK.A.001", "v.103", or "A06".

    TTL or HSS not working on Cactus V6 II and V6 IIs? Be sure to check hot shoe connectivity by doing the <CAMERA INFO> check.

    Feel free to suggest an improvement or share product ideas. Contact us directly at info@cactus-image.com.  At Cactus, we listen. 
  • Antonio said:

    Thanks for the confirmations. So it appears that the V6 II established good connections with the camera and flash.

    So is it only the K10D that is not working?

    Have you tried choosing a custom camera setting? Possibly 2 or 3 as 1 is for 645Z.

    Does your K20D work? We have one which we can certainly test again for you, but it has always worked.

    K20D not work
  • Any update about the issue?
  • Antonio said:

    Thanks for the confirmations. So it appears that the V6 II established good connections with the camera and flash.

    So is it only the K10D that is not working?

    Have you tried choosing a custom camera setting? Possibly 2 or 3 as 1 is for 645Z.

    Does your K20D work? We have one which we can certainly test again for you, but it has always worked.

    I have try Type 1 2 3 all not working...
  • We recently released new firmware for Pentax X-TTL, version PEN.A.002.

    Please give that a try.

    Cheers!
    Antonio Lao
    Brand Manager
    _____________

    To help us better help you, always state the exact firmware version installed on your Cactus device(s), such as: "1.1.013", "NIK.A.001", "v.103", or "A06".

    TTL or HSS not working on Cactus V6 II and V6 IIs? Be sure to check hot shoe connectivity by doing the <CAMERA INFO> check.

    Feel free to suggest an improvement or share product ideas. Contact us directly at info@cactus-image.com.  At Cactus, we listen. 
  • edited August 2018
    Antonio said:

    We recently released new firmware for Pentax X-TTL, version PEN.A.002.

    Please give that a try.

    Cheers!

    I just download and try PEN.A.002

    Not work for my propose...

    All I want is V6 II trigger the Godox X pro Canon over it's hotshoe in hs / powersync (over 1/180) as it do in K-3 with V1.1.013 firmware

    You guy make this work in K-3 but not right with K10d / K20d (It just do 1/180 even the camera can set over 1/180)

    I understand that there is other trigger set can do that i.e. ACON but since I buy V6II I don't want to bring so many different trigger for my system.
  • Thanks for your test results.

    I have forwarded your feedback to R&D. As soon as I get a feedback I will let you know. Hopefully I will bring good news.

    Thank you again for your patience during this time.
    Antonio Lao
    Brand Manager
    _____________

    To help us better help you, always state the exact firmware version installed on your Cactus device(s), such as: "1.1.013", "NIK.A.001", "v.103", or "A06".

    TTL or HSS not working on Cactus V6 II and V6 IIs? Be sure to check hot shoe connectivity by doing the <CAMERA INFO> check.

    Feel free to suggest an improvement or share product ideas. Contact us directly at info@cactus-image.com.  At Cactus, we listen. 
  • Hi...i am a new user here. I used the GX10 for a couple of years before getting the K20, one day I found the GX10's rear LCD screen wouldn't display, it was out of guarantee. Then bingo, I found another GX10 with a broken shutter for 50 euros inc. charger and battery
  • God the Godox XPro P and it work with K10D K20D K3 sure there is problem in your software
  • The V6 II X-TTL firmware for Pentax has been tested with latest Pentax cameras, including K-1, K-5, K3-II, Kx, K-S1 and more. They are all working fine.

    I recommend using the Pentax X-TTL firmware for the best performance. The latest version is PEN.A.004.

    All the best,
    Ray Chan

    Senior Product Specialist
     
    Cactus®
    Harvest One Limited
  • I now want to use v6ii to trigger other trigger for power sync / hi sync ... Come on please fix it by let old camera can use it.
  • raychan said:



    I recommend using the Pentax X-TTL firmware for the best performance. The latest version is PEN.A.004.

    All the best,

    For this Pentax X-TTL firmware
    Perntax camera -> trigger -> receiver -> manual flash (hi sync / fake hss / power sync) the result is not catch the peak of my mono light and very worst them the ACON trigger
Sign In or Register to comment.