Problems installation cactus v6ii with Sony alpha 350 camera and Metz meta blitz 52.

Hello, I bought a cactus V6 II set and tried to install it but my flash won't work,
I set my camera system as 'auto (others)' because Sony is no standard system in the list and on the cactus receiver I set my flash system als 'auto' as well. Both are set on the same channel. When I press the shutter I get green lights on both cactus (transmitter and receiver) but the flash doesn't go off... is there anything else I have to adjust on either the camera or the flash? What could be the problem?

Comments

  • @Ansje
    The issue could be related to your choice to use a V6II instead the V6IIS (SONY).
    Even when the A350 use the old Minolta Auto-Lock hot shoe the correct trigger is the V6IIS. You need to use the "Sony ADP-AMA Shoe Adapter" due to the V6IIS have the Multi-Interface (Mi) hot shoe.
    You can use the V6II with your Metz flash.
    Short, you need one (1) V6IIS as Transmitter and the ADP-AMA adapter for your camera , and one (1) V6II for each one Off-camera flash that you have with an ISO hot shoe.
    I have tried a similar configuration with my old Sony A37 (I no longer have it) and worked like charm.
    Maybe your dealer can help you changing one of your V6II for one V6IIS.
  • Thanks for your advice, but what I don't understand is that on the display of the transmitter is mentioned that the flash and the camera are detected even while using a V6II in stead off a V6IIS. You should expect that if I use the wrong trigger, even that won't work and even the green lights won't go off.. ?
  • @Ansje Yes, but is not getting the right info due to the system and communication protocol is completely different. Due to that you need the specific trigger to SONY cameras.
  • As @lansa301 already mentioned, the V6 II setting should be Camera (OTHERS).

    Try doing a Factory Reset.

    Or you can manually set the camera system to OTHERS.

    Hope this helps!
    Antonio Lao
    Brand Manager
    _____________

    To help us better help you, always state the exact firmware version installed on your Cactus device(s), such as: "1.1.013", "NIK.A.001", "v.103", or "A06".

    TTL or HSS not working on Cactus V6 II and V6 IIs? Be sure to check hot shoe connectivity by doing the <CAMERA INFO> check.

    Feel free to suggest an improvement or share product ideas. Contact us directly at info@cactus-image.com.  At Cactus, we listen. 
Sign In or Register to comment.