X-T10 issue with TTL version FUJ.A.001

Yesterday I updated to the A protocol and the TTL stopped working with the X-T10.

V6 II from FUJ.1.002 to FUJ.A.001
RF60X from 1.03 to A.07
X-T10 Ver. 1.30

Communication seems fine. Changing the ISO, aperture and zoom on the X-T10 is displayed on the V6 II. Changing exposure compensation the V6 II is displayed on the RF60X. But changing the exposure compensation on the V6 II doesn't change the light output on the RF60X. All exposures on the X-T10 are the same, irrespective of exposure compensation on the V6 II or the X-T10.

Any suggestions?

Comments

  • Hi @freek,

    We just released FUJ.A.002, please give that a try!

    Thank you and keep us posted.
    Antonio Lao
    Brand Manager
    _____________

    To help us better help you, always state the exact firmware version installed on your Cactus device(s), such as: "1.1.013", "NIK.A.001", "v.103", or "A06".

    TTL or HSS not working on Cactus V6 II and V6 IIs? Be sure to check hot shoe connectivity by doing the <CAMERA INFO> check.

    Feel free to suggest an improvement or share product ideas. Contact us directly at info@cactus-image.com.  At Cactus, we listen. 
  • Thanks for the superfast response, Antonio!

    I installed the FUJ.A.002 and TTL seems to work decently under different lighting conditions. Great!

    However, adjusting the TTL flash exposure (EV +/-) on the V6 II or the X-T10 still doesn't seem to have effect on the flash output. All exposures with different compensation seem the same.
  • Thanks for the feedback on on TTL compensation. I will forward that to R&D to follow up.

    Much appreciated!
    Antonio Lao
    Brand Manager
    _____________

    To help us better help you, always state the exact firmware version installed on your Cactus device(s), such as: "1.1.013", "NIK.A.001", "v.103", or "A06".

    TTL or HSS not working on Cactus V6 II and V6 IIs? Be sure to check hot shoe connectivity by doing the <CAMERA INFO> check.

    Feel free to suggest an improvement or share product ideas. Contact us directly at info@cactus-image.com.  At Cactus, we listen. 
  • I have tried a V6II (FUJ.A.002) with an X-Pro2 (5.00), apparently flash compensation works for me, but when setting it from the camera, the display does not correspond with actual settings (the same goes for manual mode).

    I hope Cactus can test thoroughly and fix the issues.
  • itsme said:

    I have tried a V6II (FUJ.A.002) with an X-Pro2 (5.00), apparently flash compensation works for me, but when setting it from the camera, the display does not correspond with actual settings (the same goes for manual mode).

    I hope Cactus can test thoroughly and fix the issues.

    Thanks very much for reporting that. I have already forwarded your observations to R&D for follow up.
    Antonio Lao
    Brand Manager
    _____________

    To help us better help you, always state the exact firmware version installed on your Cactus device(s), such as: "1.1.013", "NIK.A.001", "v.103", or "A06".

    TTL or HSS not working on Cactus V6 II and V6 IIs? Be sure to check hot shoe connectivity by doing the <CAMERA INFO> check.

    Feel free to suggest an improvement or share product ideas. Contact us directly at info@cactus-image.com.  At Cactus, we listen. 
Sign In or Register to comment.