NIK.A.004/003 Cactus V6II Problem

I use the transceiver V6 II with Nikon D850 and Nikon D750 with flash Nikon 910 and Metz 64 af-1.
Unfortunately the transceiver does not work properly. A lot of time I need to power it off an on again, the auto zoom control does not work, when I modify the aperture the action is not reflected to flash and mounting the flash on the transceiver on hot shoe flash connector of reflex, the IR assisted focus no longer works.
To move on I am temporarily using a cheaper product and it works perfectly. I am disappointed.

Comments

  • Do you experience the same symptoms on both D750 and D850?

    The D750 has a non-standard hot-shoe which can cause connectivity issues even with genuine Nikon equipment, but in particular with third-party triggers.

    I understand Cactus changed the hot-shoe layout quite a while ago to address the issues with the D750, so my expectation would have been that these problems do not occur anymore.

    If you see the same issues on both D750 and D850, it could be trigger that struggles to make contact in general. Have you tried swapping the transceiver units (transmitter <-> receiver) to see whether it makes any difference?
  • I know the connectivity issue using V6II and D750.
    So we can only focus on D850. I have four tranceivers and I swapped them several times without get any good result.
    I had the same experience before and immediately after the release of the NIK.A.001 firmware, but I thought the problem would be solved.
    As already mentioned, I have no problem using cheaper triggers.
    If necessary, I can make a video on the behavior of the whole system.
  • @aledimario It probably is the compatibility issue with Metz flash for Nikon in the Nikon X-TTL firmware. Our engineering team is looking at it and get it fixed in the next firmware update.
    Ray Chan

    Senior Product Specialist
     
    Cactus®
    Harvest One Limited
  • The Metz flash requires a manual configuration of its flash profile on the V6II. The Nikon 910 should work in the AUTO setting, but it could be worth a try to manually set the profile as well.

    If you don't need automatic exposure, but HSS only, you could also try the multi-brand firmware.
Sign In or Register to comment.