TTL passing through no longer work for SB-910

I purchased 3 Cactus V6 a few months ago to use with my strobes, SB910, and LumoPro speed light. When I purchased them, I tested and all was working fine with ttl passing through on SB910. They were all triggered strobe fine. I haven't been used ttl passing for SB910 since then. I have a up coming session with client that require 2 speed lights so I try to setup SB910 as TTL passing through (on camera) and LumoPro as off camera. I tested and all 3 Cactus V6 can no longer use TTL passing through for SB910. It locked the flash. I couldn't even change anything on the flash. Even turn off the flash, the power is still on. I tried to initiate the use Nikon Profile SB910 multiple time. I even tried to reset to factory on one of the Cactus. None of them work. This is so frustrating to the point I want to smash all 3 pieces. Please assist. 


  • Make sure you turn the flash on first, then the V6. Also, make sure that the V6 mounted to your camera shows the TTL indicator on the left side of the screen.
  • Yes, done all those in different combo. Sometimes, if it showed the TTL indicator on the V6, it wouldn't lock the flash. However, the flash can't get to TTL and changing settings on camera won't do any thing on the flash. If it doesn't show the TTL, then flash got locked.
  • Can you tell me which firmware in your V6? You can check it by pressing and holding the A + D button and turn to TX / Rx the V6 from off position. The latest version is V1.1.008 . Hopefully that will fix the known problem for the SB-910.

    In case you need to update the firmware, please visit the download page,

    When the TTL pass-through is activated (press and hold the V6 (Tx) menu button for 2 second), the SB-910 should work as it mounts directly on the camera. You will be free to make any adjustment on the SB-910 panel.
    Ray Chan

    Marketing Specialist, Customer Service

    Harvest One Limited
  • edited February 2015 PM
    It was 1.0.184

    Updated to 1.1.08
    Issue resolved. I can TTL sync (passing through) on all 3. Hopefully, it will stay like this.

    Thanks so much,
  • Excellent! I'm glad to hear that.
    Ray Chan

    Marketing Specialist, Customer Service

    Harvest One Limited
  • Hi.  Need some help so figured I would tag onto this thread.... updated v6 to 1.1.010....

    I just purchased two v6's to use on D700 and D750's. 

    I know of the hotshoe issue on the D750 but even on the D700 with SB-900 selected, TTL activated, flash on before v6 and before camera I cannot get the flash to output correct or consistently

    It is not tracking aperture, ISO flash comp changes or zoom (basically not seeing it as Nikon at all). Also, I notice that it switches to A mode vs TTL no matter what I do.  

    Help!  Thanks. 


  • Well, I've just played around for an hour or so with my v6's on both the D700 and D750's.  Doesn't matter which hot shoe it's on same problem.... but definitely related to the shoe of the v6.  

    Seems one of the contacts is with a mm of where it needs to be and if you can get it seated just right, everything works fine.  

    So, I put a small slice of electircal tape under each spring to tighten up the fit.  Put a cut of paperclip at the front of the hot shoe to keep it from going in too far.  This nearly fixed the problem, though with a little wiggle I could get it to work almost perfectly, then a small bump and out of whack again.  

    When working, it was tracking zoom, aperture, flash comp, etc.  all good and firing as well. 

    So, definitely a shoe/fit problem on the bottom of the v6.  

    Not sure if this is fixable on our own, but it pains me to spend $30 or more to ship back two new units with a value of $120.  Not a very good investment so far with parties on the horizon and needing a new system.  
  • JBoot said:

    So, definitely a shoe/fit problem on the bottom of the v6.  

    Technically speaking, it's the Nikon D750 hot shoe that has a "problem". FYI It's different than all the other Nikon's models, maybe it was intended by Nikon ;)

    Your concerns will be addressed in ther other thread:
    Antonio Lao
    Brand Manager
  • Have to agree with you Antonio on hot shoe and THANK YOU for being so responsive both here and offline to me.  I assumed you had tested with all bodies and also that Nikon hadn't made any shoe changes (not sure why they ever would given no new functionality that I'm aware of).  

    I'm looking forward to receiving the new unit direct and the other two are on their way back to you now.  

    In any case, I'll give you a full report as soon as I receive the updated unit.  

    Again, thank you!

Sign In or Register to comment.