Canon 5D3 with 600EX TTL pass through failing every so often

Shot a wedding tonight with the Cactus V6 (newest firmware) between  my 5D3 and 600EX. The V6 is set for TTL pass and set to Canon 600EX.. The ETTL works like normal most of the time BUT, every so often, the 600EX (which is in ETTL mode) starts firing FULL POWER until I turn the Cactus V6 off and then turn it back on.  Its like the TTL pass thought fails and only send a full power fire commend.   Over 7 hours it did it about 8 times and ruined a few of my shots..


  • Very similar issue to mine only of camera flash. Still no response.

  • Yes.. I have 5 of these unites, brand new.. Does it on more then one.. Just enough times to ruin a shot and I am returning them unless there is a fix..  Otherwise I like the units, but cannot have my on-camera flash messing up.. Good think I realized what it was quickly.. 
  • @RNorth  Thanks for the report. I have passed it to our R&D team and will get back to you in due course.  Many thanks for your patience during this time.
    Antonio Lao
    Brand Manager
  • Antonio Do you have any other reports or feedback on this?
  • RNorth said:

    Antonio Do you have any other reports or feedback on this?

    No, at least not at the moment, you're the first.

    BTW, in your above case, did you have any other remote flashes used?
    Or you only had one flash, which is mounted on the TX with TTL Pass Through?

    Antonio Lao
    Brand Manager
  • Sometimes yes, other times no. Since you cannot turn the V6 off, I had it on all the time (since I use on-camera flash ETTL all the time)  I noticed it would fire at full power until I turned the V6 off. Even when I was using remote flashes it would still do this.. It is some error in the ETTL signal. And my flash has never done it before with my old radios or when its just the flash by itself.  As I said, once I turn the V6 off then right back on, it worked for a while.. Either-way, for a wedding, this is a major issue 
  • Was there any resolution to this issue. I also find that TTL pass through sometimes goes a bit wonky and I have to switch things off and back on to restore operation.
  • Dear all, 

    I'm experiencing the same issues with a 5DmkII and 430EXII flashes. Any idea why the TTL pass through sometimes works, and other times just puts out a full 1/1 flash?
  • @Jaap @davebell5S @RNorth @Dyeless

    Just double checking, but have you all already:
    1. Enabled TTL pass through on the V6 TX unit,
    2. Chose the Canon system, and
    3. Chose the respecive flash profile?

    Thank you!

    Antonio Lao
    Brand Manager
  • @Antonio yes, did it couple of times. Tried it on several weddings, still every so often it starts ourputting full power flashes. I even updated to The new firmware, nr10, but that didnt solve The problem. Actually, it initiated other problems but i'll put up another post on that.
  • Thanks @Jaap I have forwarded your message to our R&D team and I will get back to you ASAP.
    Antonio Lao
    Brand Manager
  • This is probably the most frustrating issue with these triggers. I experience exactly the same thing. 

    TTL with FEC works absolutely fine then it suddenly decides to go nuts and fire at full power. This is totally unacceptable for a professional product.

    This almost wants to make me dump the V6's and just go with 600ex's which are reliable. Is there any progress on this issue with the Cactus R&D team? It has been months since first reported... Please guys - get this sorted out!

  • Have you tried the latest firmware update (Firmware 1.1.013)?

    It fixed a potentially related issue (V6 not initialising the profile after power on) and perhaps it will help with the problem reported here as well?
  • Hey people, sorry for the wait. We have been working on it still testing it.

    If you guys want to try I can send you a beta version of the new firmware. Please email me directly if you want to test it:

    Thank you!

    @davebell55 @Jaap @RNorth @Dyeless
    Antonio Lao
    Brand Manager
  • @davebell55 @Jaap @RNorth @Dyeless

    Hey all, the new firmware has been released.  It "Fixed the occasionally not responding error when  the V6 TX is working with a Canon camera and an on-camera flash with TTL pass-through enabled."  However it may not completely take away the rare full power pop. If in case you encounter one, continue and it will be back to normal on your next shot.

    Thank you!
    Antonio Lao
    Brand Manager
Sign In or Register to comment.