Fail to Update Firmware in Windows 7

Dear Support

I tried in Windows 7 and Windows 8 environment but still not able to update the firmware for my new purchased V6 and RF60. I also tried 3 different USB cable and still got the No device connected.  I can see the them under device manage and Other Devices.  Any idea how I can get them connect and recognized by my computer please?

Thanks

Henry 


No Device Connected.jpg
800 x 462 - 57K
Other Device.jpg
391 x 136 - 26K

Comments

  • Hello @henryhungbear

    Sorry to hear about this.  For the V6, have you press and hold the MENU button as you swtich it on to either TX or RX? You will see the Status LED blinks quickly in red.

    And for the RF60, just leave the Mode Switch in the OFF position. Firmware Updater should recognize it automatically.

    Hope this helps!
    Antonio Lao
    Brand Manager
  • Hello Antonio

    Yes, I followed the instruction and hold the menu button and turn to TX or RX model already.  Also, I tried on 5 differnt computers Windows 7 and 8.  Nono of them can detect V6 and RF60.  I also tried a few different mini usb cable.  And idea how to solve this please?

    Thanks

    Henry

  • Thanks Henry for the confirmation.

    So does the LED status light blinks in red after you press MENU and switch it on? In other words, does it dive into "discoverable mode" and waiting for a USB connection?
    Antonio Lao
    Brand Manager
  • HI there, im having the same problem..

    it does blink in red.. but nothing else happens.. the updater does not shows any devices connected.

    there is a code28 under devices.. the driver is not installed and cant get it to be installed through windows..

    am running windows 7.. and even bought a new cable from amazon to test it out.

    Running updater 2.01.

    plz advise...   :(
  • i have also went through the other threads on these problems and i am unable to locate any .inf file in my driver directory...


  • @rx7ong Please download the Upater again, http://www.cactus-image.com/cactus_updater.zip

    FYI we re-bundled the installer again and made sure the driver is included.

    Many thanks!

    Antonio Lao
    Brand Manager
  • thx.. everything is working now.. though you cause me a great deal of trouble.. from buying new cables.. to even formatting my laptop to make sure my system was not the problem...

    hopefully we will get proper software releases next time.

    thx
  • I have exactly the same problem. None of my 3 V6's are recognised by the installer (v2.01), but they appear with a yellow 'warning' in device manager. My firmware versions on all 3 V6's is 1.1.004

    Does anyone have any clues?
  • wizofoz said:

    I have exactly the same problem. None of my 3 V6's are recognised by the installer (v2.01), but they appear with a yellow 'warning' in device manager.

    Download the firmware updater again (see the link provided by Antonio a couple of posts above) and reinstall it. That should properly install the drivers.
  • It is now the end of May 2016 and nothing has changed for me,
    I also have the exact same problem using a Windows 10 computer.
    I have tried to update both V6 and RF60 units and none are recognized as being connected.
    Changing cables and downloading firmware updater again gives the same result, No device connected.

    Does/did the updater system work at all?

  • Yes certainly it does. I'm running on Windows 7 and it updates Cactus devices smoothly.

    Have you tried following these steps?

    http://www.cactus-image.com/community/discussion/855/how-to-install-and-update-firmware-on-windows-8-and-windows-10
    Antonio Lao
    Brand Manager
  • edited May 31 PM
    Hi Gregory,

    are you pressing the menu key and keeping it pressed while turning on the V6 in preparation for the firmware update?

    The LED needs to blink red when you connect the V6. Otherwise, it won't be recognised.

    The RF60 should be recognised as is, though. However, make sure to remove the batteries first.

    Sorry if you are doing all of the above already. My best bet is that you haven't successfully circumvented the Win 10 protection against non-signed drivers. Note that you have to go through the procedure Antonio pointed to after every restart of your computer. The drivers won't stick, so to speak and you have to convince Win 10 that you really want to install the drivers all over again.
Sign In or Register to comment.