Why my Nikon flashes automatically switches from TTL to A Mode?

I cannot remote power control my Nikon SB700, SB900 and SB910: Flash automatically switches from TTL to A Mode and would not let me switch back.

What you need to do switch off your V6 Receiver unit(s) before switching on your Nikon flash on the V6. First switch the flash on, set it to TTL mode. Then switch on the V6 by selecting RX Mode and select the correct flash profile.

Note: Flash must be in TTL mode, so when it is in “A” or “M”, the V6 is cannot remote power control the unit.


  • This does not work. 

    I have 4 cactus V6 triggers. Two nikon sb600's and two nikon sb900's. 

    The 600's work well. I have not been able to get the nikon 900's to work in the year that I have owned these triggers. 

    I've kept up to date with the latest firmware, but still, every time I put a trigger on the nikon sb900 the flash reverts to A mode, making the triggers useless. 

    I've pretty much given up on cactus now and returned to the more expensive, but reliable pocket wizards. 
  • What firmware version is running on your SB-900?

    Maybe the SB-900 need an update? There is a thread about SB-900 power levels, implying that the SB-900 works with the V6.
  • I have just purchased and received my V6's. I have the same issue; my Nikon SB-910 doesn't give TTL option on the V6. My SB-28 works fine.
    Is there a definitive answer to this issue?
  • Hi @Seb

    Did you already power on the devices top-down? That is:
    1. Switch on the SB-910
    2. Then switch on the V6 to RX mode
    3. Select the SB-910 flash profile
    I just tested it and it's working beautifully here.

    Thank you and let us know if it works for you too.

    Antonio Lao
    Brand Manager
Sign In or Register to comment.