Download firmware for Mac

I cannot use the Cactus Updater 1.03.

Despite removing batteries etc the firmware updater never detects my Cactus V6 II Transceiver - if I hold the menu button ad turn on the power, red lights flash forever.

Comments

  • Hello @johnslaytor

    May I know which Mac OS are you running on?

    Holding the MENU button as you switch on the V6 II should allow the computer to detect the device.

    Does the Updater still shows "No device connected" while the red light is blinking on your V6 II?

    FYI we have no new firmware versions since V6 II released. The latest version should still be 1.1.001.

    Thank you!
    Antonio Lao
    Brand Manager
    _____________

    To help us better help you, always state the exact firmware version installed on your Cactus device(s), such as: "1.1.013", "FUJ.1.002", "v.103".

    For the time being, Cactus V6 (MK1) running on firmware version 2.1.001 can be triggered by a V6 II (MK2) running on Multi-brand HSS firmware (e.g. 1.1.013) and not by X-TTL firmware versions: PEN.A.001 and OLY.A.001.  No schedule has been released yet. 

    Cactus RF60X / RF60 Firmware versions A01 and A02 currently ONLY works with PEN.A.001 and OLY.A.001.  Other "A" version of X-TTL firmware will be released soon. For both Multi-brand HSS and X-TTL firmware versions (FUJ, SIG, SON), install firmware version 103 / 205 on your RF60X / RF60.

    Cactus RF60 is now an off-camera TTL flash with firmware version 205 or later!

    Metz M400 (for Fujifilm) is now supported on the Cactus V6 II (HSS and TTL).

    Nikon D750 users please read this thread: 

    Fujifilm EF-X500 users please read this thread:

    Feel free to suggest an improvement or share product ideas. Contact us directly at info@cactus-image.com.  At Cactus, we listen. 
  • I am using firmware 1.1.001 on my two copies of V6II and I receive the same problem - red lights flash on the trigger but the firmware updater never detects the device.  I am running Mac - OS X El Capitan Version 10.11.5
  • I had the same experience, thinking that 1.03 referred to the firmware version. I assume that version 1.03 of the Cactus Updater will update any firmware release.
  • I'm using the Fuji X-T2 with 2-EF-X500 flash units, 3 - Cactus V6II, (v Fuji 1.02) . Nothing seems to work - can't get the flash units to fire remotely nor can I access anything in the menu that will allow HSS.
  • Hi @geotheo,

    For the camera, did you remove the metal spring plate from X-T2's hot shoe?
    You can know there's a good connection when you adjust camera zoom or shutter speed, the new settings will pop up on V6 II TX unit's LCD.

    For the flash, before mounting EF-X500 on a V6 II, did you do the spacer mod?  See the link in my signature. 

    Thank you.
    Antonio Lao
    Brand Manager
    _____________

    To help us better help you, always state the exact firmware version installed on your Cactus device(s), such as: "1.1.013", "FUJ.1.002", "v.103".

    For the time being, Cactus V6 (MK1) running on firmware version 2.1.001 can be triggered by a V6 II (MK2) running on Multi-brand HSS firmware (e.g. 1.1.013) and not by X-TTL firmware versions: PEN.A.001 and OLY.A.001.  No schedule has been released yet. 

    Cactus RF60X / RF60 Firmware versions A01 and A02 currently ONLY works with PEN.A.001 and OLY.A.001.  Other "A" version of X-TTL firmware will be released soon. For both Multi-brand HSS and X-TTL firmware versions (FUJ, SIG, SON), install firmware version 103 / 205 on your RF60X / RF60.

    Cactus RF60 is now an off-camera TTL flash with firmware version 205 or later!

    Metz M400 (for Fujifilm) is now supported on the Cactus V6 II (HSS and TTL).

    Nikon D750 users please read this thread: 

    Fujifilm EF-X500 users please read this thread:

    Feel free to suggest an improvement or share product ideas. Contact us directly at info@cactus-image.com.  At Cactus, we listen. 
  • i too cannot get the CACTUS FIRMWARE UPDATER V1.08 to see my attached V6 II, even tho the red LED is flashing, i am running a Mac on OS 10.11.6

    arrrgh!!!
  • btw the devices are brand new, only got them 2 days ago, the firmware on them is v1.1.007

  • Hi there @aaaashy, would you have a different mini-USB cable to test?

    If not, you can always get one at the Cactus Store:

    Thank you. 
    Antonio Lao
    Brand Manager
    _____________

    To help us better help you, always state the exact firmware version installed on your Cactus device(s), such as: "1.1.013", "FUJ.1.002", "v.103".

    For the time being, Cactus V6 (MK1) running on firmware version 2.1.001 can be triggered by a V6 II (MK2) running on Multi-brand HSS firmware (e.g. 1.1.013) and not by X-TTL firmware versions: PEN.A.001 and OLY.A.001.  No schedule has been released yet. 

    Cactus RF60X / RF60 Firmware versions A01 and A02 currently ONLY works with PEN.A.001 and OLY.A.001.  Other "A" version of X-TTL firmware will be released soon. For both Multi-brand HSS and X-TTL firmware versions (FUJ, SIG, SON), install firmware version 103 / 205 on your RF60X / RF60.

    Cactus RF60 is now an off-camera TTL flash with firmware version 205 or later!

    Metz M400 (for Fujifilm) is now supported on the Cactus V6 II (HSS and TTL).

    Nikon D750 users please read this thread: 

    Fujifilm EF-X500 users please read this thread:

    Feel free to suggest an improvement or share product ideas. Contact us directly at info@cactus-image.com.  At Cactus, we listen. 
  • I am using a Windows 10 machine and the updater software also does not recognize that my devices are connected (both of my Cactus v6 flashes and the V6II transceiver). I have tried two different USB cables, and have followed all of the steps. I am having a lot of problems with my V6II and I would like to try to update the firmware before sending it back to see if updating solves it's problems.
  • @ekconrad,

    Try downloading / reinstalling the Firmware Updater, but this time, disable any anti-virus programs you may have running in the background, such as Norton or MaAfee. Just disable it for 10-15 minutes. Because during the installation, it will install the drivers. However most anti-virus programs picks this up as a threat (perhaps because we haven't paid them money?), which obviously it is not a threat.

    Give that a try and the computer will recognize your V6 II.

    Thank you.

    Antonio Lao
    Brand Manager
    _____________

    To help us better help you, always state the exact firmware version installed on your Cactus device(s), such as: "1.1.013", "FUJ.1.002", "v.103".

    For the time being, Cactus V6 (MK1) running on firmware version 2.1.001 can be triggered by a V6 II (MK2) running on Multi-brand HSS firmware (e.g. 1.1.013) and not by X-TTL firmware versions: PEN.A.001 and OLY.A.001.  No schedule has been released yet. 

    Cactus RF60X / RF60 Firmware versions A01 and A02 currently ONLY works with PEN.A.001 and OLY.A.001.  Other "A" version of X-TTL firmware will be released soon. For both Multi-brand HSS and X-TTL firmware versions (FUJ, SIG, SON), install firmware version 103 / 205 on your RF60X / RF60.

    Cactus RF60 is now an off-camera TTL flash with firmware version 205 or later!

    Metz M400 (for Fujifilm) is now supported on the Cactus V6 II (HSS and TTL).

    Nikon D750 users please read this thread: 

    Fujifilm EF-X500 users please read this thread:

    Feel free to suggest an improvement or share product ideas. Contact us directly at info@cactus-image.com.  At Cactus, we listen. 
Sign In or Register to comment.