Problems + Cactus V6II rotary dial does not work.

I ordered the Lighting Kit A from you guys and the rotary dial on one of the V6II does not cycle through or adjust any options. It will click in to select but I can not cycle thru the menus or flash power or anything. 

Thats one V6II

One of the others I received simply will not find the fuji Xpro2 camera I have it attached to. No matter how i turn on both the V6 and the camera (as instructed) or otherwise.... it will not connect. I've even tried moving it around in the hotshot and it still won't work. Please help.
Tom

Comments

  • I've just tried a V6ii on an XPro2 and can confirm it works. The trick seems to be to make sure the V6 is firmly locked onto the cameras hotshoe, which means V6's locking lever will end up over the shutter speed dial. Once this is done it works.

    More on this thread : http://www.cactus-image.com/community/discussion/905/xpro-2-sb900-hss-did-work-but-but-now-doesn-t
  • @tjfbryant I am sorry to hear about this. Are you able to rotate the wheel smoothly? If indeed there's a rotation contact issue, if you have set the V6 II to TX mode, rotating the dial does not change the power outputs?

    I suspect it's a hardware problem, but just in case it's software, you can do a factory reset using the shortcut key: press group A and B buttons as you switch to either TX/RX mode.

    As for Fujifilm, their hot shoe contacts are relatively small so they must align with the V6 II. As @leoklein suggested, often by inserting the V6 II fully into the hot shoe helps the V6 II to stay in place. 

    Please let us know if this helps.  Thank you!
    Antonio Lao
    Brand Manager
    _____________

    To help us better help you, always state the exact firmware version installed on your Cactus device(s), such as: "1.1.013", "FUJ.1.002", "v.103".

    For the time being, Cactus V6 (MK1) running on firmware version 2.1.001 can be triggered by a V6 II (MK2) running on Multi-brand HSS firmware (e.g. 1.1.013) and not by X-TTL firmware versions: PEN.A.001 and OLY.A.001.  No schedule has been released yet. 

    Cactus RF60X / RF60 Firmware versions A01 and A02 currently ONLY works with PEN.A.001 and OLY.A.001.  Other "A" version of X-TTL firmware will be released soon. For both Multi-brand HSS and X-TTL firmware versions (FUJ, SIG, SON), install firmware version 103 / 205 on your RF60X / RF60.

    Cactus RF60 is now an off-camera TTL flash with firmware version 205 or later!

    Metz M400 (for Fujifilm) is now supported on the Cactus V6 II (HSS and TTL).

    Nikon D750 users please read this thread: 

    Fujifilm EF-X500 users please read this thread:

    Feel free to suggest an improvement or share product ideas. Contact us directly at info@cactus-image.com.  At Cactus, we listen. 
Sign In or Register to comment.