Cactus V6 II freezing X-Pro2 during "Learn" set up for HSS

I can't get the Cactus V6 mark II to work with my X-Pro2 and 2 Cactus RF60 flash units (both now running firmware 2.02) Works well at 1/250 but can't complete the set up for hss procedure. When I set it to do the "Learn" shot at 1/1000 the X-Pro 2 shutter refuses to fire either locking up the shutter button or just making it not fire the camera even when the shutter is fully depressed. I have to turn the X-Pro 2 off and on again to free it up.

Then the brand new cactus V6 II unit's on-off switch stopped working after 1 hour and I am awaiting a replacement unit now. I had the unit set to Fuji camera, auto flash detect, force hss, and the X-Pro2 set to force flash (also tried commander mode).

What could be the issue? any ideas? Any help appreciated.

Comments

  • Hello @Shotem

    What firmware version are you running on your X-Pro2?

    The way how your camera behaved seems as if it's running on a beta firmware from Fujifilm? If that's the case, please try a public firmware version.

    Also please adjust shooting mode to Single Shot and set to mechanical shutter.

    Thank you and I look forward to hearing your test results.
    Antonio Lao
    Brand Manager
    _____________

    To help us better help you, always state the exact firmware version installed on your Cactus device(s), such as: "1.1.013", "FUJ.1.002", "v.103".

    For the time being, Cactus V6 (MK1) running on firmware version 2.1.001 can be triggered by a V6 II (MK2) running on Multi-brand HSS firmware (e.g. 1.1.013) and not by X-TTL firmware versions: PEN.A.001 and OLY.A.001.  No schedule has been released yet. 

    Cactus RF60X / RF60 Firmware versions A01 and A02 currently ONLY works with PEN.A.001 and OLY.A.001.  Other "A" version of X-TTL firmware will be released soon. For both Multi-brand HSS and X-TTL firmware versions (FUJ, SIG, SON), install firmware version 103 / 205 on your RF60X / RF60.

    Cactus RF60 is now an off-camera TTL flash with firmware version 205 or later!

    Metz M400 (for Fujifilm) is now supported on the Cactus V6 II (HSS and TTL).

    Nikon D750 users please read this thread: 

    Fujifilm EF-X500 users please read this thread:

    Feel free to suggest an improvement or share product ideas. Contact us directly at info@cactus-image.com.  At Cactus, we listen. 
  • Ver 1.0.2, I don't have access to beta software,  I only use single shot, and I am on MS only. the new V6II arrives in  a few days (the on -off switch on the first one failed )
  • Thanks @Shotem, that's werid then. because your experience is very similar to X-T2 and X-Pro2 on firmware version fitted with their EF-X500 flash.

    Please keep us posted if the new V6 II unit.

    Thanks!
    Antonio Lao
    Brand Manager
    _____________

    To help us better help you, always state the exact firmware version installed on your Cactus device(s), such as: "1.1.013", "FUJ.1.002", "v.103".

    For the time being, Cactus V6 (MK1) running on firmware version 2.1.001 can be triggered by a V6 II (MK2) running on Multi-brand HSS firmware (e.g. 1.1.013) and not by X-TTL firmware versions: PEN.A.001 and OLY.A.001.  No schedule has been released yet. 

    Cactus RF60X / RF60 Firmware versions A01 and A02 currently ONLY works with PEN.A.001 and OLY.A.001.  Other "A" version of X-TTL firmware will be released soon. For both Multi-brand HSS and X-TTL firmware versions (FUJ, SIG, SON), install firmware version 103 / 205 on your RF60X / RF60.

    Cactus RF60 is now an off-camera TTL flash with firmware version 205 or later!

    Metz M400 (for Fujifilm) is now supported on the Cactus V6 II (HSS and TTL).

    Nikon D750 users please read this thread: 

    Fujifilm EF-X500 users please read this thread:

    Feel free to suggest an improvement or share product ideas. Contact us directly at info@cactus-image.com.  At Cactus, we listen. 
  • Everything  except HSS works on the new cactus V6II and the X-Pro2. It will not complete the hss learn set up if forced hss in set to on because the shutter cannot take a shot. If hss forced is set to off when setting up the learn shot then the shot executes but a completely black screen is captured and no subsequent captures above 1/250 work  bars and completely black. I tried setting it up numerous times and have factory reset  the device 5 or 6 times. I tried it set as Fujifilm camera and auto detect flash and auto detect camera and auto detect flash. 

    From my point of view the Cactus V6 II and the Fujifilm X-Pro2 with firmware 1.02 does not work in hss.
  • with the cactus RF60 flash units running 2.0.2 firmware ( I have not tried with other flash brands, I bought the cactus units specifically to do this.)
  • Just updated Cactus V6II firmware, still does cannot complete HSS Learn setup but at least the shutter does not freeze anymmore.
Sign In or Register to comment.