Using two V6 II transceivers with a Pentax K-1 and a Metz 52-AF1 flash (Pentax)

I am unable to trigger the Metz Flash with the shutter of my K-1.  I have one V6 II configured as a TX with a Pentax camera system and a Pentax Flash system on the K-1 hotshoe. On the Metz hotshoe I have the other V6 II configured as a RX with a Pentax Flash system (pentax auto profile). I can control the Metz flash in manual, TTL, and TTL HSS modes on the flash. I can manually trigger the flash from the test button on the V6 II TX on the camera. I can control the zoom and power of the flash from the V6 II TX on the camera. The camera is in manual mode, 1/200 sec shutter and f 7.1, ISO 100. When I press the shutter button on the camera, both V6 II briefly show a green light on the Status LED indicator. Both V6 II have been updated to the latest firmware. Help!

Comments

  • OK, it is working now. I tried the V6 II on my K-5iis and it triggered the flash. So, i put it back on the K-1 and it worked. Regardless of the mode of the Metz flash, the V6 II now triggers the flash with the K-1 shutter. It works all the way up to 1/8000 of a sec with no banding at any power level I put the flash at. In TTL modes it correctly shows the power level. In manual mode it does not show the correct power level but it still controls power and zoom functions correctly, FYI.  I think there is some marginality in the mechanical contacts between the V6 II and the Pentax hotshoes.
  • Glad to know it works now.
    In TTL modes it correctly shows the power level. In manual mode it does not show the correct power level but it still controls power and zoom functions correctly...
    The flash should always be in TTL mode.
    ...  I think there is some marginality in the mechanical contacts between the V6 II and the Pentax hotshoes.
    That's right. The locking pin does not aligned with the V6 II's so the V6 II may wobble off the alignment during use if it's not locked securely. So do make sure the V6 II is fully inserted on the camera hot shoe and also securely lock it in place.

    Thank you!
    Antonio Lao
    Brand Manager
    _____________

    To help us better help you, always state the exact firmware version installed on your Cactus device(s), such as: "1.1.013", "NIK.A.001", "v.103", or "A06".

    TTL or HSS not working on Cactus V6 II and V6 IIs? Be sure to check hot shoe connectivity by doing the <CAMERA INFO> check.

    Feel free to suggest an improvement or share product ideas. Contact us directly at info@cactus-image.com.  At Cactus, we listen. 
Sign In or Register to comment.