Nikon D3, SB900 & SB800, V6 II won't work properly

I have a set V6 1's. Dropped one and it broke sadly. So a bought a new set V6 II's, ok there are not compatible at the moment with the 1's (waiting for the firmware)...but the old camera / flash combo worked as a charm with the old 1's. But now...I simply don't get this camera / flash combo to work with the II's. Tried everything..it does not regulate the flash (EV changes but output doesn't), doesn't trigger it (other config) and TTL pass won't work. Tried the auto profile, selecting the Nikon camera profile, selected the flash profile...It won't simply work even with the latest firmware...

Comments

  • You need to wait for a new firmware for the Cactus V6, not the V6 II.

    I know it's in the fine prints, but they are important to note.
    Antonio Lao
    Brand Manager
    _____________

    To help us better help you, always state the exact firmware version installed on your Cactus device(s), such as: "1.1.013", "NIK.A.001", "v.103", or "A06".

    TTL or HSS not working on Cactus V6 II and V6 IIs? Be sure to check hot shoe connectivity by doing the <CAMERA INFO> check.

    Feel free to suggest an improvement or share product ideas. Contact us directly at info@cactus-image.com.  At Cactus, we listen. 
  • I understood that Cactus V6 firmware will be upgraded, I have patience. But the issue I am having is with two brand new VII units (as mentioned earlier before I bought a set). These new units simply won't get up and running to do the job.
  • Did the V6 TX unit auto-detect the camera as Nikon?
    You may also manually select the camera system.

    I suppose both the SB-800 and SB-900 are set to TTL mode?
    Did you turn on the flash first before switching on the V6 II to RX mode?
    It will auto-detect the flash system and applies an AUTO flash profile.
    You may also manually choose the corresponding flash profile.
    Antonio Lao
    Brand Manager
    _____________

    To help us better help you, always state the exact firmware version installed on your Cactus device(s), such as: "1.1.013", "NIK.A.001", "v.103", or "A06".

    TTL or HSS not working on Cactus V6 II and V6 IIs? Be sure to check hot shoe connectivity by doing the <CAMERA INFO> check.

    Feel free to suggest an improvement or share product ideas. Contact us directly at info@cactus-image.com.  At Cactus, we listen. 
Sign In or Register to comment.