TTL Passthrough doesn't work. HSS-sympathy mode does not work.

I just upgraded the firmware and the behavior, if anything, has gone from bad to worse.

I bought a pair of RF60 & V60. (two of each item)
Initially only one of the V60 would allow TTL passthrough -- and then only intermittently and sometimes scrambled the cameras's shutter speed above the sync speed.  (I am using Pentax K3 with AF540-FGZ on the hotshoe, and the AF540 profile on the V60). After the firmware upgrade, neither unit allows TTL passthrough.

I even have the V60 TX on the camera (also tried with the AF540 on the hotshoe). 
I then have a second V60 RX with another AF540 in the hotshoe.

The remote flash does not fire.  It sounds like the TTL profile will only fire another TTL flash in the remote hotshoe.
Correct?  So the RF60 is useless for actual TTL, assuming the feature worked in the first place.

The documentation on TTL usage with the V60 is really confusing.
Do I need the AF540 or PTTl flash on the hotshoe or does the profile handle all that on its own?

Regardless, I cannot get the remote RF60 to flash in any situation or configuration when the camera is above the sync speed.  This is regardless of using the V60 (with or without the flash in the hotshoe).
Even with only the AF540 in the cameras hotshoe (no V60 involved), there is no delay (50ms - 120ms) that allows HSS sympathy mode to fire the RF60.

The manual is so very ambiguous I cannot make heads or tails of what is supposed to work or how.
It is possible I have a bunch of bad hardware, but I doubt it. 
 I am pretty sure I am just doing something "wrong".

Any help? :-)


  • edited April 2015
    First, your K-3 does not produce a regular trigger signal anymore once the shutter speed is above the sync-speed (1/180s). That's why you cannot trigger a V6 (or RF60) when using shutter speeds faster than 1/180s. Only P-TTL equipment can be triggered with faster shutter speeds. This is a Pentax limitation.

    I recommend using Manual mode (or another mode where you control the shutter speed) to make sure that you don't exceed the sync-speed.

    There are ways to use the RF60 in HSS mode with a Pentax camera. Have a look at the respective section in my RF60 review at pentaxforums and the respective section in my V6 review at pentaxforums.

    Second, the V6 does not support P-TTL via radio communication. The only P-TTL support is via TTL pass-through for a P-TTL flash that is mounted on top of an on-camera V6. Note that for this to work optimally, the flash profile of the on-camera transmitter should be set to "AF540-FGZ" in your case. This should result in the AF540-FGZ working as if it were mounted on the camera directly. You still cannot fire off-camera flashes via radio alone when going beyond the sync-speed, though (see above).

    All off-camera flashes are controlled manually (from the V6 or an RF60 in master mode). I trust you got your RF60s to work, correct?

    For remote controlling the AF540-FGZ, your off-camera V6 receiver must be configured to use the AF540-FGZ flash profile. Once you have configured the V6 correctly, you will be able to adjust the AF540-FGZ's power levels from a V6 transmitter. You can check the radio communication (e.g., whether you have the same channel setting and whether the group of the receiver is active) by pressing the test button on the V6 transmitter. This should fire the AF540-FGZ (unless the respective group has been deactivated).

    Note that you can downgrade to an earlier firmware with the firmware updater. If everything else fails and you feel that the latest firmware is to blame, you can load an older version to your V6 units again.
  • Yeah, I know Pentax cripples their system by disabling flash it over 1/800.
    I am hoping to find some way to get a remote flash working via HSS without optical.

    I do not understand why there is a AF540 profile in the V6 if it cannot transmit PTTL over radio in the first place?  What good is it?  

    I assume it merely allows certain pins to work so you do not risk shorting or confusing the flash by improper use of pins for other brands?

    So there is no way, without optical slave, to get one of the remote flashes to fire with my shutter speed above 1/180?

    That answers some questions.  Thanks for the help.
    If the pass-through worked, I would probably keep the set as good priced manual flashes and be able to use the V6 to fire the camera remotely. :-) 
     (since I did get two sets, that would have been an option.)

  • There are only two ways, when using a Pentax DSLR, to achieve HSS with external flashes without involving P-TTL cables:
    1. The simultaneous triggering of flashes (with a delay) and the camera.
    2. Optical triggering (either on the pre-flash or the main flash with the latter only supported for shutter speeds up to 1/2000s or so).

    If you are concerned about not being able to use optical triggering for triggering external flashes, try the approach I described in my review that involves triggering a V6 optically (right next to the on-camera flash) and using this V6 to trigger all off-camera flashes via radio. You can even put the V6 on the camera's hot-shoe, enable TTL pass-through, and guide the light from an HSS-capable flash mounted on top of the V6 into the V6 sensor. This works very well and the only downside is that you have to use a full P-TTL flash on camera, just to get a trigger signal for the V6.

    The AF540 FGZ profile is provided so that a V6 can control the power level of an AF540 FGZ. Without such a profile, you would not be able to get calibrated light output levels from an attached flash.

    So it has a purpose for enabling precise manual control over power levels, but does not support automatic exposure control P-TTL style.

    If you are using multiple off-camera flashes, you will be much better of using manual level control anyhow. P-TTL offers precious little in establishing lighting ratios between multiple flashes. It is a very poor system that only works well for a very limited range of applications and multi off-camera flash control is not one of them.

    You should be able to get the TTL pass-through to work. I've used it a lot with my Pentax gear. If you see the small "TTL" symbol to the left of the V6 display, but the camera does not recognise a flash mounted on top of the (on-camera) V6, try downgrading to an older firmware. I don't know of any respective bugs in the latest version, but I do now that P-TTL pass-through worked for me with very recent firmware versions (I haven't tried the latest one, though).

  • OK, firstly I got the pass-through to work. RTFM!  I read the manual again and found that I probably accidentally held the menu button too long and turned off TTL passthrough (yes, on both remotes and at about the same time.  WTF?).  Ugh. :-)

    Now I am running into issues with the optical sensors on both remotes. (with TTL passthrough on and off.) 
    It appears either TTL or radio can be an option but not both??  Or is it merely a display limitation?

    Anyway, I am CERTAIN it is something I am doing, but damn I am having a tough time. I would bet if I read the manual a fourth time something will pop out to me and I'll get it working.  

     If I can fire two remote flashes via radio while the AF540 is in the hotshoe in HSS mode, even if it means duct-taping the remote to the flash, I will be good to go.

    I work in real life as a software engineer with stuff complex enough to melt most people's brains and manuals written by developers (i.e. half-giberish)...   so honestly, this *should* be simple. :-) :-) :-)

    Thanks for the repeated assistance!
  • edited April 2015
     So I have the RF60 set Slave mode to [S]. Not in HSS. Optical Slave is off. 
    On the V6 I have Optical Slave S1 (first flash).
    With shutter speed below 1/180 the RF60 fires.

    Next I put the AF540 in HSS mode and set the shutter speed to 1/200s
    RF60 is still in Slave Mode [S]. HSS turned On. Optical slave Off. Power 1/128.
    The V6 is set to optical slave set to S2 Main flash. 
    RF60 never fires. The camera does not see a flash, nor do I.  

    It seems like this should work. 
    I cannot get other combinations of HSS on/off, Optical Slave off/S1/S2 to work.
    I also set V6 in S1 as well as S2 mode with 95ms delay. No luck.
    Do you see something I am doing wrong?
  • edited April 2015
    If you have the shutter speed below (or equal to) 1/180s and a V6 mounted on the camera, the V6 will receive a trigger signal through the hot-shoe. No optical triggering required.

    Once we go past the sync speed, the fun begins...

    In another post you said you got optical triggering on the main flash to work (e.g. 1/3200s). Was that just with RF60s and not involving the V6? Or can you not replicate the success you once had?

    You write the AF540 FGZ is in HSS mode but you don't specify how it is connected to the camera. If it does not sit on the camera directly, but on an inbetween V6, the latter V6 must be set to TTL pass-through.

    Do you see the AF540FGZ emit a pre-flash and main-flash? If the AF540FGZ does not emit a flash at 1/200s, the optical triggering cannot work.

    To keep things simple, you should not use an older lens (e.g., ones with no "A" contact). Such an old lens may stop the camera from using P-TTL mode and you hence won't get a pre-flash and main flash out of the AF540FGZ. The "S2 MAIN FLASH" triggering may only work if there actually is a pre-flash (I'd have to confirm this, not 100% sure at the moment).

    If you don't have a modern lens, select "S1 FIRST FLASH" but still keep the delay at 0.

    The next item on the check list is to ensure that the V6 that you want to use to trigger the external flashes with can see the light emitted by the AF540FGZ. You may need to get the optical sensor at the front of the V6 fairly close to the head of the AF540FGZ, as the V6's sensor is not very sensitive (optimised for flash profiling, not for optical triggering).

    I typically just point the V6's sensor to the flash head in rather close proximity. If you don't want to do that, you can mount the V6 on the camera, set it to TTL pass-through mode, mount the AF540FGZ on top of the V6 and use a big piece of paper or so to guide the light from the AF540FGZ into the sensor of the V6. I've done that successfully, but I'd try to trigger the V6 first and then find more convenient solutions.

    Start with slow shutter speeds (e.g., 1/200s) , 0 delay, and S2 (MAIN FLASH) triggering first (provided you are using a relatively modern lens).

    Once that works, you can proceed to S1 (FIRST FLASH) triggering but then need to find the correct delay value. 95ms sounds like a good starting point and you should be able to search around in increments of three (3) in order to find the right time (which will only work optimally for a particular aperture, so make sure you are using a mode that keeps both shutter speed and aperture fixed).

  • edited April 2015
    When attempting to work with the V6, the AF540 is in the V6's hotshoe.  Passthrough and HSS on the AF540 seems to work well now that I realized I had accidentally turned off that mode on both V6 remotes at the same time. (derp) :-)

    I have no really old gear. Using DA* 16-50mm lens, mainly.

    I FINALLY got the V6 to fire the remote RF60, but there seems to be a delay. (DELAY is set to 0 or Off for both the V6 and the RF60.)

    K3 in manual mode, shutter speed above 1/180.
    AF540FGZ in hotshoe set to HSS. (and works)
    V6 about 2-3 feet in front of the flash. 
     - set to S2 main flash, Delay is off
    RF60 set to Slave mode (not in HSS)
    - delay is 0
    - slave mode is off
    This works but the flash fires noticeably some time after the shutter.

    I tried setting other values, i.e. set RF60 in HSS with no slave, etc... 
    In no other manner can I get RF60 to flash via V6 when shutter speed is above 1/180.

    Any ideas why I might be getting a delay on fire?  
    Batteries are freshly charged in all four devices. 

  • edited April 2015
    Ahha!  it works!
    Almost same setup I described above, but only if I put the V6 directly in front and touching the AF540's flash element.   OK, maybe if its an inch away.
    Wow!  Not very useful in real life.  

    So, I velcro'd the V6 to the top of my AF540 with a 2"x2" bent piece of paper on top of that and hanging over the light sensor such that it will reflect some of the light from the AF540.

    Nearly 100% success even at 1/8000s shutter speeds!  
     Of ten shots, one had a black bar visible.  For my uses, that will likely be acceptable.

    Anyway... thanks for the help. At least I know what is going on now.

    End setup:
    AF540 in HSS mode, of course.
    Shutter speed above 1/180.

    V6 in S2 (main flash) mode. No delay.
    Optical sensor within an inch of the flash head.

    RF60 in HSS mode, no optical slave. no delay.
  • Hi there Everyone....
    I'm very happy with my recent purchase of 
    two V6 units and two RF-60 flashes.

    I did notice one HUGE problem with the V6 that is causing me a bit of concern.
    I have the Olympus OMD EM-1. I inserted the V6 into the cameras hot shoe and 
    the V6 unit DOES trigger flashes off camera. 

    HOWEVER... I'm having an issue with the way the V6 slides into the Olympus OMD EM-1. 

    It will not slide all the way into the hotshoe. There is a bit of room left until the V6 unit 
    can sit flush in the hot shoe, but the V6 unit gets stuck and will not slide in any further.
    It looks and acts as if the pin closest to the front of the V6 unit is getting stuck. I was careful enough to ensure that i retracted the pin by moving the V6 units locking mechanism but the problem persists.
    The problem is the same with both V6 units i own.
    I tried pushing and wiggling the unit with a reasonable amount of SAFE force, but I still 
    can't make it sit in the 
    hotshoe the way ALL other hot shoe devices do.

    I activated the TTL pass through feature on my V6 unit and mounted a Nissin i40 flash 
    on top it. Unfortunately this did NOT work. TTL data was not passing through and the mounted flash would not even fire.

    Perhaps this may have something to do with the way the V6 unit sits on the hot shoe of 
    my Olympus OMD EM-1.

    Any help will be appreciated.
    Thank You in advance.
  • I just made a quick and boring video of the mounting issue.
    I posted it on YouTube.... Here is the link to it. 

    I dont say anything in the video but it's obvious that the V6 unit does not slide in and hit flush to the front of the hot shoe. I then mount in a Cactus RF-60 and instantly it sits in and even makes an audible click sound like it sitting in the right way. 
    You can see how it sits flush to the front of the hot shoe. 
    I think this is the reason I can NOT get TTL pass through to work.
    IF NOT this...
    Then what else can it be???

  • edited May 2015
    I'm having an issue with the way the V6 slides into the Olympus OMD EM-1. 
    It will not slide all the way into the hotshoe.

    Have you checked that it isn't the opposite problem, i.e., that the V6 slides too far into the hot-shoe?

    On the Fuji X-pro someone had to slightly pull back the V6 before the TTL pass-through mode started working. 

  • Good Point....Thank You Class A...
    I did try triggering the Nissin i40 flash as i slid the V6 into the hot shoe. Stopping at different increments to see if I can get it to trigger the flash. Unfortunately... Nothing worked. I did this test whil having TTL pass through activated on the V6 and the Nissin i40 in TTL mode.
    However... I did find out that the Nissin i40 CAN be triggered by the V6 unit while in TTL pass through mode but only if the Nissin i40 is in MANUAL mode. So still, there is no TTL data passed to the Nissin i40.

  • After many attempts... I think it all boils down to the fact that the Nissin i40 model is just not supported by the V6 unit because everything else works beautifully. However, Thanks for the help Class A.
Sign In or Register to comment.