RF60 is not recognized by Cactus Updater

Just bought my first RF60 and V6. The Cactus Updater.app for OSX did recognize and update the firmware of the V6 but did not recognize the RF60. 
I followed the instruction in the manual and on the screen saying: Switch off, Remove batteries,  Connect.

Best Regards


  • I have the same problem with my new RF60 and my new V6.  Have checked USB cable and it works OK with a different device.  Help much appreciated - FitzFoto
  • Is the driver compatible with Windows 8.1?

    The Device Manager shows:
    The drivers for this device are not installed. (Code 28)
    There are no compatible drivers for this device.

    I have run the install three times, downloading anew each time and no joy.
  • FitzFoto, have a look at this thread. There is even a video of how to install the driver under Windows 8 in the last post.
  • Doesn't solve my problem.  No driver needed on OSX and the connection is fine with V6.
    Just problems with RP60.
  • @bwing, that's why I wrote "FitzFoto, ...".

    Hopefully Cactus can respond to your question of whether or not the RF60 should be recognised by the OS X updater.
  • Just received my second RF60, not recognized by update neither.
  • @bwing I just tested my RF60 and it worked fine.

    I took out the batteries from the RF60
    Plug in the USB cable from the RF60 to the Mac
    Open the "Cactus Updater" application
    And instantly I see  "STATUS: Connected"

    At this moment, the LCD of the RF60 does not display anything, even if you switch on the flash.

    Next I went on and after downloading and selecting the latest firmware, clicked the UPDATE button and the RF60 is updated in a couple of seconds. The LCD then turns on all the segment texts briefty then switches on the flash in Local (L) Mode. And the Firmware Updater application says: "STATUS: No device connected"

    I then Exit the Updater and unplugged the USB cable.

    My MacBook Pro is running on OS X Yosemite v 10.10.3.

    What version is your OSX running on?

  • edited May 2015

    So it works generally. I wonder if you plugged it in now, having already the latest firmware, would it still recognize it?

  • @bwing Yes the Firmware Updater Application (on our Macbook) recognized the RF60 as soon as I switched it on, and the RF60 already has version 124 installed.

    Let us know if you need further assistance.

  • Morning everyone,

    I'm afraid I'm facing the same issue. OS X Yosemite 10.10.3.

    My V6s updated with no trouble, so I'm positive the cable, computer, and so on are all good. However, when I connect up either of my RF60s, the updater keeps saying "No device connected".

    How could I debug this?

    Thank you
  • Mine is Imac running 10.10.3.
  • Why has there been no response to this issue? It has been hanging around with no resolution plan or communications strategy since the beginning of May.
  • Is it possible that the Cactus updater does not connect to an RF60 that has current firmware installed? Rather than providing the use with a message, to the effect, "Your firmware is up to date"? Sloppy programming if true, but perhaps an explanation for the inconsistent behaviour.
  • I thought the same but 3 posts above Antonio mentioned that his one is recognized even with the latest firmware.

  • Hey people, our Macbook Pro is also on 10.10.3

    And it has no problem recognizing the RF60, which is almost instant as soon as I plug in the USB cable.  Despite the flash LCD displays nothing but the Firmware Updater says Connected.

    Do you have another Mac computer that you can try? hmm...
  • Same problem here, the updater works fine with the V6 but doesn't recognise the RF60. I'm on Yosemite 10.10.2.
  • Asked my son to install the updater on his windows machine. My RF60 was recognized. I used the same cable.
    So it's an issue with the mac only.
  • @bwing glad to hear you have it sorted out. 

    Anyone out there with a Mac running on 10.10.3 and was able to update the firmware of RF60 successfuly? I don't think it's just us right?

    @Adam have you  tried 10.10.3 yet?

  • My Mac doesn't recognize it either. OSX 10.10.5. The V6 gets recognized.
  • Problem fixed! 

    Download the new Firmware Updater V.1.03:
    http://www.cactus-image.com/Cactus Updater for Mac.zip

    Thank you all!

    @rreopjopo @Adam @Bags @bwing @eenixon @FritzFoto
  • Great, works fine.
    Thank You.

Sign In or Register to comment.