Flash not firing test flash

Hi everyone,

So yesterday I received the RF60 and V6 and recommended Sanyo Eneloop batteries. I attached the V6 to my Fuji X-T1 and mounted the RF60 to a softbox. Setup was very easy and everything seemed to work instantly.

After taking some 20 test shots I noticed that sometimes the flash wouldn't fire and after a while it didn't fire at all. A test flash from the V6 wouldn't fire either.

So then I decided to try the test button on the RF60 itself and BAM, the flash fired. After that I tried the test button on the V6 and BAM it fired, so I started taking pictures and everything was fine untill I had to repeat this process.

After about 30 minutes of shooting the RF60 wouldn't fire at all, test button was red but didn't do anything either. (note: entire shoot was at 1/128 - 1/8). I could however see that the  values I selected on the V6 were changing on the RF60, so there was a connection.

I thought maybe it's overheated or something but today I turned it on again and still no flashes. The battery indicator says the batteries are full and the red light on the test button is lighting up.

Is there something I can do to fix this or is the flash broken?

Thanks in advance!

Tim


Comments

  • Hello Tim,

    I am sorry to hear about this. To test whether there's a hot shoe connection issue between the camera and the V6, besides making sure the V6 is securely mounted (inserted fully) on the camera, check if the LED blinks green on the camera-mounted V6 TX unit when you depress the shutter button. 

    Also try switching to other channels. If you were on Channel 1 now, try Channel 13 or something that's radically different.

    Third is to check the distance between the camera and the RF60.  You may watnt to enable SHORT RANGE mode if you are shooting in close proximity, say 5-10 meters.

    As for testing the RF60, you can try pressing the Test button on the back panel and make sure it's not the batteries or the capacitor that's having the problem firing.

    Thank you and I look forward to hearing your test results.
    Antonio Lao
    Brand Manager
    _____________

    To help us better help you, always state the exact firmware version installed on your Cactus device(s), such as: "1.1.013", "FUJ.1.002", "v.103".

    For the time being, Cactus V6 (MK1) running on firmware version 2.1.001 can be triggered by a V6 II (MK2) running on Multi-brand HSS firmware (e.g. 1.1.013) and not by X-TTL firmware versions: PEN.A.001 and OLY.A.001.  No schedule has been released yet. 

    Cactus RF60X / RF60 Firmware versions A01 and A02 currently ONLY works with PEN.A.001 and OLY.A.001.  Other "A" version of X-TTL firmware will be released soon. For both Multi-brand HSS and X-TTL firmware versions (FUJ, SIG, SON), install firmware version 103 / 205 on your RF60X / RF60.

    Cactus RF60 is now an off-camera TTL flash with firmware version 205 or later!

    Metz M400 (for Fujifilm) is now supported on the Cactus V6 II (HSS and TTL).

    Nikon D750 users please read this thread: 

    Fujifilm EF-X500 users please read this thread:

    Feel free to suggest an improvement or share product ideas. Contact us directly at info@cactus-image.com.  At Cactus, we listen. 
  • Hi Antonio,

    I have tried your suggestions, with the following results:

    - V6 blinks green when I depress the shutter button, this seems to be fine. I don't think the problem is with the V6.

    - I tried all channels, all give the same result: settings get updated on the RF60 but still no flash.

    - Short range doesn't change anything, still settings are changing, flash is not firing.

    As for the RF60:
    - The test button is lighting up red but doesn't do anything. I have changed the batteries with full eneloops, no change, then I changed the batteries to new non rechargeable batteries and still no change.

    I guess that this particular RF60 is faulty and I should return it?

    Thanks
    Tim
  • Hello Tim,

    How far is your camera (V6) from the RF60? Are they more than 15cm apart? Just to be safe you can set them well over a meter and try again.

    To test the mechanical bits of the RF60, mount it directly on your camera hot shoe, set it to M mode, set to power like 1/128 or 1/16, fire a few shots and check if it fires everytime.

    About the Test button on the flash, did you tried pressing the red LED button on the RF60? Would it fire?

    If pressing that button fires a flash but not from a V6 TX unit (set to the same channel / group) by pressing:
    1. Test Button of V6
    2. Camera shutter button
    Then, the RF60 may indeed be faulty. Return it and our dealer would be happy to assist you.

    Thank you again for checking.

    Antonio Lao
    Brand Manager
    _____________

    To help us better help you, always state the exact firmware version installed on your Cactus device(s), such as: "1.1.013", "FUJ.1.002", "v.103".

    For the time being, Cactus V6 (MK1) running on firmware version 2.1.001 can be triggered by a V6 II (MK2) running on Multi-brand HSS firmware (e.g. 1.1.013) and not by X-TTL firmware versions: PEN.A.001 and OLY.A.001.  No schedule has been released yet. 

    Cactus RF60X / RF60 Firmware versions A01 and A02 currently ONLY works with PEN.A.001 and OLY.A.001.  Other "A" version of X-TTL firmware will be released soon. For both Multi-brand HSS and X-TTL firmware versions (FUJ, SIG, SON), install firmware version 103 / 205 on your RF60X / RF60.

    Cactus RF60 is now an off-camera TTL flash with firmware version 205 or later!

    Metz M400 (for Fujifilm) is now supported on the Cactus V6 II (HSS and TTL).

    Nikon D750 users please read this thread: 

    Fujifilm EF-X500 users please read this thread:

    Feel free to suggest an improvement or share product ideas. Contact us directly at info@cactus-image.com.  At Cactus, we listen. 
  • Hi Antonio,

    I have tried again and didn't get the test button to work. I returned the RF60 to the dealer and they replaced it. The new one seems to work fine so far.

    Thanks,

    Tim
  • Hi Tim,

    Great and thanks for posting an update.  Just shout if you need anything else.
    Antonio Lao
    Brand Manager
    _____________

    To help us better help you, always state the exact firmware version installed on your Cactus device(s), such as: "1.1.013", "FUJ.1.002", "v.103".

    For the time being, Cactus V6 (MK1) running on firmware version 2.1.001 can be triggered by a V6 II (MK2) running on Multi-brand HSS firmware (e.g. 1.1.013) and not by X-TTL firmware versions: PEN.A.001 and OLY.A.001.  No schedule has been released yet. 

    Cactus RF60X / RF60 Firmware versions A01 and A02 currently ONLY works with PEN.A.001 and OLY.A.001.  Other "A" version of X-TTL firmware will be released soon. For both Multi-brand HSS and X-TTL firmware versions (FUJ, SIG, SON), install firmware version 103 / 205 on your RF60X / RF60.

    Cactus RF60 is now an off-camera TTL flash with firmware version 205 or later!

    Metz M400 (for Fujifilm) is now supported on the Cactus V6 II (HSS and TTL).

    Nikon D750 users please read this thread: 

    Fujifilm EF-X500 users please read this thread:

    Feel free to suggest an improvement or share product ideas. Contact us directly at info@cactus-image.com.  At Cactus, we listen. 
Sign In or Register to comment.