What firmware version for ...

Canon 7D Mk 1, Canon 600EX-RT.

Setup is relay mode, but the latest version of the firmware rendered remote power control of the flash inoperable.
Adjusting flash power between 1/128 and 1/1 via the remote transmitter adjusts the corresponding power levels on the camera and flash correctly, but the flash itself does not adjust power.  All shots are illuminated exactly the same.



  • ... seems that the flash is being triggered either before or after the shutter is released.  Two of my V6 transmitters report firmware v1.1.016, the third reports USE RF CH . 16.  

    All test shots at 1/125, f2.8.

    Even using CH 16 makes no difference.  The flash is triggered out-of-sync with the shutter, rendering dark images.
  • ... he transceiver controlling the 600EX-RT has started adjusting flash power, but the flash is still triggering ahead of the shutter.  

    As a test, I mounted a v6 on the camera hot shoe and stuck the 600EX-RT on another.  Took 10 shots at each power level: 45% fail rate at most flash power settings. 100% fail rate between full power and 1/4 power.

    Think I should back up to a way earlier firmware release?  This weirdness only started occurring after I updated to the latest release. 
  • edited December 2015
    The relay mode enables the V6 to be a wireless shutter release while triggering other speedlite's at the same time. You also need a shutter release cable, connecting the V6 to the camera shutter release socket. In regular setup without relay mode, you need two unit of flash transceiver, one for the wireless shutter release and another one for flash triggering. With relay mode enable, you only need one unit of V6. 

    However, I guess you don't intent to use the wireless shutter release. You may disable the RELAY mode in both V6 units. In addition, I lay out the steps in the user manual here for remote power control.

    1. Connect the flash units to the V6. 
    2. Switch on the flash units in TTL mode. Then switch on the V6 in RX mode. 
    3. Choose the correct flash prof ile for each V6.

    Now you may not find this steps on your printed user manual. You can download the latest PDF version here: 

    I hope that helps. Cheers!
    Ray Chan

    Senior Product Specialist
    Harvest One Limited
  • Two of my V6 transmitters report firmware v1.1.016, the third reports USE RF CH . 16.
    If you see "USE RF CH. 16." you are half-pressing the test button as well.

    Make sure to only press A & D while turning the V6 on.

    BTW, the latest firmware version is V1.1.019.

    If the flash is firing ahead of the camera, the problem might be that you are triggering it with your remote shutter release V6 at the same time as you are triggering the camera. Since the camera has shutter lag, it will always be behind. For remote triggering to work, both the remote shutter release V6 (Tx) and the on-camera V6 (Tx) must be in "RELAY" mode.

    Does normal triggering (just a V6 on the camera's hot-shoe and the 600EX-RT on a V6 in Rx mode) still work? Make sure that neither of the V6 is in "relay" mode and that none of them has a delay value set. The latest firmware will show any delay value other than "OFF" as "DEL" as a status in the display, but earlier firmware versions did not do that.

    Also make sure to select the right flash profile for the 600EX-RT on the V6 in Rx the flash is mounted on.

    I'd try that simple scenario first and then proceed to using a remote radio trigger approach (using relay mode) after confirming that the basics are still working.

    If V1.1.019 does not work, try any of the older available firmwares. The Updater should allow you to pick a number of the versions that were made available earlier.
  • Thank you for the detailed responses.  I have the latest User's Manual and am aware of the RX startup sequence. 

    @Class A ... I did test the configuration of a TX on the hot shoe and an RX on a 600.  Some shots worked perfectly; others didn't. 
    I'm not gentle with my 10 Cacti ... they get buried in snow, dropped, rained on and yet have worked perfectly.  The unit I had mounted on my hot shoe showed a "bit" of usage, so I swapped it out and operations went back to normal. I should have tried the swap first, but given the reliability I've experienced with my Cacti it simply didn't dawn on me that the unit I had on the hot shoe may have, ahem, been at one time been somewhat abused.

    Anyway, my dealer looked at the unit, shook his head, and handed me a new V6 ... no questions. 

  • You have 10 Cacti?!?

    Is it you Joe (McNally)? ;) :D

    Glad you solved the issue. :)
Sign In or Register to comment.