V6 II S

Would it be possible to find out if the upcoming V6IIS for Sony cameras will be a Sony only model or its it a a standard V6II with added Sony capability i.e. will it work only with Sony or will it work with other bodies such as Fuji or Olympus etc as well.  

Any help appreciated. 

Comments

  • Hello @stoneysnapper

    It's going to be a Sony-only model, with both the top and bottom hot shoes bearing the Sony Multi Interface (MI) shoe design.

    So for your Fuji and Olympus cameras, you will need the V6 II.
    Antonio Lao
    Brand Manager
    _____________

    To help us better help you, always state the exact firmware version installed on your Cactus device(s), such as: "1.1.013", "FUJ.1.002", "NIK.A.001", "v.103".

    For the time being, Cactus V6 (MK1) running on firmware version 2.1.001 can be triggered by a V6 II (MK2) running on Multi-brand HSS firmware (e.g. 1.1.013) but not by X-TTL firmware versions:  PEN.A.001 NIK.A.001 OLY.A.001.  No schedule has been released yet for an "A" version firmware on the V6 (MK1). 

    Cactus RF60X / RF60 Firmware versions A04 and A03 currently ONLY works with PEN.A.001 NIK.A.001 and OLY.A.001.  Other "A" version of X-TTL firmware will be released soon. For both Multi-brand HSS and X-TTL firmware versions (FUJ, SIG, SON), install firmware version 103 / 205 on your RF60X / RF60.

    Nikon D750 users please read this thread: 

    Fujifilm EF-X500 users please read this thread:

    Feel free to suggest an improvement or share product ideas. Contact us directly at info@cactus-image.com.  At Cactus, we listen. 
  • Hello @stoneysnapper

    It's going to be a Sony-only model, with both the top and bottom hot shoes bearing the Sony Multi Interface (MI) shoe design.

    So for your Fuji and Olympus cameras, you will need the V6 II.
    Ok thanks Antonio. I've decided to sell my Fuji now anyway so one less problem to worry about. Thanks for info. 
  • When will the V6 MKll S be shipping?

  • Hello @Graham_Darlington

    There's been a bit of delay with debugging and we hope to complete final checks within the next couple month.

    As soon as we have an official date we will annouce it. Thank you!
    Antonio Lao
    Brand Manager
    _____________

    To help us better help you, always state the exact firmware version installed on your Cactus device(s), such as: "1.1.013", "FUJ.1.002", "NIK.A.001", "v.103".

    For the time being, Cactus V6 (MK1) running on firmware version 2.1.001 can be triggered by a V6 II (MK2) running on Multi-brand HSS firmware (e.g. 1.1.013) but not by X-TTL firmware versions:  PEN.A.001 NIK.A.001 OLY.A.001.  No schedule has been released yet for an "A" version firmware on the V6 (MK1). 

    Cactus RF60X / RF60 Firmware versions A04 and A03 currently ONLY works with PEN.A.001 NIK.A.001 and OLY.A.001.  Other "A" version of X-TTL firmware will be released soon. For both Multi-brand HSS and X-TTL firmware versions (FUJ, SIG, SON), install firmware version 103 / 205 on your RF60X / RF60.

    Nikon D750 users please read this thread: 

    Fujifilm EF-X500 users please read this thread:

    Feel free to suggest an improvement or share product ideas. Contact us directly at info@cactus-image.com.  At Cactus, we listen. 
  • i own the catcus v6 trigger and recently bought a sony camera. if i purchased a v6 IIs would it be compatible with my v6 so i can still trigger my strobes? 
  • Hello @mrccupid3

    Your V6 works with Sony cameras too. 
    Despite the centre pin on Sony camera is slightly off-centered than standard ISO hot shoes, it still aligns with V6's bottom hot shoe's centre pin.

    If you need HSS, you need to upgrade your entire set to the new V6 IIs.

    FYI existing V6, after new firmware in October 2016, will only support Power Sync - power boost over full power (normal flash pulse), and not the typical HSS (long pulsing flash).

    Do your strobes support HSS natively? Is there a HI-Speed / HSS function that you can turn on? If so, you may plug the V6 IIs (RX) directly to sync port of the strobe. Power has to be adjusted on the strobe.

    However if your strobe does not support HSS natively, in order to support HSS, it has to have a flash duration of 1/100s or longer, at t0.1.

    Hope this helps.
    Antonio Lao
    Brand Manager
    _____________

    To help us better help you, always state the exact firmware version installed on your Cactus device(s), such as: "1.1.013", "FUJ.1.002", "NIK.A.001", "v.103".

    For the time being, Cactus V6 (MK1) running on firmware version 2.1.001 can be triggered by a V6 II (MK2) running on Multi-brand HSS firmware (e.g. 1.1.013) but not by X-TTL firmware versions:  PEN.A.001 NIK.A.001 OLY.A.001.  No schedule has been released yet for an "A" version firmware on the V6 (MK1). 

    Cactus RF60X / RF60 Firmware versions A04 and A03 currently ONLY works with PEN.A.001 NIK.A.001 and OLY.A.001.  Other "A" version of X-TTL firmware will be released soon. For both Multi-brand HSS and X-TTL firmware versions (FUJ, SIG, SON), install firmware version 103 / 205 on your RF60X / RF60.

    Nikon D750 users please read this thread: 

    Fujifilm EF-X500 users please read this thread:

    Feel free to suggest an improvement or share product ideas. Contact us directly at info@cactus-image.com.  At Cactus, we listen. 
Sign In or Register to comment.