V6 OK button not working?

I have a V6 and 2x RF60s. I'm fairly new to the system, but I've used them sucessfully quite a few times before.

I just got my V6 out after a few weeks and a can't seem to enter any of the menus. Clicking with the dial wheel or OK button doesn't seem to do anything. Sometimes it starts up with the dial locked, sometimes not. The dial and other buttons seem to work ok.

I tried a firmware update which said sucessful, but if I turn on the power while holding A+D I get the message "APP_CRC: 0xCOCFEF", instead of the firmware verion.

Am I doing anything wrong, is there a hard reset I can try?


Cactus V6, 2x RF60, Pentax K-1, Panasonic GX80.


  • edited October 2016
    I don't know what that message means, but "CRC" could stand for "cyclic redundancy check" and if that fails it may be the case that there is something wrong with the firmware.

    Perhaps you are just somehow provoking the device to show the CRC calculation result? That wouldn't indicate an error then. Unless you are inadvertently pressing another button, it seems there is a hardware issue that results in one or more buttons always considered to be pressed.

    I'd try
    • using the Firmware Updater to select the latest firmeware (V1.1.004) and upload it to the trigger.
    • using fresh batteries or freshly charged rechargables.

    However, it sounds as if you have a hardware issue.

    P.S.: The only "reset" I am aware of has to be accessed through the menu system.

  • Hi Class A, I've tried fresh batteries and firmware update to no avail. I guess one of the buttons is stuck down electrically (even though the dial and OK button both click), as the it first starts up it's locked, the second time it starts unlocked, the next locked etc.

    Looks like I'll have to send it in.

    P.S. Thanks from a fellow Pentax user.

    Cactus V6, 2x RF60, Pentax K-1, Panasonic GX80.
  • Hi @weinelm,

    Indeed it sounds like a hardware issue. do send your V6 in for repair. Or you may also contact the dealer you bought it from if it's quicker that way.

    For more info please email us at info@cactus-image.com.

    Antonio Lao
    Brand Manager

    To help us better help you, always state the exact firmware version installed on your Cactus device(s), such as: "1.1.013", "NIK.A.001", "v.103", or "A06".

    TTL or HSS not working on Cactus V6 II and V6 IIs? Be sure to check hot shoe connectivity by doing the <CAMERA INFO> check.

    Feel free to suggest an improvement or share product ideas. Contact us directly at info@cactus-image.com.  At Cactus, we listen. 
Sign In or Register to comment.