Beta firmware for Fujifilm HSS...where to download?

Hi,

I'm new to Cactus products, so sorry if this has been discussed, but i'm trying to locate the beta firmware for the Fujifilm cameras to work with the V6 II triggers in HSS.  I'm told you have to email Cactus support, but I can't even find a support section.  Does anyone know how I can get my hands on this beta firmware?

Thanks!

Comments

  • Hi @syrcular,

    Here it is:
    http://www.cactus-image.com/community/discussion/1005/fujifilm-x-t2-compatibility-with-cactus-v6-ii-to-support-hss/p1

    You need to send an email to us and we will send you the instructions.

    Thank you!
    Antonio Lao
    Brand Manager
    _____________

    To help us better help you, always state the exact firmware version installed on your Cactus device(s), such as: "1.1.013", "FUJ.1.002", "v.103".

    For the time being, Cactus V6 (MK1) running on firmware version 2.1.001 can be triggered by a V6 II (MK2) running on Multi-brand HSS firmware (e.g. 1.1.013) and not by X-TTL firmware versions: PEN.A.001 and OLY.A.001.  No schedule has been released yet. 

    Cactus RF60X / RF60 Firmware versions A01 and A02 currently ONLY works with PEN.A.001 and OLY.A.001.  Other "A" version of X-TTL firmware will be released soon. For both Multi-brand HSS and X-TTL firmware versions (FUJ, SIG, SON), install firmware version 103 / 205 on your RF60X / RF60.

    Cactus RF60 is now an off-camera TTL flash with firmware version 205 or later!

    Metz M400 (for Fujifilm) is now supported on the Cactus V6 II (HSS and TTL).

    Nikon D750 users please read this thread: 

    Fujifilm EF-X500 users please read this thread:

    Feel free to suggest an improvement or share product ideas. Contact us directly at info@cactus-image.com.  At Cactus, we listen. 
  • Hi,
    Is it okay for me to get the update? I own Fuji X-T2 and Cactus V6ii with two RF60
    Thanks
    Best reagards
    Glenn
  • Antonio said:

    Hi @syrcular,

    Here it is:
    http://www.cactus-image.com/community/discussion/1005/fujifilm-x-t2-compatibility-with-cactus-v6-ii-to-support-hss/p1

    You need to send an email to us and we will send you the instructions.

    Thank you!

    Thanks Antonio.  Just got the email from Cactus, with instructions last night.  Picking up my Cactus gear at B&H this morning!  :)
  • Glenn said:


    Is it okay for me to get the update? I own Fuji X-T2 and Cactus V6ii with two RF60

    Hi Glenn, I see you have already sent us an email. :)
    .
    .
    .
    syrcular said:

    Antonio said:

    Hi @syrcular,

    Here it is:
    http://www.cactus-image.com/community/discussion/1005/fujifilm-x-t2-compatibility-with-cactus-v6-ii-to-support-hss/p1

    You need to send an email to us and we will send you the instructions.

    Thank you!

    Thanks Antonio.  Just got the email from Cactus, with instructions last night.  Picking up my Cactus gear at B&H this morning!  :)
    Fantastic!
    Let us know how it is working for you.

    FYI we've been collecting various buy reports I think we are nearly ready. But don't hesitate to share any problems you encounter.

    Thank you in advance!
    Antonio Lao
    Brand Manager
    _____________

    To help us better help you, always state the exact firmware version installed on your Cactus device(s), such as: "1.1.013", "FUJ.1.002", "v.103".

    For the time being, Cactus V6 (MK1) running on firmware version 2.1.001 can be triggered by a V6 II (MK2) running on Multi-brand HSS firmware (e.g. 1.1.013) and not by X-TTL firmware versions: PEN.A.001 and OLY.A.001.  No schedule has been released yet. 

    Cactus RF60X / RF60 Firmware versions A01 and A02 currently ONLY works with PEN.A.001 and OLY.A.001.  Other "A" version of X-TTL firmware will be released soon. For both Multi-brand HSS and X-TTL firmware versions (FUJ, SIG, SON), install firmware version 103 / 205 on your RF60X / RF60.

    Cactus RF60 is now an off-camera TTL flash with firmware version 205 or later!

    Metz M400 (for Fujifilm) is now supported on the Cactus V6 II (HSS and TTL).

    Nikon D750 users please read this thread: 

    Fujifilm EF-X500 users please read this thread:

    Feel free to suggest an improvement or share product ideas. Contact us directly at info@cactus-image.com.  At Cactus, we listen. 
  • Thanks! I do have one question. I'm using a Mac to update the firmware and found the directions hard to follow. I tried looking for the .cactus directory but didn't find it. Alternatively, what I did was right click on the Updater application and selected show package info and went into the Resources directory and copied over the beta firmware and replaced the current firmware by renaming the beta the same name as the current firmware and it looked like it flashed my unit however is there a way to confirm I have the right firmware on my V6 II?
  • I was able to use the unit past 1/1000 of a second with my RF60 triggered from the V6II so I assume it upgraded ok? But I'd like to see if I could confirm in some way if possible. Thanks!
  • I'm interested in the Beta software as well (that allows the units to work with the X-Pro2 running the latest firmware). I've sent an email as instructed but have not received any response.

    Thank,

    Kurt
  • syrcular said:

    I was able to use the unit past 1/1000 of a second with my RF60 triggered from the V6II so I assume it upgraded ok? But I'd like to see if I could confirm in some way if possible. Thanks!

    Hold the A and D buttons while you switch on the V6 II.
    You will see the firmware version displayed on the LCD.
    Antonio Lao
    Brand Manager
    _____________

    To help us better help you, always state the exact firmware version installed on your Cactus device(s), such as: "1.1.013", "FUJ.1.002", "v.103".

    For the time being, Cactus V6 (MK1) running on firmware version 2.1.001 can be triggered by a V6 II (MK2) running on Multi-brand HSS firmware (e.g. 1.1.013) and not by X-TTL firmware versions: PEN.A.001 and OLY.A.001.  No schedule has been released yet. 

    Cactus RF60X / RF60 Firmware versions A01 and A02 currently ONLY works with PEN.A.001 and OLY.A.001.  Other "A" version of X-TTL firmware will be released soon. For both Multi-brand HSS and X-TTL firmware versions (FUJ, SIG, SON), install firmware version 103 / 205 on your RF60X / RF60.

    Cactus RF60 is now an off-camera TTL flash with firmware version 205 or later!

    Metz M400 (for Fujifilm) is now supported on the Cactus V6 II (HSS and TTL).

    Nikon D750 users please read this thread: 

    Fujifilm EF-X500 users please read this thread:

    Feel free to suggest an improvement or share product ideas. Contact us directly at info@cactus-image.com.  At Cactus, we listen. 
  • tr4driver said:

    I'm interested in the Beta software as well (that allows the units to work with the X-Pro2 running the latest firmware). I've sent an email as instructed but have not received any response.

    Thank,

    Kurt
    Hi Kurt,

    You've got it now, right?

    Thanks!
    Antonio Lao
    Brand Manager
    _____________

    To help us better help you, always state the exact firmware version installed on your Cactus device(s), such as: "1.1.013", "FUJ.1.002", "v.103".

    For the time being, Cactus V6 (MK1) running on firmware version 2.1.001 can be triggered by a V6 II (MK2) running on Multi-brand HSS firmware (e.g. 1.1.013) and not by X-TTL firmware versions: PEN.A.001 and OLY.A.001.  No schedule has been released yet. 

    Cactus RF60X / RF60 Firmware versions A01 and A02 currently ONLY works with PEN.A.001 and OLY.A.001.  Other "A" version of X-TTL firmware will be released soon. For both Multi-brand HSS and X-TTL firmware versions (FUJ, SIG, SON), install firmware version 103 / 205 on your RF60X / RF60.

    Cactus RF60 is now an off-camera TTL flash with firmware version 205 or later!

    Metz M400 (for Fujifilm) is now supported on the Cactus V6 II (HSS and TTL).

    Nikon D750 users please read this thread: 

    Fujifilm EF-X500 users please read this thread:

    Feel free to suggest an improvement or share product ideas. Contact us directly at info@cactus-image.com.  At Cactus, we listen. 
  • Yes. I was able to download it and update the firmware. Unfortunately, I'm having the same problem that I've had on and off with the units. They simply will not consistently recognize my X-Pro2. Now they have pretty much quit functioning altogether.  I have tried everything I can think of and have read on this forum, including removal of the hotshoe spring. Nothing works. Now When I switch on the TX unit mounted to my X-Pro2, it comes up with the empty camera icon. In this state, it will only fire the flash at low power (regardless as to what I have set the power to on the unit). On the rare occasion that it does come up with the "F" in the icon, it will not fire the flash at all. The flash I'm using is a Nikon SB700, and it functions perfectly when mounted to the X-Pro2 directly (in manual mode). They have become completely useless. I had them working for a couple of days fairly consistently a month or so ago by removing the spring in the hotshoe, but now that no longer works. Any additional ideas or suggestions would be greatly appreciated. I really, really want them to work.

    Thanks,

    Kurt
  • Hi Kurt,
    tr4driver said:

    ...  Now When I switch on the TX unit mounted to my X-Pro2, it comes up with the empty camera icon. In this state, it will only fire the flash at low power (regardless as to what I have set the power to on the unit).
    Hmm.. maybe we need to get an X-Pro2 as we only have the X-Pro1 right now in the studio.

    As for the little "F" camera icon, if auto-detect can't get a hold of the camera, there's no point in taking a shot, it simply won't work.

    So I am shocked to hear when you said...
    tr4driver said:

    ...On the rare occasion that it does come up with the "F" in the icon, it will not fire the flash at all.
    But when you said:
    tr4driver said:

    .... I had them working for a couple of days fairly consistently a month or so ago by removing the spring in the hotshoe, but now that no longer works.

    Were you running an older firmware on your X-Pro2 then?

    Thanks!
    Antonio Lao
    Brand Manager
    _____________

    To help us better help you, always state the exact firmware version installed on your Cactus device(s), such as: "1.1.013", "FUJ.1.002", "v.103".

    For the time being, Cactus V6 (MK1) running on firmware version 2.1.001 can be triggered by a V6 II (MK2) running on Multi-brand HSS firmware (e.g. 1.1.013) and not by X-TTL firmware versions: PEN.A.001 and OLY.A.001.  No schedule has been released yet. 

    Cactus RF60X / RF60 Firmware versions A01 and A02 currently ONLY works with PEN.A.001 and OLY.A.001.  Other "A" version of X-TTL firmware will be released soon. For both Multi-brand HSS and X-TTL firmware versions (FUJ, SIG, SON), install firmware version 103 / 205 on your RF60X / RF60.

    Cactus RF60 is now an off-camera TTL flash with firmware version 205 or later!

    Metz M400 (for Fujifilm) is now supported on the Cactus V6 II (HSS and TTL).

    Nikon D750 users please read this thread: 

    Fujifilm EF-X500 users please read this thread:

    Feel free to suggest an improvement or share product ideas. Contact us directly at info@cactus-image.com.  At Cactus, we listen. 
  • Antonio,

    When the units were working, I was using the old X-Pro2 firmware, and had the spring clip removed from the hot shoe.  Last night when I narrowed the problem down to what I think is only one of the units, I was having consistent success with the spring clip in place in the hot shoe.

    Regarding the behavior of the flash not firing when the "F" was displayed in the icon, I did have a similar experience early on with the old firmware after first acquiring the units.  In that case, I would sometimes have the "F" in the icon, but the shutter wouldn't release at all.  What I experienced recently was different.  The shutter would release, and the light on both the TX and RX units would blink green (indicating that they were communicating); however, the flash would not fire.  I have not been able to repeat this issue since isolating the problem to one of the units as mentioned in my message in the "Problems" forum.  I'll try to do some further testing this evening.

    I'm wondering is this isn't some kind of physical alignment issue between the X-Pro2 and the V6 II.

    Thanks,

    Kurt

  • Thanks Kurt, I just replied your message here.
    Antonio Lao
    Brand Manager
    _____________

    To help us better help you, always state the exact firmware version installed on your Cactus device(s), such as: "1.1.013", "FUJ.1.002", "v.103".

    For the time being, Cactus V6 (MK1) running on firmware version 2.1.001 can be triggered by a V6 II (MK2) running on Multi-brand HSS firmware (e.g. 1.1.013) and not by X-TTL firmware versions: PEN.A.001 and OLY.A.001.  No schedule has been released yet. 

    Cactus RF60X / RF60 Firmware versions A01 and A02 currently ONLY works with PEN.A.001 and OLY.A.001.  Other "A" version of X-TTL firmware will be released soon. For both Multi-brand HSS and X-TTL firmware versions (FUJ, SIG, SON), install firmware version 103 / 205 on your RF60X / RF60.

    Cactus RF60 is now an off-camera TTL flash with firmware version 205 or later!

    Metz M400 (for Fujifilm) is now supported on the Cactus V6 II (HSS and TTL).

    Nikon D750 users please read this thread: 

    Fujifilm EF-X500 users please read this thread:

    Feel free to suggest an improvement or share product ideas. Contact us directly at info@cactus-image.com.  At Cactus, we listen. 
Sign In or Register to comment.