Group sequence function don't works with fw version 2.04

Hi, i use a V6 (fw version 1.1.019) on camera and trigger at least 1 RF60 in a group of flashes. With FW version 1.42 the group sequence function is working and the RF60 fires. After update to version 2.04 the RF60 don't fire. If i downgrade to version 1.42 it works again.

Thank you in advance


  • Hello Christian,

    Since you are using the V6, you should stick to firmware 1.42 on your RF60.


    Thank you.
    Antonio Lao
    Brand Manager

    To help us better help you, always state the exact firmware version installed on your Cactus device(s), such as: "1.1.013", "NIK.A.001", "v.103", or "A06".

    TTL or HSS not working on Cactus V6 II and V6 IIs? Be sure to check hot shoe connectivity by doing the <CAMERA INFO> check.

    Feel free to suggest an improvement or share product ideas. Contact us directly at  At Cactus, we listen. 
  • Hi Antonio,

    it is not realy a problem. I have only to take care to don't mix the environment v6 to v6 with fw 1.42 on the RF60 and v6 ii to v6 ii with fw 2.04 on the RF60's.

    We see different download pages, my one is without remarks.

    Thank you

    RF60.jpg 287.6K
  • The new V6 firmware is ready to download. After upgrading, the V6 will be compatible with V6 II for remote power control, flash trigger , group sequence and all other existing V6 functions. 

    Ray Chan

    Senior Product Specialist
    Harvest One Limited
  • Hi Ray,

    i tested the group sequence on a Pentax 645z, V6 ii (fw V1.1.004) on camera; A: RF60 (fw 2.04); B: V6 (fw 2.1.001) with SB900 and C: V6 (fw 2.1.001) with Youngnuo 560 III as a manual flash. It worke'd correct in the chosen sequence A-B-C-D.

    2'nd test, changing the camera to a Fuji X100T worked.

    3'rd test HSS with the 645z and the RF60 worked thrue shutter speed 1/4000 (highest on the 645z).

    Thank you, i'm so happy that every thing which i need is working.
Sign In or Register to comment.