V6 II with Off Camera R6 stuck in TTL Flash mode with Fujifilm X-T2

Hi all,

I'm new to this setup, so pardon if this has been covered before.  I currently have a Cactus V6 II trigger with a Cactus RF60 Off camera flash. I've loaded the beta firmware that allows it to work with HSS, and I'm able to confirm that it works, however, I noticed that the X-T2 whenever I have the V6 II mounted, only gives me TTL or Off modes for flash. If I don't need HSS, and I'm in the studio, how do I switch to manual mode with this setup? Thoughts, and advice would greatly appreciated! Thanks!

Comments

  • Hello @syrcular
    ...If I don't need HSS, and I'm in the studio, how do I switch to manual mode with this setup?
    Well, for Fujifilm, you need to manually switch ON and OFF the Forced HSS function on the V6 II - by pushing in the Adjustment Dial on the V6 II.
    .
    .
    .

    ...I noticed that the X-T2 whenever I have the V6 II mounted, only gives me TTL or Off modes for flash.
    By this, are you referring to the "TTL" icon showing on camera's LCD?

    That is showing when the camera detected a Fujifilm system flash device mounted on its hot shoe, which the V6 II tricked it to be one.

    But this has nothing to do with TTL itself, nor are there any TTL being transmitted wireless.

    Hope this helps!
    Antonio Lao
    Brand Manager
    _____________

    To help us better help you, always state the exact firmware version installed on your Cactus device(s), such as: "1.1.013", "NIK.A.001", "v.103", or "A06".

    TTL or HSS not working on Cactus V6 II and V6 IIs? Be sure to check hot shoe connectivity by doing the <CAMERA INFO> check.

    Feel free to suggest an improvement or share product ideas. Contact us directly at info@cactus-image.com.  At Cactus, we listen. 
  • Thanks Antonio!  That explains it clearly!  Much appreciated.....
  • No problem! :)
    Antonio Lao
    Brand Manager
    _____________

    To help us better help you, always state the exact firmware version installed on your Cactus device(s), such as: "1.1.013", "NIK.A.001", "v.103", or "A06".

    TTL or HSS not working on Cactus V6 II and V6 IIs? Be sure to check hot shoe connectivity by doing the <CAMERA INFO> check.

    Feel free to suggest an improvement or share product ideas. Contact us directly at info@cactus-image.com.  At Cactus, we listen. 
Sign In or Register to comment.