V6 II, i40 and Fuji XT-2 Xpro2 after firmware updates

I need a bit of help please with Cactus V6II, Nissan i40 and XT-2 or Xpro2 please. Just invested in 3 Cactus triggers for some TTL (with i40) and in manual using my Nikon flashes. 

When I fire the i40 in TTL pass through or manual using the Fuji cameras, it is a very weak flash (almost like a trigger).


I have updated both camera and triggers in the last few days. I can fire the Nikon Flash from both Fujis ... so it would appear to be an issue with i40. Both TX and RX are set to Fujifilm, i40 

I have Nikon SB910 and D4s - the triggers work for both manual flash and TTL. The i40 works fine when on camera. I also  seem to be ok with the Nikon flashes in manual and TTL (from D4s), so convinced the triggers ok. 

Triggers set to A  and channel 1. Trigger on camera set to TX and flash set to RX. Set RX to be for Fuji Flash and i40. The same for the TX. When I try and use either TTL or manual from either Fuji cameras I get a flash triggered, but absolutely no power - it is as if it was set up as COMMAND mode (which it is not in the camera menus.) Has me somewhat flummoxed! Any help gratefully received (even if it makes me look silly ;-)).

Comments

  • So figured this out in the end ....

    • There is no TTL off camera only manual (this is for i40), I knew the Nikons were manual only.
    • You need to remove the plate - which is way once you have found a suitable instrument (dental flosser tooth pick)
    • Using the AUTo mode is quicker
    • The order is VERY important (I know there is a lot written down on this, but a lot of the issues I had we're over multiple notes, so missed the significance). Last to switch on is the trigger.
    Now I need to figure out how to use the i40 in manual mode off camera. It still seems to act as a "commander" mode.
  • Hey @pduce

    We now got our hands on an X-Pro2 and will look into compatibility with the i40.

    Hopefully we will have a fix soon.

    Thank you!
    Antonio Lao
    Brand Manager
    _____________

    To help us better help you, always state the exact firmware version installed on your Cactus device(s), such as: "1.1.013", "FUJ.1.002", "NIK.A.001", "v.103".

    For the time being, Cactus V6 (MK1) running on firmware version 2.1.001 can be triggered by a V6 II (MK2) running on Multi-brand HSS firmware (e.g. 1.1.013) but not by X-TTL firmware versions:  PEN.A.001 NIK.A.001 OLY.A.001.  No schedule has been released yet for an "A" version firmware on the V6 (MK1). 

    Cactus RF60X / RF60 Firmware versions A04 and A03 currently ONLY works with PEN.A.001 NIK.A.001 and OLY.A.001.  Other "A" version of X-TTL firmware will be released soon. For both Multi-brand HSS and X-TTL firmware versions (FUJ, SIG, SON), install firmware version 103 / 205 on your RF60X / RF60.

    Nikon D750 users please read this thread: 

    Fujifilm EF-X500 users please read this thread:

    Feel free to suggest an improvement or share product ideas. Contact us directly at info@cactus-image.com.  At Cactus, we listen. 
  • Thanks Antonio ;-)
Sign In or Register to comment.