New Cactus user. Fuji Cameras will not fire Flash, but Nikon camera will.

I have updated my V6 II to the latest software and believe I understand how to set up the groups and channels.  My Nikon SB-910 fires when the Cactus Tx and Rx units are used with my Nikon D810.  I bought these for use with my Fuji XT-2 and X-Pro2 cameras.  TX unit seems to recognize a Fuji Camera, and RX unit seems to recognize the the SB-910 flash.  I can hit the test fire button on the front of the camera and the flash fires.  I also see the green light on the RX unit when I press the shutter button, but it doesn't fire.  The TX unit seems to control the power and zoom of the flash.  The flash is set in TTL Mode.

One thing I do not see is an N in the display of the TX unit for the Nikon flash.  I have removed the spring from the X-T2 to make sure I have good contact with the trigger.  I have made sure I don't have my camera on continuous mode, electronic shutter or silent mode and it will fire my flash when connected directly to the hotshoe.  However, when I hold down the menu button to engage the TTL passthrough with the Nissin i40a mounted on the TX unit on top of the camera, it does not fire.

I am out of ideas.  What am I missing?  If I can't get this going quickly, I may have to move in another direction.  Thanks.

Comments

  • Hello @mjhedge
    ...TX unit seems to recognize a Fuji Camera,...
    This needs to be a positive yes before you carry forward with the setup procedures.

    I would recommend this check:
    1. Has the hot shoe metal spring plate been removed from your Fujifilm cameras?
    2. Did
      the V6 II auto-detect the camera as Fujifilm by half-pressing* the
      camera shutter button while switching the V6 II to TX mode?  Make sure
      to securely mount the V6 II on the camera hot shoe.
    3. Try re-doing the LEARN HSS process in case it actually failed in recording the timing on the first run.
    4. Before shooting above camera's x-sync speed (1/250s on the X-T2), manually switch ON Forced HSS by pushing the Adjustment Dial.
    5. Similarily, before shooting at or below camera's x-sync speed (1/250s on the X-T2), manually switch OFF Forced HSS by again pushing the Adjustment Dial.
    6. Make sure both the V6 II are running on the firmware version 1.1.006.


    * Tips on half-pressing on Fujifilm cameras and getting the V6 II to auto-detect it > try triple-clicking the shutter button instead of just half-press and hold positiion. The camera sends signal to the hot shoe when you release the button, and that's how V6 II receive the signal and recognize it as a Fujifilm.

    Steps 4 and 5 are especially important too.

    You have to do manually turn on / off Forced HSS because it is not a function native on the Fujifilm camera.  This is the case, not until we complete the study of the EF-X500.  But even so, some older camera models won't be compatible witht he X500 for HSS, such as the X-Pro1.
    ...One thing I do not see is an N in the display of the TX unit for the Nikon flash....  However, when I hold down the menu button to engage the TTL passthrough with the Nissin i40a mounted on the TX unit on top of the camera, it does not fire.


    You simply cannot TTL Pass Through a Nikon flash mounted on a Fujifilm camera.

    With a non-Fujifilm flash mounted on the V6 II TX on a Fujiflm, you can only manually control its power and zoom, because Fujifilm TTL sent to the hot shoe cannot be understood by the Nikon flash.  Despite the V6 II is sandwiched in between, in only passes the data up. 

    In other words you can only do TTL Pass Through when you are using your Nikon camera.

    Also to keep in mind, if you are using autto-detect (default setting) always power on the flash first, set it TTL, and then switch on the V6 II to TX / RX.

    Thanks!
    Antonio Lao
    Brand Manager
    _____________

    To help us better help you, always state the exact firmware version installed on your Cactus device(s), such as: "1.1.013", "FUJ.1.002", "NIK.A.001", "v.103".

    Nikon D750 users please read this thread: 

    Fujifilm EF-X500 users please read this thread:

    Feel free to suggest an improvement or share product ideas. Contact us directly at info@cactus-image.com.  At Cactus, we listen. 
  • Antonio.  

    Maybe I shouldn't have said "seems" in my comments about recognizing the camera.  It definitely pops up with an F and recognizes the fujiI am not trying to use HSS at all and HSS is OFF.  Both RX and TX units successfully updated to firmware 1.1.006 before I even tried to use them.  As I said in my post I have already removed the metal spring plate.  I also did the auto-detect as described in 2. above.  I have mounted and remounted it in the camera to try to make sure it is secure.

    When I am turning it on now, it has an F for  the flash showing on the transmitter even though I have the Nikon mounted to the receiving unit, which the receiving unit properly recognizes.

    In regards to the TTL pass through, I believe you misunderstood what I was saying.  I was utiliizing the Nissin i40 Fujifilm version when trying to mount it on top of the transmitter unit on the camera.

    I have also tried the power on sequence you recommended. with no luck.

    As I said, it worked perfectly when mounted to my Nikon camera.  I also get a green light that flashes on the receiving unit when I press the shutter button, but no flash.  I have also tried changing the work range to short as suggested in some of the posts I have seen here.


  • Thanks for your clarification.

    You may have have previously selected the flash system / flash profile.

    Do a factory reset and follow the same setup procedure again and see if you are able to sync the i40 (for Fujifilm)?
    Antonio Lao
    Brand Manager
    _____________

    To help us better help you, always state the exact firmware version installed on your Cactus device(s), such as: "1.1.013", "FUJ.1.002", "NIK.A.001", "v.103".

    Nikon D750 users please read this thread: 

    Fujifilm EF-X500 users please read this thread:

    Feel free to suggest an improvement or share product ideas. Contact us directly at info@cactus-image.com.  At Cactus, we listen. 
  • Antonio,

    After almost giving up, I went back and did a reset.  When I loaded the firmware updating software, and ran it, it apparently loaded 1.1.003 and not the most recent version.  I downloaded the current version and now believe it have it working.  Thanks for your help.
  • Ah-Ha!

    Glad to hear you picked up the cause. Good job on the troubleshooting!

    Let us know anytime should you require further assistance.

    Cheers!
    Antonio Lao
    Brand Manager
    _____________

    To help us better help you, always state the exact firmware version installed on your Cactus device(s), such as: "1.1.013", "FUJ.1.002", "NIK.A.001", "v.103".

    Nikon D750 users please read this thread: 

    Fujifilm EF-X500 users please read this thread:

    Feel free to suggest an improvement or share product ideas. Contact us directly at info@cactus-image.com.  At Cactus, we listen. 
Sign In or Register to comment.