Cactus VII does not work reliably with Pentax 645Z and Pentax flashes

I've now had a chance to test the new Cactus V6 II with my Pentax 645Z and Pentax flashes (AF-540FGZ and AF-360FGZ). I've set up both TX and RX as outlined in the manual. The Pentax Flash profile for the AF-540FGZ results in repeated flash bursts after the initial exposure. The most serious problem is that the power settings do not reliably control the flash output. When taking multiple shots with the same settings, the flash output will remain consistent for about 4-8 shots then the flash will fire at maximum output without notice. This occurs with both flashes, and whether the flash profile is set to the specific flash or the auto setting. Also, This is more likely to happen when changing power levels from the TX module attached to the camera. Unless I'm making a terrible mistake setting these units up, I've concluded that the V6 II does not work reliably with my equipment. I look forward to comments about possible solutions...


  • Hello Pasto,

    I am using the 645z as well with two AF540FGZ II's.

    I have them working well and have not seen any power issues. The only time I have a pre-flash issue is if I try to use a wireless remote with a 3 second delay.

    I have the TX set to Pentax camera and Pentax flash. Auto detect by turning on camera first, then cactus to TX.

    I have the flash units set to Pentax flash but use the AUTO instead of the 540 profile. I also let them auto detect by turing on flash and then cactus unit.

    Have you tried just getting one flash to work at a time? Maybe try to get the 540 working alone to see if that works?
    Also, I have read about setting the units to low "work range" if they are very close. Have you tried that? I and on long work range and the two flashes are about 7-10 feet away from camera and I have no issues.

    Mine were all firmware version 005. Are all your firmware versions the same on all cactus units? If not, you can download the firmware updater to get them all to the same version. It is very easy to do.

    I hope you get your setup working...

    Happy New Year to you!

  • Thanks for your input Phred. I use the same procedure as you do. When you mentioned the firmware, I checked and had 003. I ran the updater and downloaded 006, It now works perfectly!

    Happy new year to you as well.
  • ... I ran the updater and downloaded 006, It now works perfectly!

    Happy new year to you as well.
    Great news!  Thanks for the update @pasto.

    Also thanks @Phred for chiming in.
    Antonio Lao
    Brand Manager

    To help us better help you, always state the exact firmware version installed on your Cactus device(s), such as: "1.1.013", "NIK.A.001", "v.103", or "A06".

    TTL or HSS not working on Cactus V6 II and V6 IIs? Be sure to check hot shoe connectivity by doing the <CAMERA INFO> check.

    Feel free to suggest an improvement or share product ideas. Contact us directly at  At Cactus, we listen. 
Sign In or Register to comment.