TTL pass through on X-T1 not working


Yesterday I received three V6 Transceivers. First everything worked great on my X-T1, also TTL pass through. I used as test an SB-900 and SB-28DX from Nikon off camera and put the EF-X8 Flash from Fuji in TTL pass through mode on the tranceiver which was on the camera. After a few tests I couldn get it running again. First I thought I modified something in the X-T1 menu which caused the problem, but this isn't the case so far I can see. The EF-X8 is not firing anymore. When I take away the transceiver and put the flash on the cameras hotshot it works directly. Back, so same adjustments with transceiver, it will not fire and the camera is also not detecting the flash on the hotshot which is displayed on the display normally.
FYI: settings on the X-T1 are AF-S, single shot and 1/180, flash set to on the menu.
I hope someone can help, otherwise I have to send them back. TTL pass through was one of the main reasons to buy them.




  • I forgot something - I think, the problem comes from the multi hot shoe and the pins which are not in use on the V6, damaging the color on the X-T1's hotshoe, that there is contact to something between the V6 and the X-T1 (the upper right pin, on the X-T1 the hotshoe is rounded because there is normally no pin and the part is made of black painted metal. Now, the black color is gone, scratched by the V6).
    Could that be?
  • edited October 2014
    After searching for possible reasons, i found this here:
    That would mean with the additional power contact on the hotshoe of the X-T1 for EF-X8 the flash never fired? Because the V6 doesn't have this additional power contact. I'm pretty sure it fired. When not, this could be the reason. Stupid that i have no other Fuji flash till yet to try it.
    Can someone confirm my thoughts?
  • Thank you for contacting us.

    When a Fuji flash mounts on the V6 Tx unit on the camera to use TTL pass-through, I would suggest to set the flash profile to MANUAL FLASH in the V6 Tx unit. FYI, for example, choosing a Nikon / Canon / Pentax profile to work with a Fiji flash in TTL passthrough mode could cause unintended triggering.

    Maybe you can update the V6 latest firmware. Please click below link to download the updater,

    To check your current V6 firmware ver, turn off the V6, press and hold A + D button then switch it to either TX or RX mode. The version will be shown on the display.

    By th way, I'm sorry to hear about the scratch. Especially, the black paint is easy to be rubbed off.
  • Hi Ray Chan,

    does the choosen profile impact the pass through flash? However, it is not a problem to set the TX V6 to manuel flash. The profiles i only have to set on the RX V6, right?
    I hope the other Fuji flashes i can fire with TTL on the TX in pass through mode. The bigger ones won't have the extra power pin.
    Otherwise i'm very happy with the product, great Trigger!

    Kind regards,


  • does the choosen profile impact the pass through flash?
    Yes for Canon latest camera model. Maybe it applies to other brands too. 

    However, it is not a problem to set the TX V6 to manuel flash. The profiles i only have to set on the RX V6, right?
    It's possible to set flash profile for the Tx unit. Please select the correct profile and try again. 
  • Ray Chan,

    the Fuji flash i have currently, is not working on the V6 as TX in pass trough mode. The Flash i have is the EF-X8 which belongs to the scope of delivery of the Fuji X-T1. This is s small flash which has an extra pin for Power (the flash itsself has no batteries). This pin is not supported by the V6 - so maybe you have to put this flash on your list of not supported flashes.

  • Hi Torben
    You are correct. The EF-X8 has extra pins that do not exist in other Fuji flashes. So, the V6 doesn't support it.

    Thank you for the information.


  • edited November 2014
    Dear Cactus Team,

    I have to edit my comment!!!!
    I`m not a fan of reading manuals but this time I´m happy I did!
    TTL path through mode is not activated by default, you have to activate it by holding the menu button 2 sekonds!

    Fuji XT-1 with EF-42 works well!!!

    Best regards
  • Hello Tobias

    Excellent! I'm happy to hear the TTL pass-through works with FujiXT-1 and EF-42.

    All the best.
  • edited December 2014
    Hi Ray Chan, today i received the new Nissin i40 Flash for Fuji. I activated TTL passthrough on the V6, set the profile to manual, but nothing is happening. Without V6 the flash works well in TTL on the X-T1. When i set the flash to M, it is fired in passthrough on the V6/camera. 
    Can you help?

    Kind regards,

  • I just happened to have i40 for Fuji and Fuji X100 on hand to test. I didn't find any problem using V6 TTL pass-through mode when the i40 is set to TTL mode. The V6 flash profile was set to MANUAL FLASH also.

    Have you got a chance to try another speedlite or camera?

    I look forward to hearing you.

    All the best.
  • Ray Chan, i put it on my Nikon D700 with the SB-900 and it directly worked witout changing anything on the V6. So there Must be a differente between the X-T1 and the X100.
  • So i spend some time now and tried it with several adjustments in the X-T1 but it is not working. Also the flash goes into stand by mode while using the camera. I hope this can be solved with an firmware upgrade of the V6, because of this function i bought the triggers. 


  • Do you have a chance to test it with a X-T1?

  • Hi,

    I also bought a Nissin i40 (for Fuji) flash two days ago, and I can confirm that it will NOT fire, together with the Fuji X-T1 and the Cactus V6 in TTL pass-through mode. The flash is on the TX unit ON the camera of course.

    X-T1 and Cactus V6: latest firmware (V6 upgraded yesterday)
    V6 TX: profile: Manual Flash and TTL pass-through mode (no channel on the display)

    Fuji X-T1 with Nissin i40:

    i40 on M: i40 flashes (V6 in pass-through mode)
    i40 on A or TTL: NO flash (this has been tested by me on TWO V6 devices)

    X-T1 with Fuji EF-20 flash:

    EF-20 flashes BUT all pictures are overexposed, regardless of the flash exposure compensation set on the X-T1.

    Nissin i40 and Fuji EF-20 directly on camera: no problem

    I hope Cactus will find a solution soon, as the Fuji camera does NOT trigger the PC sync connector when there is a TTL flash in the flash shoe.

    The Fuji X-T1 will get a firmware upgrade on 18 December.


     The Netherlands
  • Thank you Marcel, not nice but nice to hear that you have same problem.
    Then looking forward that the problem gets solved soon by an firmware upgrade and that it is not impossible due to physical connections inside the V6.


  • edited December 2014
    That is not possible to use TTL pass-through with Fuji X-T1 due to the limitation of the hardware design. The X-T1 has one extra pin on the hotshoe (see attachment) than other Fuji camera. Because the V6 doesn't have the connection pin, it is not possible to get it solved through the firmware upgrade.

    Hope that helps.
  • That means not only the Nissin i40 will not work in TTL pass through on the X-T1/ V6, all other ones also? For me this was the only reason to buy the V6 and now i have three of them. :-(
  • Ray Chan, the i40 is not using this new pin on the X-T1 because there is no connection pin in the i40 for that. So TTL must be possible without using it because without the V6 the i40 is working great on the X-T1.
    The i40 has the same hotshoe/ pin layout as the X100. So when you have both available you should see that on the i40 is no pin for the new connector on the X-T1. 
  • Hello Torbo
    Noted that the i40 doesn't use the new pin on the X-T1. I guess the X-T1 may have different way to handle the operation for controlling flashes. Unfortunately, I don't have the X-T1 to test the TTL pass-through, so I can't tell what happen with other flashes.
  • Ray Chan,
    do you plan to work on this issue in the near future or this issue done for you now? When the connector is not in use, it normally can be corrected via firmware of the V6, or? 
  • edited December 2014
    We certainly want to find out the reason for solution. I don't know whether it can be corrected via firmware update because it may involve hardware design.
  • If this problem is consistent for all X-T1 users, this is VERY upsetting.  I bought the V6 specifically to use TTL pass through.

    I will be testing out the X-T1 with TTL pass-through on the Fuji EF-42
    tonight and will report my results here.  If TTL pass through doesn't
    work with the X-T1, this is a BIG problem.  I specifically purchased
    over $400 work of cactus equipment (2V6s and 2RF60s) so I could use TTL
    pass through for events and weddings.

    Note: I tested it out the V-6 on my X-E2 and TTL pass through worked great with the X-E2 and Fuji EF-42 flash. 

  • i successfully tested the v6 TTL pass through with my x-T1 and fuji EF 42 tonight. it works just fine!

    i cant imagine why the nissin flash wouldnt work as well. i did notice that the v6 is a little tricky to slide into the xt1 hotshoe, it is a tight fit, and you have to make sure it slides all the way with a little "click" into the fuji hotshoe. If i didnt get it in far enough, ttl would not work. i wonder if some of the nissin users are simply having problems getting the v6 properly seated into the hotshoe. It was finicky for me until i got the hang of it.
  • Also could not get the Nissan i40 to work in TTL pass through with v6 on top of fuji xt1. The flash itself worked fine TTL by itself on the camera.
  • It seems there are more users which are not very happy with this issue. There is a note also on Fujirumors: So we hope that this issue is getting solved soon!
  • The Fuji XT-1 wiith Fui EF-42 and Cactus V6 works like a charme.

    But first I was really frustrated because I didn't realised that you have to activate that path through mode in the menu of the V6 because it's not set by factory default to work.
    Could this be the same problem on your side?

    The extra pin on the XT-1 is to power the litte ef-8 flash which is delivered together with the XT-1.
  • Ray Chan,

    any news on the issue? Is there a chance that it will be solved in the future?


  • Hi Torben
    I just send you a email. Please check.

    Thank you.
  • Hello again,

    Sorry but I CANNOT get the Fuji Xt1 with V6 on top to do pass thru TTL using the Fuji EF-42 flash.

    Others above seem to have no problem.

    I have the flash in TTL and the V6 passthrough TTL symbol activated, and using manual flash mode.


    thank you

Sign In or Register to comment.