Problem updating the firmware

Dear Sir,
I am facing this big problem while I am trying to update my Cactus V6II trigger. I have 2 of them so i tried to update them with the new software so they can work with my Fujifilm XT-2. I updated the first one without any problem . When i tried to update the second one it appears an icon telling me that there is problem updating the device. The worst think is that this device can NOT  open any more, does do nothing at all!!! So i can not reset it to the original settings. I work on a iMac , i 've tried several times to update it but nothing. What should i do ??
Thank you!!!


  • Hello @georgev, I am sorry to let you know the unit that cannot power on sound like is having an issue with the circuit board. Please contact the dealer you bought from and get a replacement.

    Thank you for your understanding.
    Antonio Lao
    Brand Manager

    To help us better help you, always state the exact firmware version installed on your Cactus device(s), such as: "1.1.013", "NIK.A.001", "v.103", or "A06".

    TTL or HSS not working on Cactus V6 II and V6 IIs? Be sure to check hot shoe connectivity by doing the <CAMERA INFO> check.

    Feel free to suggest an improvement or share product ideas. Contact us directly at  At Cactus, we listen. 
Sign In or Register to comment.