Olympus Flash FL-50R can't be set in TTL mode when attached to a Cactus V6 II receiver

edited December 2016 in V6 II Compatibility
Hello,
It seems I have an issue with my Olympus Flashes FL-50R (3 flashes) when I attached to Cactus receiver V6 II.

None of my flashes can be set to TTL mode once attached to receiver,any other modes are available on my flash menu such as Auto, Manual, Slave, RC and  etc,,,, but they can't be set to TTL Mode.

As soon as I detach my flash from receiver and  put it on my Olympus camera hot shoe (OM-D-EM-5 MK!!) the TTL becomes available in the menu.

I am following the instructions as per Cactus recommends in the user's manual  and so far  no luck. Am I missing  any parts of the steps during the set up?

I have to  mention here  that my flash and my camera are detected by Cactus TX  and  The receivers are capable of auto detecting the flash system of my attached flashes.

Can someone help me to find out a way to set my Flashes in TTL Mode once they are attached to receiver?
Here is my list of gear and camera used.

1)- Olympus OM-D E-M5 MK2
2)- 3 Flash Olympus FL-50R
3)- 4 Cactus V6 II ( one transmitter and 3 receivers).

Thanks for any helps.

Alex.G

Comments

  • Hi Alex,

    First check, are your V6 II already running on 1.1.006? Just to make sure we are on the same page.  You can check the firmware version under: Menu > Preference > Firmware.

    Before the FL-50R detects an Olympus camera or hot shoe device that's sending Olympus you won't get the TTL option when pressing the Mode button on the flash.  Try this:
    1. Switch on the FL-50R
    2. Set the flash to AUTO mode
    3. Switch on the V6 II to RX, it will auto-detect it as Olympus
    4. Change the mode from AUTO to TTL AUTO. You will also see the FP icon.

    Let us know if you can repeat the above steps.


    Thanks!

    Antonio Lao
    Brand Manager
    _____________

    To help us better help you, always state the exact firmware version installed on your Cactus device(s), such as: "1.1.013", "NIK.A.001", "v.103", or "A06".

    TTL or HSS not working on Cactus V6 II and V6 IIs? Be sure to check hot shoe connectivity by doing the <CAMERA INFO> check.

    Feel free to suggest an improvement or share product ideas. Contact us directly at info@cactus-image.com.  At Cactus, we listen. 
  • edited December 2016
    Hi Antonio,

    Thanks a lot for the advice. Yesssss,,,  they are all now working in TTL Mode with no issue.

    in fact what I was missing in my set up, I was not setting my flashes in Auto mode and I was constantly  trying to Set them in TTL mode manually once attached to the Receiver.

    Thanks again. :-)

    However I noticed something that I am not sure if this is normal or not. my flashes set and remain  in TTL mode even when I increase my shutter speed on my camera and I set my transmitter to "NORMAL HSS".  Usuaally  when I use a higher shutter speed (higher than 1/250S) my flash should  get switched to FP TTL Auto.
    I am shooting at 1/4000s or higher, my flashes are properly triggered with the correct amount of light. However on the flash display I still see "TTL Auto" and not "FP TTL Auto" . Is this normal? 

    Alex.G


  • Hi Alex,

    Glad to hear you got it working.

    And yes, it's normal because technically camera settings are not transferred wirelessly to the flash, if it did then the V6 II would be a TTL trigger already.  But with HSS, you don't necessary need TTL. As long as the flash syncs with the image in both under x-sync and HSS then it's good to go.

    Let us know if you need anything else.
    Antonio Lao
    Brand Manager
    _____________

    To help us better help you, always state the exact firmware version installed on your Cactus device(s), such as: "1.1.013", "NIK.A.001", "v.103", or "A06".

    TTL or HSS not working on Cactus V6 II and V6 IIs? Be sure to check hot shoe connectivity by doing the <CAMERA INFO> check.

    Feel free to suggest an improvement or share product ideas. Contact us directly at info@cactus-image.com.  At Cactus, we listen. 
Sign In or Register to comment.