Fuji X-T20 with V6II and Nissin Di866 Mark II

Hello all,

i try to use Fuji X-T20 with two V6II and Nissin Di866 Mark II (for Canon Camera) in TTL mode.
i first updated my new V6II to latest Fuji FW: Fuj.1.002 and attach them to the X-T20 (switch on by half pressing shutter button) / Nissin Di866 MII

On RX V6II i choose the Canon Nissin Di866 II. But i can´t shoot in TTL Mode. I have tried in Auto or TTL Mode of Nissin Flash. If i shoot the Nissin flashes but in photo the flash ins´t seeable.

Also a regulation of flash power don´t work proper. On the both V6II i can regulate the flash power, but this dont work on Nissin Flash.

Can you help me on this topic? In Compatibility List the Canon Nissin Di866II is listed.

Thanks and best regards,
Chris

Comments

  • Hi Chris,

    Sounds like a hot shoe connection issue. Try removing the metal spring plate from camera's hot shoe.



    And for the Nissin flash, for testing purposes, you can just use the auto-detected AUTO flash profile. You should see a "C" in the flash icon on the V6 II RX unit. Always use TTL mode on the flash and switch on the flash first before the V6 II.

    Hope this helps!
    Antonio Lao
    Brand Manager
    _____________

    To help us better help you, always state the exact firmware version installed on your Cactus device(s), such as: "1.1.013", "NIK.A.001", "v.103", or "A06".

    TTL or HSS not working on Cactus V6 II and V6 IIs? Be sure to check hot shoe connectivity by doing the <CAMERA INFO> check.

    Feel free to suggest an improvement or share product ideas. Contact us directly at info@cactus-image.com.  At Cactus, we listen. 
  • Hi Antonio,

    Thanks for your answer. I have now removed the metal spring plate from camera's hot shoe.
    Same issue as before: Flash in TTL mode, switched on before the V6 II. In RX V6II i see Auto TTL and "C" Flash. In TX V6II after switch on i see "F" Cam and two times "TTL". 
    The Flash fires but in shoot photo the light isn´t seen. For testing i used 1/80 sec.

    What preferences has to be choosed in booth V6II units?

    I have a further question about the compatibility list: How is it to reed? Is the Nissin Di 866 MkII (in Canon version) compatible to Fuji X-T20? Or are only theese Flashes compatible to Fuji System: Nissin i40, i601, M400?
    --> what row is the right one to look for my components? The "Canon E-TTL / E-TTL II HSS" as i used Flashes for Canon System or "Fujifilm TTL" as i use Fuji Camera? If Fuji it is clear that it don´t work as i use a Nissin (Canon) Flash.

    Best regards,
    Chris
  • Hi Antonio,

    i tried also with Sigma EF-500 DG Super (in Canon variant) with X-T20. The Flash also work in TTL Mode but not every time. Somtimes flash isn´t synchron with cam - that means in photo light isn´t seen, sometimes too much light (white picture), sometimes correct lightning.

    Best regards,
    Chris
  • Hi Chris,

    Whenever a flash is not in sync, most likely there's a hot shoe connection issue, where the V6 II TX is not communicating with the camera, not seeing it as a Fujifilm camera, and it's not getting the timing information.

    Do make sure the transmitter is securely mounted on camera hot shoe.  Make sure it is not rotated during use and the rear two pins may not be correctly aligned. 

    There's a masking tape cushion trick.  Please refer to this post:

    If a flash model is listed, it is compatible. So the Nissin Di866ii is compatible. 

    Thank you.

    Antonio Lao
    Brand Manager
    _____________

    To help us better help you, always state the exact firmware version installed on your Cactus device(s), such as: "1.1.013", "NIK.A.001", "v.103", or "A06".

    TTL or HSS not working on Cactus V6 II and V6 IIs? Be sure to check hot shoe connectivity by doing the <CAMERA INFO> check.

    Feel free to suggest an improvement or share product ideas. Contact us directly at info@cactus-image.com.  At Cactus, we listen. 
  • Hi Antonio,

    i checked: v6ii don´t is rotated during use. At TTL mode in this test session i only got 1 shot with flash on photo, all other shots are without light at photo (but flash flashes) --> i don´t touch v6ii while this test.

    in M mode flash is synchron to capturing photo of cam.

    Which menu preferences i should have to use for correct work?

    BR,
    Chris
  • Hi Antonio,

    i´m also in contact with Nick from ishootyou (you know, i think), he try also to help me and give cactus support. The interaction of Fuji X-T20, V6ii, Nissin Di866 Mark II (for Canon Camera) or Sigma EF500DG Super (also for Canon Camera) we don´t got to work.

    Do you really think the Nissin Flash have to work?

    Therefore i try a RF60x Flash with also problems. (i also updated RF60x to latest FW from beginning of november)

    Wireless:
    Short is choosen, Chanel,
    RadID, Group is identcal at V6ii und RF60x.
    RF60x don´t fire, only when it is directly on a 2nd V6ii the RF60x will fire.
    RF60x don´t triger in Master
    Mode other V6ii. It seems no wireless connection works.between RF60x and V6ii´s.

    RF60x andV6ii direct on Fuji X-T20:
    Cam is switched to TTL Mode.
    TTL Passthrough isn´t able to choos at V6ii "Systems do noch
    match" --> is this a normal message because at use of V6ii with Nissin 866ii i don´t get this message.
    At usage direct on Cam all photos are totally overlighted, also at 1/128 or 1/Lo adjustment at Flash.
    Change of Flash power only works directly on Flash unit, not on V6ii or on Fuji Cam.

    What preferences do you prefer in theese menu:
    Delay, Relay,
    Flash System, Flash Mode?

    Best regards and sorry for too much questions,
    Christoph

  • Hi Christoph,

    Your gear should work with the V6 II. And thanks for contacting our Ambassador Nick Schreger. 

    First of all, make sure all of your Cactus gear is running on the correct firmware version.

    Cactus V6 II:    version FUJ.1.002
    Cactus RF60X:  version 103

    Then, run a Factory Reset on all your V6 II units before attempting any further tests.


    Setup Procedure on RX (Off-camera flash units)
    1. Mount portable flash on V6 II's hot shoe
    2. Switch on portable flash
    3. Set flash mode to E-TTL
    4. Switch on HSS mode on portable flash
    5. Switch V6 II to RX mode
    6. The default auto-detect will identify the correct flash system (i.e. Canon) and apply an AUTO flash profile  (i.e. AUTO CANON)
    Use this setup procedure for both your portable flash units.


    Setup Procedure for TX
    1. Switch on camera
    2. Set shooting mode to M (for testing purposes)
    3. Mount V6 II on camera hot shoe securely by pushing it all the way into the hot shoe and lock it
    4. Switch V6 II to TX mode and the default auto-detect will identify whether the camera supports HSS or not  (if the camera does not support HSS, you will find the menu option of <LEARN HSS>. Since your X-T20 supports HSS, you should not see such a menu item. If you see <LEARN HSS> that means there's a hot shoe connection issue.  In either case the letter F will be shown inside the camera icon)
    5. To test whether there's a good connection between the camera and the V6 II transmitter, adjust camera ISO, lens zoom or aperture values and check if numbers are updated on V6 II's display. If numbers do not pop up that means there's a hot shoe alignment issue.


    ... Do you really think the Nissin Flash have to work?


    Yes, we are sure it works (Di866 Mark II). We have one in the studio and have always tested it.
    .
    .
    .

    ...  Therefore i try a RF60x Flash with also problems. (i also updated RF60x to latest FW from beginning of november)


    Make sure you did not install the latest version with a prefix "A", i.e. version A01.  Currently this version only works with Pentax X-TTL firmware and will not work with any other X-TTL firmware.

    We will release a new firmware soon (version FUJ.A.001) for Fujifilm, and it will also work with RF60X running on A01 firmware.
    .
    .
    .


    ... TTL Passthrough isn´t able to choos at V6ii "Systems do noch
    match" --> is this a normal message because at use of V6ii with Nissin 866ii i don´t get this message.
    For your X-T20, TTL Pass Through only works when you have a compatible TTL flash, for example, with a manual flash like the RF60X (it only has a single hot shoe pin) and the V6 II sees the RF60X as a manual flash so the V6 II cannot "pass through" the signal from camera to a non-TTL device like the RF60X. 

    The RF60X is only a TTL flash off-camera, in Slave (S) mode when triggered by a Cactus V6 II (TX). 


    I hope the above helps.  Thank you and keep us posted on how you get on.
    Antonio Lao
    Brand Manager
    _____________

    To help us better help you, always state the exact firmware version installed on your Cactus device(s), such as: "1.1.013", "NIK.A.001", "v.103", or "A06".

    TTL or HSS not working on Cactus V6 II and V6 IIs? Be sure to check hot shoe connectivity by doing the <CAMERA INFO> check.

    Feel free to suggest an improvement or share product ideas. Contact us directly at info@cactus-image.com.  At Cactus, we listen. 
  • Thanks
    for your Answer, Antonio.



    I have done step by step your procedure.
    RF60X FW
    changed to version 103

    V6II FW
    was correct, done factory reset.
    All
    tests are done at 1/60 sec (on f1/2,8)

    Note: before this actions all time in TX V6II numbers
    are updated on V6 II's display by changing ISO, … on Cam.

     

    First
    I have tested the RF60x on and off the (RX) V6II:

    The RF60x
    fires synchrony to Camera. I can manually correct power to +5, but 0 and -5 are
    the same light in final photo. This is in booth tests on the V6II and off the
    V6II (as Slave S). I have changed power on TX V6II. Power is also then
    displayed in Slave RF60x (e.g. TTL -17 for -1,7).

    (If I change
    power directly on Camera X-T20, in TX V6II or on Slave RF60x no change is
    displayed and also no change in light power will occur – I think this is a
    normal behave)

     

    Second
    I have tested the RF60x on V6II on Cam X-T20 (Cam -> V6II -> RF60x)

    In this
    operating mode also only at Slave Mode of RF60x the power is changeable into +,
    not into - (0 and -5 are the same light in final photo). In all other Modes of
    Flash (L and M) no power is changeable.

     

     

    Third,
    test Nissin 866II on RX V6II (blue TTL icon):

    Global: Then I will test my Nissin 866II. I initiated
    with this procedure:

    Mounting  Nissin 866II on V6II's hot shoe, Switch on
    portable flash, Set flash mode to E-TTL (blue TTL icon) and switch V6 II to RX
    mode

    Note: Switch on HSS mode on Nissin 866II not done
    due to no separate HSS mode on Flash is available. I do the test in TTL mode
    with enabled and disabled HSS, same outcome:

     

    After switch
    V6 II to RX mode Canon Flash was detected, in V6II´s display is “Auto TTL”
    shown.

    Now the
    Nissin 866II fires synchrony to Camera. Power change is comparable to Cactus
    Flash: the power is changeable into +, not into - (0 and -5 are the same light
    in final photo).

    A manual
    change of zoom angle is possible due to change selection dial on TX unit and then
    866II on RX will change.

     

    Fourth,
    test Nissin 866II on RX V6II (green Auto icon):

    Same as
    upper in TTL mode of Flash: the power is changeable into +, not into -, a manual
    change of zoom angle works

     

    Conclusion:

    Now
    flashes (RF60x and 866II) fires synchrony to X-T20, I think the factory reset
    works to got this outcome.

    A manual
    power change only works into positive shift, not into negative shift. Do you
    have information about this?

     

    Best
    regards,
    Christoph

  • Thanks Christoph,

    I have reported to R&D and will get back to you ASAP.

    Did you try manual power control, adjusting from full power 1/1 down to 1/128 or even 1/256, was that okay? 

    So it could be that the problem is only with + / - in TTL mode.

    Thank you.
    Antonio Lao
    Brand Manager
    _____________

    To help us better help you, always state the exact firmware version installed on your Cactus device(s), such as: "1.1.013", "NIK.A.001", "v.103", or "A06".

    TTL or HSS not working on Cactus V6 II and V6 IIs? Be sure to check hot shoe connectivity by doing the <CAMERA INFO> check.

    Feel free to suggest an improvement or share product ideas. Contact us directly at info@cactus-image.com.  At Cactus, we listen. 
  • fuxfux
    edited November 2017
    Hi Antonio,

    i now tried manual power control, this works. But after switch back to TTL mode the 866II fires not synchrony to X-T20 again.
    After second factory reset (1st yesterday, 2nd today) TTL works synchrony (without power control to - ). Then tried manual power again and switch again into TTL mode --> not synchrony.
    After third factory reset TTL and manual power control works. This means also TTL + and - works! And a switch to manual mode and back to TTL mode also don´t affect synchrony since third factory reset.
    Can this be a firmware compatibility issue? I don´t change anything in between of 2nd and 3rd factory reset.

    What also don´t work is 
    866II on V6II on Cam X-T20 (Cam -> V6II -> 866II). In this mode i can´t adjust the power of flash. +/- 5 don´t affect the light output. Which preferences i should try to can use flash on cam?

    Also my Sigma EF-500 DG Super don´t work. This flash is also listed. Should it work in my configuration with Fuji X-T20? The flash don´t fire. I tried all flash modes on EF-500.

    Sorry for so much questions :-)

    Best regards,
    Christoph
  • fuxfux
    edited November 2017
    I forgot to report a further phenomenon i seen:
    RX V6II is on "Group" A, TX send on all Groups (A to D) Nissin Flash on RX fires, everything is ok.

    Then change TX to send only on Group A (as there is also RX assigned to A) --> but in this mode RX dont fire Nissin Flash synchrony to Cam.

    If i change back TX to all Groups (A, B, C, D), RX will fire again synchrony.

    I can´t imagine why this take happen in this way.

    Best regards,
    Christoph
  • Hi Christoph,

    Thanks for your updates. I have reported to R&D and will get back to you as soon as I hear back from them.

    Antonio Lao
    Brand Manager
    _____________

    To help us better help you, always state the exact firmware version installed on your Cactus device(s), such as: "1.1.013", "NIK.A.001", "v.103", or "A06".

    TTL or HSS not working on Cactus V6 II and V6 IIs? Be sure to check hot shoe connectivity by doing the <CAMERA INFO> check.

    Feel free to suggest an improvement or share product ideas. Contact us directly at info@cactus-image.com.  At Cactus, we listen. 
  • fuxfux
    edited November 2017
    Hi Antonio,

    is it possible to get your final solution feedback until latest 28th of november?

    Best regards and nice weekend,
    Christoph
  • Hi Antonio,

    is it possible to get your final solution feedback until latest 28th of november?

    Best regards and nice weekend,
    Christoph
    Sorry but we are still running tests on the beta firmware and it won't be available by 28th of November.

    Thank you for your understanding.

    Antonio Lao
    Brand Manager
    _____________

    To help us better help you, always state the exact firmware version installed on your Cactus device(s), such as: "1.1.013", "NIK.A.001", "v.103", or "A06".

    TTL or HSS not working on Cactus V6 II and V6 IIs? Be sure to check hot shoe connectivity by doing the <CAMERA INFO> check.

    Feel free to suggest an improvement or share product ideas. Contact us directly at info@cactus-image.com.  At Cactus, we listen. 
  • Hi Antonio,

    i got a time extension from my dealer, therefore today is not necessary anymore. When do you think to finished beta tests?

    Best regards,
    Christoph


  • Hey Christoph,

    Good to hear that the dealer offer you a time extension from the dealer. Should you encounter with such issues in the future please let us know and we will talk to the dealer directly and "make" them give you an extension. :)

    As for the beta testing, I am now checking with R&D team and hope we can roll out a new firmware ASAP.  And when we do release it, the firmware will run on the new wireless protocol, and it will be called: FUJ.A.001.

    FYI at the moment we are mainly doing beta testing for OLY.A.001 (M43) and it's nearly finished. So from what I observed R&D is a bit stressed out now. Once the OLY version is done (in a week or so), we should get around in final checking the bug fixes we applied to the FUJ firmware.

    Thank you.
    Antonio Lao
    Brand Manager
    _____________

    To help us better help you, always state the exact firmware version installed on your Cactus device(s), such as: "1.1.013", "NIK.A.001", "v.103", or "A06".

    TTL or HSS not working on Cactus V6 II and V6 IIs? Be sure to check hot shoe connectivity by doing the <CAMERA INFO> check.

    Feel free to suggest an improvement or share product ideas. Contact us directly at info@cactus-image.com.  At Cactus, we listen. 
  • Hi Antonio,

    thanks for you support offer due to extension making, if necessary i will came back to you. :)

    Do you have new information about the new FW yet?

    Best regards,
    Christoph
  • Hi Christoph,

    Olympus X-TTL firmware has been released and we are now testing the FUJ.A.001 firmware. So it shouldn't be too long until we release new firmware for Fujifilm, probably in a few weeks.

    Thank you.
    Antonio Lao
    Brand Manager
    _____________

    To help us better help you, always state the exact firmware version installed on your Cactus device(s), such as: "1.1.013", "NIK.A.001", "v.103", or "A06".

    TTL or HSS not working on Cactus V6 II and V6 IIs? Be sure to check hot shoe connectivity by doing the <CAMERA INFO> check.

    Feel free to suggest an improvement or share product ideas. Contact us directly at info@cactus-image.com.  At Cactus, we listen. 
  • Hi Antonio,

    do you have news about the Fuji firmware?

    Best regards,
    Christoph
  • Hi Christoph,

    We are still working on it as some other bugs were reported so we still need to run another round of tests before we can release the new version. 

    Thank you for your patience during this time.

    Cheers!

    Antonio Lao
    Brand Manager
    _____________

    To help us better help you, always state the exact firmware version installed on your Cactus device(s), such as: "1.1.013", "NIK.A.001", "v.103", or "A06".

    TTL or HSS not working on Cactus V6 II and V6 IIs? Be sure to check hot shoe connectivity by doing the <CAMERA INFO> check.

    Feel free to suggest an improvement or share product ideas. Contact us directly at info@cactus-image.com.  At Cactus, we listen. 
  • Hi Antonio,

    do you have an update since the last two month?

    Best regards,
    Christoph
  • Hi @fux

    We are doing final testing of the new FUJ firmware before public release. It should be released real soon.  

    Thank you very much for sticking by!


    Antonio Lao
    Brand Manager
    _____________

    To help us better help you, always state the exact firmware version installed on your Cactus device(s), such as: "1.1.013", "NIK.A.001", "v.103", or "A06".

    TTL or HSS not working on Cactus V6 II and V6 IIs? Be sure to check hot shoe connectivity by doing the <CAMERA INFO> check.

    Feel free to suggest an improvement or share product ideas. Contact us directly at info@cactus-image.com.  At Cactus, we listen. 
  • Hi Antonio,

    my Nissin works well, of course. Thank you for helping.
    Do you have also already information for my second flash, Sigma EF-500 DG Super (in Canon variant)?

    Best regards,
    Christoph
  • @fux Christoph
    Sigma EF-500 for Canon isn't using a complete Canon TTL protocol, said by our engineer. Therefore, it's not possible to get it worked with V6 II.

    All the best,
    Ray Chan

    Senior Product Specialist
     
    Cactus®
    Harvest One Limited
  • Thanks for your information.

    All the best for you, too,
    Christoph
Sign In or Register to comment.