One of two flashes not firing

I own a Pentax K1 and two Pentax 540fgzII flashes. I also own three Cactus V6 transceivers. I am new to the cactus system,must I do think I set things up correctly. One of my flashes fires, and the other does not. The one that does not fire does fire when placed directly on my camera. All of the cactus transceivers have been updated to accommodate these flash models.

What can I try?

Comments

  • What you need to do is selecting a corresponding flash profile for the on-camera 540FGZII, just like what you did for the RX unit. Also make sure the flash is in P-TTL mode. 

    You can also control the on-camera flash power output by holding down the menu button as you scroll the adjustment dial.

    In case you want your on-camera flash to have automatic TTL, you can do that by holding V6's Menu button for 2 seconds, which turns on <TTL PASS THROUGH> and now there is a direct linkage between camera and the flash.

    Let us know if the above helps. Thanks!

    Antonio Lao
    Brand Manager
    _____________

    To help us better help you, always state the exact firmware version installed on your Cactus device(s), such as: "1.1.013", "NIK.A.001", "v.103", or "A06".

    TTL or HSS not working on Cactus V6 II and V6 IIs? Be sure to check hot shoe connectivity by doing the <CAMERA INFO> check.

    Feel free to suggest an improvement or share product ideas. Contact us directly at info@cactus-image.com.  At Cactus, we listen. 
  • Hmmm, I don't think this addresses the issue. I have two off camera flashes. One fires and one doesnt. I would like them both to fire at the same time off camera.
  • The flash that does not fire, what channel is the V6 set to? Make sure all 3 V6 transceivers are running on the same channel.  e.g. set all to channel 12.

    TX:  Channel 12, group A and B switched on

    RX (1/2): Channel 12, group A
    RX (2/2): Channel 12, group B


    Thanks!

    Antonio Lao
    Brand Manager
    _____________

    To help us better help you, always state the exact firmware version installed on your Cactus device(s), such as: "1.1.013", "NIK.A.001", "v.103", or "A06".

    TTL or HSS not working on Cactus V6 II and V6 IIs? Be sure to check hot shoe connectivity by doing the <CAMERA INFO> check.

    Feel free to suggest an improvement or share product ideas. Contact us directly at info@cactus-image.com.  At Cactus, we listen. 
Sign In or Register to comment.