Manual mode not working with Fujifilm X-T3

edited June 5 in V6 II Problems
Hi
I updated my brand new V6 II with FUJ.A.004 firmware. I am unable to set manual mode in camera or on the flash. When I'm trying to do it, they immediately switch back to TTL. I am able to manually control the flash only within the Cactus device itself, but camera and flash still think they're in TTL. That's not how manual mode should work. I should be able to control my flash from it's buttons. Switching flash system to Manual Flash is not a solution as I want to use HSS. Flash brand is Canon(and Canon compatible ones like Yongnuo). Are there any solutions or will I have to return my device?
Thanks in advance for any help :)

Comments

  • The V6 II takes control over the flash that is in TTL mode. You can manually control the flash power through the V6 II by pressing the group button on the V6 II to switch to M mode.

    I hope that helps.
    Ray Chan

    Senior Product Specialist
     
    Cactus®
    Harvest One Limited
  • That's bad. Why would you force the lamp(or other device) into TTL? Is this done to limit usage with other transmitters? I planned to use your transmitter to trigger a Canon TX but it keeps switching to TTL so I don't have any control over groups or anything...
  • The V6 II uses TTL protocol to control the flash. That's why the flash has to be in TTL mode.
    Ray Chan

    Senior Product Specialist
     
    Cactus®
    Harvest One Limited
Sign In or Register to comment.