Relay triggers camera, not RF60

I've got an problem with my V6 units, trying to trigger my GX8 camera, and an RF60. The v6 transmitter is set to relay, the camera receiver is set to relay, and when I press the button on the transmitter, the camera focuses and then fires. so far so good.

The RF60 responds to adjustments, I can see the display update when I adjust it with the V6. But when I trigger the camera the RF60 does not fire. I've tried different groups, I've tried swapping the rx and tx units, to no avail.

Am I doing something wrong?


  • Ah, solved. 

    Relay mode relies on the camera to output a flash signal through the hotshoe.  The GX8 disables the hotshoe entirely when the flash is set to off. 
  • Yes, you figured out the cause of the problem.

    If you don't want to rely on the camera hot-shoe signal, you can trigger both camera and flash with on Tx at the "same" time, using a delay for the flash only.
  • Yup, already worked that out.  67ms delay and all's well.
Sign In or Register to comment.